You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@commons.apache.org by "Zhongxin Yan (Jira)" <ji...@apache.org> on 2025/12/23 14:36:00 UTC

[jira] [Created] (LANG-1808) Redundant test case in CharSetUtilsTest.testDelete_StringStringarray

Zhongxin Yan created LANG-1808:
----------------------------------

             Summary: Redundant test case in CharSetUtilsTest.testDelete_StringStringarray
                 Key: LANG-1808
                 URL: https://issues.apache.org/jira/browse/LANG-1808
             Project: Commons Lang
          Issue Type: Bug
          Components: lang.*
    Affects Versions: 3.20.0
            Reporter: Zhongxin Yan
         Attachments: image-2025-12-23-22-30-47-056.png

The unit test method {{testDelete_StringStringarray()}} in {{CharSetUtilsTest}} contains a *redundant assertion* that serves no functional purpose and reduces test readability/maintainability:



!image-2025-12-23-22-30-47-056.png|width=414,height=305!



--
This message was sent by Atlassian Jira
(v8.20.10#820010)