You are viewing a plain text version of this content. The canonical link for it is here.
Posted to commits@samza.apache.org by "Jakob Homan (JIRA)" <ji...@apache.org> on 2013/11/26 21:00:37 UTC
[jira] [Updated] (SAMZA-44) Change "state topic" phrasing in
KafkaCheckpointManager
[ https://issues.apache.org/jira/browse/SAMZA-44?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]
Jakob Homan updated SAMZA-44:
-----------------------------
Labels: newbie (was: )
> Change "state topic" phrasing in KafkaCheckpointManager
> -------------------------------------------------------
>
> Key: SAMZA-44
> URL: https://issues.apache.org/jira/browse/SAMZA-44
> Project: Samza
> Issue Type: Bug
> Components: kafka
> Affects Versions: 0.6.0
> Reporter: Chris Riccomini
> Labels: newbie
>
> Currently, we refer to stateTopic and "state topic" in KafkaCheckpointManager. For example:
> {code}
> if (offset <= 0) {
> info("Got offset 0 (no messages in state topic) for topic %s and partition %s, so returning null. If you expected the state topic to have messages, you're probably going to lose data." format (stateTopic, partition))
> return null
> }
> {code}
> This is a misleading phrase, and variable name. We should rename all mentions of state topic to checkpoint topic, so it doesn't get confused with ACTUAL state topics (LoggedStores).
--
This message was sent by Atlassian JIRA
(v6.1#6144)