You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@slider.apache.org by Sumit Mohanty <sm...@apache.org> on 2014/09/24 22:07:34 UTC
Renaming default appConfig.json and resources.json files inside the
app package
https://issues.apache.org/jira/browse/SLIDER-450
Some recent feedback pointed out that the inclusion of appConfig.json and
resources.json in the app package is confusing.
The source of confusion is that it is not clear that these included files
in the package are samples. It is also not clear that there is no need not
recreate the application package with modified appConfig.json and
resources.json files.
I propose we still retain the files in the application package as its an
easy way to ship and access defaults. We can rename the files as follows:
appConfig.json --> default_template.json
resources.json --> default_resources.json
I think we can still keep them at the current folder location in the .zip
file.
-Sumit
Re: Renaming default appConfig.json and resources.json files inside
the app package
Posted by Ted Yu <yu...@gmail.com>.
I covered hbase-win already.
Sumit:
Please go ahead with the other components.
Thanks
On Wed, Sep 24, 2014 at 3:37 PM, Sumit Mohanty <su...@gmail.com>
wrote:
> Changes look good. We should make similar changes to hbase-win, memcached,
> memcached-win, and storm as well.
>
> Ted, if you want to only commit the hbase changes now then leave the JIRA
> assigned to me and I can change the other packages.
>
> Billie, will the accumulo functional tests break if we make this change to
> the accumulo package?
>
> -Sumit
>
> On Wed, Sep 24, 2014 at 2:28 PM, Ted Yu <yu...@gmail.com> wrote:
>
> > See if my patch on SLIDER-450 is fine.
> >
> > Cheers
> >
> > On Wed, Sep 24, 2014 at 1:40 PM, Sumit Mohanty <smohanty@hortonworks.com
> >
> > wrote:
> >
> > > We can go for -
> > > appConfig.json --> template-default.json
> > > resources.json --> resources-default.json
> > >
> > > Looking at "template-default" as a name, it seems that
> > > "appConfig-default.json" sounds better (from, Gour)
> > >
> > > -Sumit
> > >
> > > -Sumit
> > >
> > >
> > >
> > > On Wed, Sep 24, 2014 at 1:16 PM, Ted Yu <yu...@gmail.com> wrote:
> > >
> > > > +1 to this idea.
> > > >
> > > > Should these files be named appConfig-default.json and
> > > > resources-default.json
> > > > ?
> > > >
> > > > The following search in hadoop shows files with -default.xml:
> > > > find . -name '*defau*.xml'
> > > >
> > > > Cheers
> > > >
> > > > On Wed, Sep 24, 2014 at 1:07 PM, Sumit Mohanty <sm...@apache.org>
> > > > wrote:
> > > >
> > > > > https://issues.apache.org/jira/browse/SLIDER-450
> > > > >
> > > > > Some recent feedback pointed out that the inclusion of
> appConfig.json
> > > and
> > > > > resources.json in the app package is confusing.
> > > > >
> > > > > The source of confusion is that it is not clear that these included
> > > files
> > > > > in the package are samples. It is also not clear that there is no
> > need
> > > > not
> > > > > recreate the application package with modified appConfig.json and
> > > > > resources.json files.
> > > > >
> > > > > I propose we still retain the files in the application package as
> its
> > > an
> > > > > easy way to ship and access defaults. We can rename the files as
> > > follows:
> > > > >
> > > > > appConfig.json --> default_template.json
> > > > > resources.json --> default_resources.json
> > > > >
> > > > > I think we can still keep them at the current folder location in
> the
> > > .zip
> > > > > file.
> > > > >
> > > > > -Sumit
> > > > >
> > > >
> > >
> > > --
> > > CONFIDENTIALITY NOTICE
> > > NOTICE: This message is intended for the use of the individual or
> entity
> > to
> > > which it is addressed and may contain information that is confidential,
> > > privileged and exempt from disclosure under applicable law. If the
> reader
> > > of this message is not the intended recipient, you are hereby notified
> > that
> > > any printing, copying, dissemination, distribution, disclosure or
> > > forwarding of this communication is strictly prohibited. If you have
> > > received this communication in error, please contact the sender
> > immediately
> > > and delete it from your system. Thank You.
> > >
> >
>
>
>
> --
> thanks
> Sumit
>
Re: Renaming default appConfig.json and resources.json files inside
the app package
Posted by Sumit Mohanty <su...@gmail.com>.
Changes look good. We should make similar changes to hbase-win, memcached,
memcached-win, and storm as well.
Ted, if you want to only commit the hbase changes now then leave the JIRA
assigned to me and I can change the other packages.
Billie, will the accumulo functional tests break if we make this change to
the accumulo package?
-Sumit
On Wed, Sep 24, 2014 at 2:28 PM, Ted Yu <yu...@gmail.com> wrote:
> See if my patch on SLIDER-450 is fine.
>
> Cheers
>
> On Wed, Sep 24, 2014 at 1:40 PM, Sumit Mohanty <sm...@hortonworks.com>
> wrote:
>
> > We can go for -
> > appConfig.json --> template-default.json
> > resources.json --> resources-default.json
> >
> > Looking at "template-default" as a name, it seems that
> > "appConfig-default.json" sounds better (from, Gour)
> >
> > -Sumit
> >
> > -Sumit
> >
> >
> >
> > On Wed, Sep 24, 2014 at 1:16 PM, Ted Yu <yu...@gmail.com> wrote:
> >
> > > +1 to this idea.
> > >
> > > Should these files be named appConfig-default.json and
> > > resources-default.json
> > > ?
> > >
> > > The following search in hadoop shows files with -default.xml:
> > > find . -name '*defau*.xml'
> > >
> > > Cheers
> > >
> > > On Wed, Sep 24, 2014 at 1:07 PM, Sumit Mohanty <sm...@apache.org>
> > > wrote:
> > >
> > > > https://issues.apache.org/jira/browse/SLIDER-450
> > > >
> > > > Some recent feedback pointed out that the inclusion of appConfig.json
> > and
> > > > resources.json in the app package is confusing.
> > > >
> > > > The source of confusion is that it is not clear that these included
> > files
> > > > in the package are samples. It is also not clear that there is no
> need
> > > not
> > > > recreate the application package with modified appConfig.json and
> > > > resources.json files.
> > > >
> > > > I propose we still retain the files in the application package as its
> > an
> > > > easy way to ship and access defaults. We can rename the files as
> > follows:
> > > >
> > > > appConfig.json --> default_template.json
> > > > resources.json --> default_resources.json
> > > >
> > > > I think we can still keep them at the current folder location in the
> > .zip
> > > > file.
> > > >
> > > > -Sumit
> > > >
> > >
> >
> > --
> > CONFIDENTIALITY NOTICE
> > NOTICE: This message is intended for the use of the individual or entity
> to
> > which it is addressed and may contain information that is confidential,
> > privileged and exempt from disclosure under applicable law. If the reader
> > of this message is not the intended recipient, you are hereby notified
> that
> > any printing, copying, dissemination, distribution, disclosure or
> > forwarding of this communication is strictly prohibited. If you have
> > received this communication in error, please contact the sender
> immediately
> > and delete it from your system. Thank You.
> >
>
--
thanks
Sumit
Re: Renaming default appConfig.json and resources.json files inside
the app package
Posted by Ted Yu <yu...@gmail.com>.
See if my patch on SLIDER-450 is fine.
Cheers
On Wed, Sep 24, 2014 at 1:40 PM, Sumit Mohanty <sm...@hortonworks.com>
wrote:
> We can go for -
> appConfig.json --> template-default.json
> resources.json --> resources-default.json
>
> Looking at "template-default" as a name, it seems that
> "appConfig-default.json" sounds better (from, Gour)
>
> -Sumit
>
> -Sumit
>
>
>
> On Wed, Sep 24, 2014 at 1:16 PM, Ted Yu <yu...@gmail.com> wrote:
>
> > +1 to this idea.
> >
> > Should these files be named appConfig-default.json and
> > resources-default.json
> > ?
> >
> > The following search in hadoop shows files with -default.xml:
> > find . -name '*defau*.xml'
> >
> > Cheers
> >
> > On Wed, Sep 24, 2014 at 1:07 PM, Sumit Mohanty <sm...@apache.org>
> > wrote:
> >
> > > https://issues.apache.org/jira/browse/SLIDER-450
> > >
> > > Some recent feedback pointed out that the inclusion of appConfig.json
> and
> > > resources.json in the app package is confusing.
> > >
> > > The source of confusion is that it is not clear that these included
> files
> > > in the package are samples. It is also not clear that there is no need
> > not
> > > recreate the application package with modified appConfig.json and
> > > resources.json files.
> > >
> > > I propose we still retain the files in the application package as its
> an
> > > easy way to ship and access defaults. We can rename the files as
> follows:
> > >
> > > appConfig.json --> default_template.json
> > > resources.json --> default_resources.json
> > >
> > > I think we can still keep them at the current folder location in the
> .zip
> > > file.
> > >
> > > -Sumit
> > >
> >
>
> --
> CONFIDENTIALITY NOTICE
> NOTICE: This message is intended for the use of the individual or entity to
> which it is addressed and may contain information that is confidential,
> privileged and exempt from disclosure under applicable law. If the reader
> of this message is not the intended recipient, you are hereby notified that
> any printing, copying, dissemination, distribution, disclosure or
> forwarding of this communication is strictly prohibited. If you have
> received this communication in error, please contact the sender immediately
> and delete it from your system. Thank You.
>
Re: Renaming default appConfig.json and resources.json files inside
the app package
Posted by Sumit Mohanty <sm...@hortonworks.com>.
We can go for -
appConfig.json --> template-default.json
resources.json --> resources-default.json
Looking at "template-default" as a name, it seems that
"appConfig-default.json" sounds better (from, Gour)
-Sumit
-Sumit
On Wed, Sep 24, 2014 at 1:16 PM, Ted Yu <yu...@gmail.com> wrote:
> +1 to this idea.
>
> Should these files be named appConfig-default.json and
> resources-default.json
> ?
>
> The following search in hadoop shows files with -default.xml:
> find . -name '*defau*.xml'
>
> Cheers
>
> On Wed, Sep 24, 2014 at 1:07 PM, Sumit Mohanty <sm...@apache.org>
> wrote:
>
> > https://issues.apache.org/jira/browse/SLIDER-450
> >
> > Some recent feedback pointed out that the inclusion of appConfig.json and
> > resources.json in the app package is confusing.
> >
> > The source of confusion is that it is not clear that these included files
> > in the package are samples. It is also not clear that there is no need
> not
> > recreate the application package with modified appConfig.json and
> > resources.json files.
> >
> > I propose we still retain the files in the application package as its an
> > easy way to ship and access defaults. We can rename the files as follows:
> >
> > appConfig.json --> default_template.json
> > resources.json --> default_resources.json
> >
> > I think we can still keep them at the current folder location in the .zip
> > file.
> >
> > -Sumit
> >
>
--
CONFIDENTIALITY NOTICE
NOTICE: This message is intended for the use of the individual or entity to
which it is addressed and may contain information that is confidential,
privileged and exempt from disclosure under applicable law. If the reader
of this message is not the intended recipient, you are hereby notified that
any printing, copying, dissemination, distribution, disclosure or
forwarding of this communication is strictly prohibited. If you have
received this communication in error, please contact the sender immediately
and delete it from your system. Thank You.
Re: Renaming default appConfig.json and resources.json files inside
the app package
Posted by Ted Yu <yu...@gmail.com>.
+1 to this idea.
Should these files be named appConfig-default.json and resources-default.json
?
The following search in hadoop shows files with -default.xml:
find . -name '*defau*.xml'
Cheers
On Wed, Sep 24, 2014 at 1:07 PM, Sumit Mohanty <sm...@apache.org> wrote:
> https://issues.apache.org/jira/browse/SLIDER-450
>
> Some recent feedback pointed out that the inclusion of appConfig.json and
> resources.json in the app package is confusing.
>
> The source of confusion is that it is not clear that these included files
> in the package are samples. It is also not clear that there is no need not
> recreate the application package with modified appConfig.json and
> resources.json files.
>
> I propose we still retain the files in the application package as its an
> easy way to ship and access defaults. We can rename the files as follows:
>
> appConfig.json --> default_template.json
> resources.json --> default_resources.json
>
> I think we can still keep them at the current folder location in the .zip
> file.
>
> -Sumit
>