You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@lucene.apache.org by "Yonik Seeley (JIRA)" <ji...@apache.org> on 2012/09/12 17:41:07 UTC

[jira] [Commented] (SOLR-3830) Rename LFUCache to FastLFUCache

    [ https://issues.apache.org/jira/browse/SOLR-3830?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13454067#comment-13454067 ] 

Yonik Seeley commented on SOLR-3830:
------------------------------------

bq. so I'd like to rename it to FastLFUCache.

+1, it hasn't been used in the default solrconfig.xml, so this change shouldn't really affect anyone.

I don't think we should rename the other ones that people are likely to have in their configs already though.  There is a note right next to where one would configure these cases that tries to explain the difference.  We should update that if it's not sufficient.
                
> Rename LFUCache to FastLFUCache
> -------------------------------
>
>                 Key: SOLR-3830
>                 URL: https://issues.apache.org/jira/browse/SOLR-3830
>             Project: Solr
>          Issue Type: Bug
>    Affects Versions: 4.0-BETA
>            Reporter: Adrien Grand
>            Priority: Minor
>
> I find it a little disturbing that LFUCache shares most of its behavior (not strictly bounded size, good at concurrent reads, slow at writes unless eviction is performed in a separate thread) with FastLRUCache while it sounds like it is the LFU equivalent of LRUCache (strictly bounded size, synchronized reads, fast writes) so I'd like to rename it to FastLFUCache.
> Maybe we should also rename these Fast*Cache to Concurrent*Cache so that people don't think that they are better than their non Fast alternatives in every way.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org