You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@hbase.apache.org by "Phil Yang (JIRA)" <ji...@apache.org> on 2016/11/03 09:02:00 UTC
[jira] [Commented] (HBASE-16975) Disable two subtests of
TestSerialReplication
[ https://issues.apache.org/jira/browse/HBASE-16975?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15632128#comment-15632128 ]
Phil Yang commented on HBASE-16975:
-----------------------------------
Thanks.
I think I can take the new issue and naming it "Serial replication should handle daughter regions being assigned to another RS" again? Assign daughter regions to another RS is a good feature, serial replication should support it. I am working for it.
> Disable two subtests of TestSerialReplication
> ---------------------------------------------
>
> Key: HBASE-16975
> URL: https://issues.apache.org/jira/browse/HBASE-16975
> Project: HBase
> Issue Type: Test
> Reporter: Ted Yu
> Assignee: Phil Yang
> Priority: Minor
> Fix For: 2.0.0
>
> Attachments: HBASE-16975-ignore.patch, HBASE-16975-v1.patch
>
>
> As seen in https://builds.apache.org/job/PreCommit-HBASE-Build/4246/artifact/patchprocess/patch-unit-hbase-server.txt :
> {code}
> testRegionMerge(org.apache.hadoop.hbase.replication.TestSerialReplication) Time elapsed: 14.763 sec <<< FAILURE!
> java.lang.AssertionError: null
> at org.junit.Assert.fail(Assert.java:86)
> at org.junit.Assert.assertTrue(Assert.java:41)
> at org.junit.Assert.assertTrue(Assert.java:52)
> at org.apache.hadoop.hbase.replication.TestSerialReplication.assertIntegerList(TestSerialReplication.java:396)
> at org.apache.hadoop.hbase.replication.TestSerialReplication.testRegionMerge(TestSerialReplication.java:326)
> testRegionSplit(org.apache.hadoop.hbase.replication.TestSerialReplication) Time elapsed: 203.88 sec <<< ERROR!
> java.lang.Exception: Not all logs have been pushed
> at org.apache.hadoop.hbase.replication.TestSerialReplication.testRegionSplit(TestSerialReplication.java:264)
> {code}
--
This message was sent by Atlassian JIRA
(v6.3.4#6332)