You are viewing a plain text version of this content. The canonical link for it is here.
Posted to solr-dev@lucene.apache.org by "Otis Gospodnetic (JIRA)" <ji...@apache.org> on 2008/05/22 05:19:55 UTC
[jira] Updated: (SOLR-502) Add search time out support
[ https://issues.apache.org/jira/browse/SOLR-502?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]
Otis Gospodnetic updated SOLR-502:
----------------------------------
Fix Version/s: 1.3
Yes, I think we should get this in 1.3. I left the following comment in SOLR-505, but since this issue includes the patch from SOLR-505, I will assume the patch will be developed further as part of this issue and not SOLR-505.
I took a quick look at the patch and saw this:
{code}rsp.setAvoidHttpCaching(false);{code}
Am I the only one who has a harder time reading negative methods like this, esp. when they take false?
Would it not be nicer to just have:
{code}rsp.setHttpCaching(true/false);{code}
or even
{code}rsp.httpCachingOn() + rsp.httpCachingOff(){code}
Similarly, instead of {code}isAvoidHttpCaching(){code} have {code}isHttpCachingOn(){code}
I know this is "just naming", but I think it helps with readability a bit.
I notice the unit test mods are not in the patch. Is there no need to test the modified behaviour?
> Add search time out support
> ---------------------------
>
> Key: SOLR-502
> URL: https://issues.apache.org/jira/browse/SOLR-502
> Project: Solr
> Issue Type: New Feature
> Components: search
> Reporter: Sean Timm
> Priority: Minor
> Fix For: 1.3
>
> Attachments: SOLR-502-solrj.patch, solrTimeout.patch, solrTimeout.patch, solrTimeout.patch, solrTimeout.patch, solrTimeout.patch
>
>
> Uses LUCENE-997 to add time out support to Solr.
--
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.