You are viewing a plain text version of this content. The canonical link for it is here.
Posted to java-user@lucene.apache.org by Nicola Buso <nb...@ebi.ac.uk> on 2015/06/03 14:44:19 UTC

Lucene 5 field indexed

Hi guys,

just few notes about recent API changes about IndexOptions.NONE and
FieldInfo.isIndexed():
http://issues.apache.org/jira/browse/LUCENE-6013

As a API user do you really think that:

if (fieldInfo.getIndexOptions() != IndexOptions.NONE) { ... }

is better than?

if (fieldInfo.isIndexed()) { ... }

I understand the redundancy in the code, but the API should be as user
friendly as possible :-)

Can you also confirm that the correct expression to check if the field
is indexed is as above and not check != null as proposed initially in
the ticket?


Other thing is this incongruity:

FieldType.indexOptions()

FieldInfo.getIndexOptions()


What about to use the same naming conventions?



Nicola


-- 
Nicola Buso <nb...@ebi.ac.uk>
EMBL-EBI

---------------------------------------------------------------------
To unsubscribe, e-mail: java-user-unsubscribe@lucene.apache.org
For additional commands, e-mail: java-user-help@lucene.apache.org