You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@mahout.apache.org by "Dan Filimon (JIRA)" <ji...@apache.org> on 2013/01/01 21:04:12 UTC

[jira] [Created] (MAHOUT-1135) Unify decorated vectors in DecoratedVector

Dan Filimon created MAHOUT-1135:
-----------------------------------

             Summary: Unify decorated vectors in DecoratedVector<T>
                 Key: MAHOUT-1135
                 URL: https://issues.apache.org/jira/browse/MAHOUT-1135
             Project: Mahout
          Issue Type: Wish
          Components: Math
    Affects Versions: 1.0
            Reporter: Dan Filimon
            Priority: Minor


I'm finding the current Vector classes in Mahout a bit confusing.
The vector implementation are just fine, I'm talking more about the decorated vectors:
WeightedVector
MatrixSlice
NamedVector

I propose using a single DecoratedVector<T> type that can easily be extended.
For example, right now MatrixSlice doesn't even implement the Vector interface.

So,
WeightedVector -> DecoratedVector<Pair<Integer, Double>>
MatrixSlice -> DecoratedVector<Integer>
NamedVector -> DecoratedVector<String>

We could even keep the names (maybe changing MatrixSlice to something like IndexedVector though?) by extending DecoratedVector<T>.

I'd be willing to fix this if people think it's a good idea.
What about it? :)

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira