You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@camel.apache.org by "Babak Vahdat (JIRA)" <ji...@apache.org> on 2013/11/20 03:12:18 UTC

[jira] [Updated] (CAMEL-6985) Clean-up the codebase of the Karaf commands a bit

     [ https://issues.apache.org/jira/browse/CAMEL-6985?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Babak Vahdat updated CAMEL-6985:
--------------------------------

    Description: 
- Better avoid the current code duplication for the {{camelController}} field and it's corresponding setter  by different commands & completers and extract it out into the {{CamelCommand}} & {{CamelCompleter}} abstract base classes.

- As a general rule of thumb always iterate over {{Properties#entrySet()}} instead of {{Properties#keySet()}} which is faster as you skip the lookup step for the given {{Properties}} by each iteration inside the loop (that's better use {{entry#getKey()}} & {{entry#getValue()}} inside the loop instead of {{key}} & {{Properties#getProperty(key)}}).

- After CAMEL-6980 remove the {{CamelController#getRouteDefinitions()}} API and it's implementation by {{CamelControllerImpl}} as there's no usage of it anymore.

- Correct the text alignment of the "Properties" information given by the "route-info" command, that's the {{RouteInfo}} class.

  was:
- Better avoid the current code duplication for the {{camelController}} field and it's corresponding setter  by different commands & completers and extract it out into the {{CamelCommand}} & {{CamelCompleter}} abstract base classes.

- As a general rule of thumb always iterate over {{Properties#entrySet()}} instead of {{Properties#keySet()}} which is faster as you skip the lookup step inside the given {{Map}}/{{Hashtable}} by each iteration inside the loop.

- After CAMEL-6980 remove the {{CamelController#getRouteDefinitions()}} API and it's implementation by {{CamelControllerImpl}} as there's no usage of it anymore.

- Correct the text alignment of the "Properties" information given by the "route-info" command, that's the {{RouteInfo}} class.


> Clean-up the codebase of the Karaf commands a bit
> -------------------------------------------------
>
>                 Key: CAMEL-6985
>                 URL: https://issues.apache.org/jira/browse/CAMEL-6985
>             Project: Camel
>          Issue Type: Task
>          Components: karaf
>    Affects Versions: 2.12.1
>            Reporter: Babak Vahdat
>            Assignee: Babak Vahdat
>            Priority: Minor
>             Fix For: 2.13.0
>
>
> - Better avoid the current code duplication for the {{camelController}} field and it's corresponding setter  by different commands & completers and extract it out into the {{CamelCommand}} & {{CamelCompleter}} abstract base classes.
> - As a general rule of thumb always iterate over {{Properties#entrySet()}} instead of {{Properties#keySet()}} which is faster as you skip the lookup step for the given {{Properties}} by each iteration inside the loop (that's better use {{entry#getKey()}} & {{entry#getValue()}} inside the loop instead of {{key}} & {{Properties#getProperty(key)}}).
> - After CAMEL-6980 remove the {{CamelController#getRouteDefinitions()}} API and it's implementation by {{CamelControllerImpl}} as there's no usage of it anymore.
> - Correct the text alignment of the "Properties" information given by the "route-info" command, that's the {{RouteInfo}} class.



--
This message was sent by Atlassian JIRA
(v6.1#6144)