You are viewing a plain text version of this content. The canonical link for it is here.
Posted to commits@cassandra.apache.org by "Jeff Jirsa (JIRA)" <ji...@apache.org> on 2018/03/02 06:21:00 UTC

[jira] [Commented] (CASSANDRA-14260) Refactor pair to avoid boxing longs/ints

    [ https://issues.apache.org/jira/browse/CASSANDRA-14260?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16383234#comment-16383234 ] 

Jeff Jirsa commented on CASSANDRA-14260:
----------------------------------------

Force pushed, refactored to have specialized inner classes anywhere a Pair was used with primitives. Branch [here|https://github.com/jeffjirsa/cassandra/commits/trunk-pair-refactor] with some fixes. Tests will run [here|https://circleci.com/gh/jeffjirsa/cassandra/tree/trunk-pair-refactor] . 2 commits, one with the main change, and a second to add {{hashCode()}} and {{equals()}}

[~bdeggleston] interested in review ( or [~slebresne] , not sure if you're still up for reviews ). There's at least one or two name changes I'm not thrilled with, so please nit pick the naming, I dont like them, but I'm low on creativity.



> Refactor pair to avoid boxing longs/ints
> ----------------------------------------
>
>                 Key: CASSANDRA-14260
>                 URL: https://issues.apache.org/jira/browse/CASSANDRA-14260
>             Project: Cassandra
>          Issue Type: Improvement
>            Reporter: Jeff Jirsa
>            Assignee: Jeff Jirsa
>            Priority: Minor
>             Fix For: 4.x
>
>
> We uses Pair<X,Y> all over the place, and in many cases either/both of X and Y are primitives (ints, longs), and we end up boxing them into Integers and Longs. We should have specialized versions that take primitives. 



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

---------------------------------------------------------------------
To unsubscribe, e-mail: commits-unsubscribe@cassandra.apache.org
For additional commands, e-mail: commits-help@cassandra.apache.org