You are viewing a plain text version of this content. The canonical link for it is here.
Posted to common-dev@hadoop.apache.org by "Haohui Mai (JIRA)" <ji...@apache.org> on 2013/09/16 21:12:52 UTC

[jira] [Created] (HADOOP-9966) Refactor XDR code into XDRReader and XDRWriter

Haohui Mai created HADOOP-9966:
----------------------------------

             Summary: Refactor XDR code into XDRReader and XDRWriter
                 Key: HADOOP-9966
                 URL: https://issues.apache.org/jira/browse/HADOOP-9966
             Project: Hadoop Common
          Issue Type: Improvement
            Reporter: Haohui Mai
            Assignee: Haohui Mai


Several methods in the current XDR class have ambiguous semantics. For example, Size() returns the actual size of internal byte array. The actual size of current buffer, is also affected by read requests, which pull data out of the buffer.

These ambiguous semantics makes removing redundant copies on the NFS paths difficult.

This JIRA proposes to decompose the responsibilities of XDR into two separate class: XDRReader and XDRWriter. The overall designs should closely follow Java's *Reader / *Writer classes.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira