You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@spark.apache.org by "Sean Owen (JIRA)" <ji...@apache.org> on 2016/02/21 18:20:18 UTC
[jira] [Updated] (SPARK-12799) Simplify various string output for
expressions
[ https://issues.apache.org/jira/browse/SPARK-12799?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]
Sean Owen updated SPARK-12799:
------------------------------
Assignee: Cheng Lian
> Simplify various string output for expressions
> ----------------------------------------------
>
> Key: SPARK-12799
> URL: https://issues.apache.org/jira/browse/SPARK-12799
> Project: Spark
> Issue Type: Sub-task
> Components: SQL
> Reporter: Reynold Xin
> Assignee: Cheng Lian
> Fix For: 2.0.0
>
>
> We currently have "sql", "prettyString", "toString".
> The default implementation of "prettyString" is simply "toString" but replaced the AttributeReferences with PrettyAttributes. I think we can just remove the existing "sql" one, and rename "prettyString" to "sql". We might need to do a little bit cleanup to make the prettyString work.
--
This message was sent by Atlassian JIRA
(v6.3.4#6332)
---------------------------------------------------------------------
To unsubscribe, e-mail: issues-unsubscribe@spark.apache.org
For additional commands, e-mail: issues-help@spark.apache.org