You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@hive.apache.org by "Namit Jain (JIRA)" <ji...@apache.org> on 2012/08/07 08:31:03 UTC

[jira] [Created] (HIVE-3339) Change the rules in SemanticAnalyzer to use Operator.getName() instead of hardcoded names

Namit Jain created HIVE-3339:
--------------------------------

             Summary: Change the rules in SemanticAnalyzer to use Operator.getName() instead of hardcoded names
                 Key: HIVE-3339
                 URL: https://issues.apache.org/jira/browse/HIVE-3339
             Project: Hive
          Issue Type: Bug
            Reporter: Namit Jain
            Priority: Minor


This should be done for code cleanup.

Instead of the rule being:

SEL%

It should say SelectOperator.getName()%

It would make the rules more readable.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

[jira] [Updated] (HIVE-3339) Change the rules in SemanticAnalyzer to use Operator.getName() instead of hardcoded names

Posted by "Zhenxiao Luo (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/HIVE-3339?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Zhenxiao Luo updated HIVE-3339:
-------------------------------

    Attachment: HIVE-3339.2.patch.txt
    
> Change the rules in SemanticAnalyzer to use Operator.getName() instead of hardcoded names
> -----------------------------------------------------------------------------------------
>
>                 Key: HIVE-3339
>                 URL: https://issues.apache.org/jira/browse/HIVE-3339
>             Project: Hive
>          Issue Type: Bug
>            Reporter: Namit Jain
>            Assignee: Zhenxiao Luo
>            Priority: Minor
>         Attachments: HIVE-3339.1.patch.txt, HIVE-3339.2.patch.txt
>
>
> This should be done for code cleanup.
> Instead of the rule being:
> SEL%
> It should say SelectOperator.getName()%
> It would make the rules more readable.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

[jira] [Updated] (HIVE-3339) Change the rules in SemanticAnalyzer to use Operator.getName() instead of hardcoded names

Posted by "Zhenxiao Luo (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/HIVE-3339?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Zhenxiao Luo updated HIVE-3339:
-------------------------------

    Assignee: Zhenxiao Luo
      Status: Patch Available  (was: Open)
    
> Change the rules in SemanticAnalyzer to use Operator.getName() instead of hardcoded names
> -----------------------------------------------------------------------------------------
>
>                 Key: HIVE-3339
>                 URL: https://issues.apache.org/jira/browse/HIVE-3339
>             Project: Hive
>          Issue Type: Bug
>            Reporter: Namit Jain
>            Assignee: Zhenxiao Luo
>            Priority: Minor
>         Attachments: HIVE-3339.1.patch.txt
>
>
> This should be done for code cleanup.
> Instead of the rule being:
> SEL%
> It should say SelectOperator.getName()%
> It would make the rules more readable.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

[jira] [Updated] (HIVE-3339) Change the rules in SemanticAnalyzer to use Operator.getName() instead of hardcoded names

Posted by "Namit Jain (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/HIVE-3339?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Namit Jain updated HIVE-3339:
-----------------------------

      Resolution: Fixed
    Hadoop Flags: Reviewed
          Status: Resolved  (was: Patch Available)

Committed. Thanks Zhenxiao
                
> Change the rules in SemanticAnalyzer to use Operator.getName() instead of hardcoded names
> -----------------------------------------------------------------------------------------
>
>                 Key: HIVE-3339
>                 URL: https://issues.apache.org/jira/browse/HIVE-3339
>             Project: Hive
>          Issue Type: Bug
>            Reporter: Namit Jain
>            Assignee: Zhenxiao Luo
>            Priority: Minor
>         Attachments: HIVE-3339.1.patch.txt, HIVE-3339.2.patch.txt
>
>
> This should be done for code cleanup.
> Instead of the rule being:
> SEL%
> It should say SelectOperator.getName()%
> It would make the rules more readable.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

[jira] [Updated] (HIVE-3339) Change the rules in SemanticAnalyzer to use Operator.getName() instead of hardcoded names

Posted by "Zhenxiao Luo (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/HIVE-3339?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Zhenxiao Luo updated HIVE-3339:
-------------------------------

    Attachment: HIVE-3339.1.patch.txt
    
> Change the rules in SemanticAnalyzer to use Operator.getName() instead of hardcoded names
> -----------------------------------------------------------------------------------------
>
>                 Key: HIVE-3339
>                 URL: https://issues.apache.org/jira/browse/HIVE-3339
>             Project: Hive
>          Issue Type: Bug
>            Reporter: Namit Jain
>            Priority: Minor
>         Attachments: HIVE-3339.1.patch.txt
>
>
> This should be done for code cleanup.
> Instead of the rule being:
> SEL%
> It should say SelectOperator.getName()%
> It would make the rules more readable.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

[jira] [Commented] (HIVE-3339) Change the rules in SemanticAnalyzer to use Operator.getName() instead of hardcoded names

Posted by "Zhenxiao Luo (JIRA)" <ji...@apache.org>.
    [ https://issues.apache.org/jira/browse/HIVE-3339?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13453403#comment-13453403 ] 

Zhenxiao Luo commented on HIVE-3339:
------------------------------------

Review request submitted at:
https://reviews.facebook.net/D5343
                
> Change the rules in SemanticAnalyzer to use Operator.getName() instead of hardcoded names
> -----------------------------------------------------------------------------------------
>
>                 Key: HIVE-3339
>                 URL: https://issues.apache.org/jira/browse/HIVE-3339
>             Project: Hive
>          Issue Type: Bug
>            Reporter: Namit Jain
>            Priority: Minor
>         Attachments: HIVE-3339.1.patch.txt
>
>
> This should be done for code cleanup.
> Instead of the rule being:
> SEL%
> It should say SelectOperator.getName()%
> It would make the rules more readable.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

[jira] [Updated] (HIVE-3339) Change the rules in SemanticAnalyzer to use Operator.getName() instead of hardcoded names

Posted by "Zhenxiao Luo (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/HIVE-3339?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Zhenxiao Luo updated HIVE-3339:
-------------------------------

    Status: Patch Available  (was: Open)
    
> Change the rules in SemanticAnalyzer to use Operator.getName() instead of hardcoded names
> -----------------------------------------------------------------------------------------
>
>                 Key: HIVE-3339
>                 URL: https://issues.apache.org/jira/browse/HIVE-3339
>             Project: Hive
>          Issue Type: Bug
>            Reporter: Namit Jain
>            Assignee: Zhenxiao Luo
>            Priority: Minor
>         Attachments: HIVE-3339.1.patch.txt, HIVE-3339.2.patch.txt
>
>
> This should be done for code cleanup.
> Instead of the rule being:
> SEL%
> It should say SelectOperator.getName()%
> It would make the rules more readable.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

[jira] [Commented] (HIVE-3339) Change the rules in SemanticAnalyzer to use Operator.getName() instead of hardcoded names

Posted by "Namit Jain (JIRA)" <ji...@apache.org>.
    [ https://issues.apache.org/jira/browse/HIVE-3339?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13454620#comment-13454620 ] 

Namit Jain commented on HIVE-3339:
----------------------------------

+1
                
> Change the rules in SemanticAnalyzer to use Operator.getName() instead of hardcoded names
> -----------------------------------------------------------------------------------------
>
>                 Key: HIVE-3339
>                 URL: https://issues.apache.org/jira/browse/HIVE-3339
>             Project: Hive
>          Issue Type: Bug
>            Reporter: Namit Jain
>            Assignee: Zhenxiao Luo
>            Priority: Minor
>         Attachments: HIVE-3339.1.patch.txt, HIVE-3339.2.patch.txt
>
>
> This should be done for code cleanup.
> Instead of the rule being:
> SEL%
> It should say SelectOperator.getName()%
> It would make the rules more readable.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

[jira] [Updated] (HIVE-3339) Change the rules in SemanticAnalyzer to use Operator.getName() instead of hardcoded names

Posted by "Namit Jain (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/HIVE-3339?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Namit Jain updated HIVE-3339:
-----------------------------

    Status: Open  (was: Patch Available)

comments on phabricator
                
> Change the rules in SemanticAnalyzer to use Operator.getName() instead of hardcoded names
> -----------------------------------------------------------------------------------------
>
>                 Key: HIVE-3339
>                 URL: https://issues.apache.org/jira/browse/HIVE-3339
>             Project: Hive
>          Issue Type: Bug
>            Reporter: Namit Jain
>            Assignee: Zhenxiao Luo
>            Priority: Minor
>         Attachments: HIVE-3339.1.patch.txt
>
>
> This should be done for code cleanup.
> Instead of the rule being:
> SEL%
> It should say SelectOperator.getName()%
> It would make the rules more readable.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

[jira] [Commented] (HIVE-3339) Change the rules in SemanticAnalyzer to use Operator.getName() instead of hardcoded names

Posted by "Hudson (JIRA)" <ji...@apache.org>.
    [ https://issues.apache.org/jira/browse/HIVE-3339?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13454813#comment-13454813 ] 

Hudson commented on HIVE-3339:
------------------------------

Integrated in Hive-trunk-h0.21 #1666 (See [https://builds.apache.org/job/Hive-trunk-h0.21/1666/])
    Checked in recursive_dir.q by mistake while committing HIVE-3339 (Revision 1384204)
HIVE-3339 Change the rules in SemanticAnalyzer to use Operator.getName() instead of hardcoded names
(Zhenxiao Luo via namit) (Revision 1384200)

     Result = SUCCESS
namit : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1384204
Files : 
* /hive/trunk/ql/src/test/queries/clientpositive/recursive_dir.q

namit : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1384200
Files : 
* /hive/trunk/ql/src/java/org/apache/hadoop/hive/ql/exec/CommonJoinOperator.java
* /hive/trunk/ql/src/java/org/apache/hadoop/hive/ql/exec/FileSinkOperator.java
* /hive/trunk/ql/src/java/org/apache/hadoop/hive/ql/exec/FilterOperator.java
* /hive/trunk/ql/src/java/org/apache/hadoop/hive/ql/exec/GroupByOperator.java
* /hive/trunk/ql/src/java/org/apache/hadoop/hive/ql/exec/HashTableDummyOperator.java
* /hive/trunk/ql/src/java/org/apache/hadoop/hive/ql/exec/HashTableSinkOperator.java
* /hive/trunk/ql/src/java/org/apache/hadoop/hive/ql/exec/LateralViewForwardOperator.java
* /hive/trunk/ql/src/java/org/apache/hadoop/hive/ql/exec/LateralViewJoinOperator.java
* /hive/trunk/ql/src/java/org/apache/hadoop/hive/ql/exec/LimitOperator.java
* /hive/trunk/ql/src/java/org/apache/hadoop/hive/ql/exec/MapJoinOperator.java
* /hive/trunk/ql/src/java/org/apache/hadoop/hive/ql/exec/MapOperator.java
* /hive/trunk/ql/src/java/org/apache/hadoop/hive/ql/exec/Operator.java
* /hive/trunk/ql/src/java/org/apache/hadoop/hive/ql/exec/ReduceSinkOperator.java
* /hive/trunk/ql/src/java/org/apache/hadoop/hive/ql/exec/SMBMapJoinOperator.java
* /hive/trunk/ql/src/java/org/apache/hadoop/hive/ql/exec/ScriptOperator.java
* /hive/trunk/ql/src/java/org/apache/hadoop/hive/ql/exec/SelectOperator.java
* /hive/trunk/ql/src/java/org/apache/hadoop/hive/ql/exec/TableScanOperator.java
* /hive/trunk/ql/src/java/org/apache/hadoop/hive/ql/exec/UDTFOperator.java
* /hive/trunk/ql/src/java/org/apache/hadoop/hive/ql/exec/UnionOperator.java
* /hive/trunk/ql/src/java/org/apache/hadoop/hive/ql/optimizer/BucketMapJoinOptimizer.java
* /hive/trunk/ql/src/java/org/apache/hadoop/hive/ql/optimizer/ColumnPruner.java
* /hive/trunk/ql/src/java/org/apache/hadoop/hive/ql/optimizer/GroupByOptimizer.java
* /hive/trunk/ql/src/java/org/apache/hadoop/hive/ql/optimizer/MapJoinProcessor.java
* /hive/trunk/ql/src/java/org/apache/hadoop/hive/ql/optimizer/ReduceSinkDeDuplication.java
* /hive/trunk/ql/src/java/org/apache/hadoop/hive/ql/optimizer/SamplePruner.java
* /hive/trunk/ql/src/java/org/apache/hadoop/hive/ql/optimizer/SortedMergeBucketMapJoinOptimizer.java
* /hive/trunk/ql/src/java/org/apache/hadoop/hive/ql/optimizer/index/RewriteCanApplyCtx.java
* /hive/trunk/ql/src/java/org/apache/hadoop/hive/ql/optimizer/index/RewriteQueryUsingAggregateIndexCtx.java
* /hive/trunk/ql/src/java/org/apache/hadoop/hive/ql/optimizer/lineage/Generator.java
* /hive/trunk/ql/src/java/org/apache/hadoop/hive/ql/optimizer/pcr/PartitionConditionRemover.java
* /hive/trunk/ql/src/java/org/apache/hadoop/hive/ql/optimizer/physical/LocalMapJoinProcFactory.java
* /hive/trunk/ql/src/java/org/apache/hadoop/hive/ql/optimizer/physical/MapJoinResolver.java
* /hive/trunk/ql/src/java/org/apache/hadoop/hive/ql/optimizer/physical/MetadataOnlyOptimizer.java
* /hive/trunk/ql/src/java/org/apache/hadoop/hive/ql/optimizer/physical/SkewJoinResolver.java
* /hive/trunk/ql/src/java/org/apache/hadoop/hive/ql/optimizer/physical/index/IndexWhereTaskDispatcher.java
* /hive/trunk/ql/src/java/org/apache/hadoop/hive/ql/optimizer/ppr/PartitionPruner.java
* /hive/trunk/ql/src/java/org/apache/hadoop/hive/ql/optimizer/unionproc/UnionProcessor.java
* /hive/trunk/ql/src/java/org/apache/hadoop/hive/ql/parse/SemanticAnalyzer.java
* /hive/trunk/ql/src/java/org/apache/hadoop/hive/ql/ppd/PredicatePushDown.java
* /hive/trunk/ql/src/test/queries/clientpositive/recursive_dir.q

                
> Change the rules in SemanticAnalyzer to use Operator.getName() instead of hardcoded names
> -----------------------------------------------------------------------------------------
>
>                 Key: HIVE-3339
>                 URL: https://issues.apache.org/jira/browse/HIVE-3339
>             Project: Hive
>          Issue Type: Bug
>            Reporter: Namit Jain
>            Assignee: Zhenxiao Luo
>            Priority: Minor
>         Attachments: HIVE-3339.1.patch.txt, HIVE-3339.2.patch.txt
>
>
> This should be done for code cleanup.
> Instead of the rule being:
> SEL%
> It should say SelectOperator.getName()%
> It would make the rules more readable.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

[jira] [Commented] (HIVE-3339) Change the rules in SemanticAnalyzer to use Operator.getName() instead of hardcoded names

Posted by "Zhenxiao Luo (JIRA)" <ji...@apache.org>.
    [ https://issues.apache.org/jira/browse/HIVE-3339?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13453814#comment-13453814 ] 

Zhenxiao Luo commented on HIVE-3339:
------------------------------------

@Namit:

Thanks a lot for the comments.

I just updated the patch, and review request at:
https://reviews.facebook.net/D5343
                
> Change the rules in SemanticAnalyzer to use Operator.getName() instead of hardcoded names
> -----------------------------------------------------------------------------------------
>
>                 Key: HIVE-3339
>                 URL: https://issues.apache.org/jira/browse/HIVE-3339
>             Project: Hive
>          Issue Type: Bug
>            Reporter: Namit Jain
>            Assignee: Zhenxiao Luo
>            Priority: Minor
>         Attachments: HIVE-3339.1.patch.txt, HIVE-3339.2.patch.txt
>
>
> This should be done for code cleanup.
> Instead of the rule being:
> SEL%
> It should say SelectOperator.getName()%
> It would make the rules more readable.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira