You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@jmeter.apache.org by Philippe Mouawad <ph...@gmail.com> on 2017/04/06 19:44:56 UTC

Rename "request_sent_retry_enabled" to retry_all_methods ?

Hello,
As per discussion "JMeter 3.1 httpclient4.retrycount does not work" on user
mailing list,
do you think we should rename this property ?

Thanks
Regards

Re: Rename "request_sent_retry_enabled" to retry_all_methods ?

Posted by sebb <se...@gmail.com>.
On 7 April 2017 at 17:27, Philippe Mouawad <ph...@gmail.com> wrote:
> On Fri, Apr 7, 2017 at 10:44 AM, sebb <se...@gmail.com> wrote:
>
>> If a user property is renamed, it may break some tests.
>>
> It was introduced only few days ago for tuukka.

OK, in which case it can be renamed or deleted with impunity.

>
>>
>> It is possible to rename, but you need to keep the old name as an
>> alias for at least one revision, and usage of the old alias should
>> generate a warning log message.
>>
>> On 6 April 2017 at 20:44, Philippe Mouawad <ph...@gmail.com>
>> wrote:
>> > Hello,
>> > As per discussion "JMeter 3.1 httpclient4.retrycount does not work" on
>> user
>> > mailing list,
>> > do you think we should rename this property ?
>> >
>> > Thanks
>> > Regards
>>
>
>
>
> --
> Cordialement.
> Philippe Mouawad.

Re: Rename "request_sent_retry_enabled" to retry_all_methods ?

Posted by Philippe Mouawad <ph...@gmail.com>.
On Fri, Apr 7, 2017 at 10:44 AM, sebb <se...@gmail.com> wrote:

> If a user property is renamed, it may break some tests.
>
It was introduced only few days ago for tuukka.


>
> It is possible to rename, but you need to keep the old name as an
> alias for at least one revision, and usage of the old alias should
> generate a warning log message.
>
> On 6 April 2017 at 20:44, Philippe Mouawad <ph...@gmail.com>
> wrote:
> > Hello,
> > As per discussion "JMeter 3.1 httpclient4.retrycount does not work" on
> user
> > mailing list,
> > do you think we should rename this property ?
> >
> > Thanks
> > Regards
>



-- 
Cordialement.
Philippe Mouawad.

Re: Rename "request_sent_retry_enabled" to retry_all_methods ?

Posted by sebb <se...@gmail.com>.
If a user property is renamed, it may break some tests.

It is possible to rename, but you need to keep the old name as an
alias for at least one revision, and usage of the old alias should
generate a warning log message.

On 6 April 2017 at 20:44, Philippe Mouawad <ph...@gmail.com> wrote:
> Hello,
> As per discussion "JMeter 3.1 httpclient4.retrycount does not work" on user
> mailing list,
> do you think we should rename this property ?
>
> Thanks
> Regards