You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@camel.apache.org by "Hadrian Zbarcea (JIRA)" <ji...@apache.org> on 2009/07/10 16:42:33 UTC

[jira] Created: (CAMEL-1822) Cleanup unnecessary copy related methods in Exchange

Cleanup unnecessary copy related methods in Exchange
----------------------------------------------------

                 Key: CAMEL-1822
                 URL: https://issues.apache.org/activemq/browse/CAMEL-1822
             Project: Apache Camel
          Issue Type: Improvement
    Affects Versions: 2.0-M2
            Reporter: Hadrian Zbarcea
            Assignee: Hadrian Zbarcea
             Fix For: 2.0.0


There are currently 4 apis related to copying exchanges that overlap for the most part, are confusing and unnecessary.  The consensus is to replace:

    Exchange newInstance();
    Exchange copy();
    Exchange newCopy(boolean handoverOnCompletion);
    void copyFrom(Exchange source);
with:
    Exchange copy();
    Exchange copy(boolean handoverOnCompletion);

newInstance() does not bring much value,
copyFrom() is semantically equivalent to copy()
newCopy() will be just renamed to copy(boolean) 
 
See nabble thread:
http://www.nabble.com/-DISCUSS--Exchange-copy-api-cleanup-td24400340.html

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


[jira] Issue Comment Edited: (CAMEL-1822) Cleanup unnecessary copy related methods in Exchange

Posted by "Hadrian Zbarcea (JIRA)" <ji...@apache.org>.
    [ https://issues.apache.org/activemq/browse/CAMEL-1822?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=52796#action_52796 ] 

Hadrian Zbarcea edited comment on CAMEL-1822 at 7/31/09 8:34 PM:
-----------------------------------------------------------------

[DONE:r799794] newInstance() does not bring much value,
copyFrom() is semantically equivalent to copy()
[DONE:r792977] newCopy() will be just renamed to copy(boolean)

      was (Author: hadrian):
    newInstance() does not bring much value,
copyFrom() is semantically equivalent to copy()
[DONE:r792977] newCopy() will be just renamed to copy(boolean)
  
> Cleanup unnecessary copy related methods in Exchange
> ----------------------------------------------------
>
>                 Key: CAMEL-1822
>                 URL: https://issues.apache.org/activemq/browse/CAMEL-1822
>             Project: Apache Camel
>          Issue Type: Improvement
>    Affects Versions: 2.0-M2
>            Reporter: Hadrian Zbarcea
>            Assignee: Hadrian Zbarcea
>             Fix For: 2.0.0
>
>
> There are currently 4 apis related to copying exchanges that overlap for the most part, are confusing and unnecessary.  The consensus is to replace:
>     Exchange newInstance();
>     Exchange copy();
>     Exchange newCopy(boolean handoverOnCompletion);
>     void copyFrom(Exchange source);
> with:
>     Exchange copy();
>     Exchange copy(boolean handoverOnCompletion);
> newInstance() does not bring much value,
> copyFrom() is semantically equivalent to copy()
> newCopy() will be just renamed to copy(boolean) 
>  
> See nabble thread:
> http://www.nabble.com/-DISCUSS--Exchange-copy-api-cleanup-td24400340.html

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


[jira] Commented: (CAMEL-1822) Cleanup unnecessary copy related methods in Exchange

Posted by "Hadrian Zbarcea (JIRA)" <ji...@apache.org>.
    [ https://issues.apache.org/activemq/browse/CAMEL-1822?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=52796#action_52796 ] 

Hadrian Zbarcea commented on CAMEL-1822:
----------------------------------------

newInstance() does not bring much value,
copyFrom() is semantically equivalent to copy()
[DONE:r792977] newCopy() will be just renamed to copy(boolean)

> Cleanup unnecessary copy related methods in Exchange
> ----------------------------------------------------
>
>                 Key: CAMEL-1822
>                 URL: https://issues.apache.org/activemq/browse/CAMEL-1822
>             Project: Apache Camel
>          Issue Type: Improvement
>    Affects Versions: 2.0-M2
>            Reporter: Hadrian Zbarcea
>            Assignee: Hadrian Zbarcea
>             Fix For: 2.0.0
>
>
> There are currently 4 apis related to copying exchanges that overlap for the most part, are confusing and unnecessary.  The consensus is to replace:
>     Exchange newInstance();
>     Exchange copy();
>     Exchange newCopy(boolean handoverOnCompletion);
>     void copyFrom(Exchange source);
> with:
>     Exchange copy();
>     Exchange copy(boolean handoverOnCompletion);
> newInstance() does not bring much value,
> copyFrom() is semantically equivalent to copy()
> newCopy() will be just renamed to copy(boolean) 
>  
> See nabble thread:
> http://www.nabble.com/-DISCUSS--Exchange-copy-api-cleanup-td24400340.html

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


[jira] Work started: (CAMEL-1822) Cleanup unnecessary copy related methods in Exchange

Posted by "Hadrian Zbarcea (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/activemq/browse/CAMEL-1822?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Work on CAMEL-1822 started by Hadrian Zbarcea.

> Cleanup unnecessary copy related methods in Exchange
> ----------------------------------------------------
>
>                 Key: CAMEL-1822
>                 URL: https://issues.apache.org/activemq/browse/CAMEL-1822
>             Project: Apache Camel
>          Issue Type: Improvement
>    Affects Versions: 2.0-M2
>            Reporter: Hadrian Zbarcea
>            Assignee: Hadrian Zbarcea
>             Fix For: 2.0.0
>
>
> There are currently 4 apis related to copying exchanges that overlap for the most part, are confusing and unnecessary.  The consensus is to replace:
>     Exchange newInstance();
>     Exchange copy();
>     Exchange newCopy(boolean handoverOnCompletion);
>     void copyFrom(Exchange source);
> with:
>     Exchange copy();
>     Exchange copy(boolean handoverOnCompletion);
> newInstance() does not bring much value,
> copyFrom() is semantically equivalent to copy()
> newCopy() will be just renamed to copy(boolean) 
>  
> See nabble thread:
> http://www.nabble.com/-DISCUSS--Exchange-copy-api-cleanup-td24400340.html

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


[jira] Resolved: (CAMEL-1822) Cleanup unnecessary copy related methods in Exchange

Posted by "Hadrian Zbarcea (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/activemq/browse/CAMEL-1822?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Hadrian Zbarcea resolved CAMEL-1822.
------------------------------------

    Resolution: Fixed

All done, wiki updated.

> Cleanup unnecessary copy related methods in Exchange
> ----------------------------------------------------
>
>                 Key: CAMEL-1822
>                 URL: https://issues.apache.org/activemq/browse/CAMEL-1822
>             Project: Apache Camel
>          Issue Type: Improvement
>    Affects Versions: 2.0-M2
>            Reporter: Hadrian Zbarcea
>            Assignee: Hadrian Zbarcea
>             Fix For: 2.0.0
>
>
> There are currently 4 apis related to copying exchanges that overlap for the most part, are confusing and unnecessary.  The consensus is to replace:
>     Exchange newInstance();
>     Exchange copy();
>     Exchange newCopy(boolean handoverOnCompletion);
>     void copyFrom(Exchange source);
> with:
>     Exchange copy();
>     Exchange copy(boolean handoverOnCompletion);
> newInstance() does not bring much value,
> copyFrom() is semantically equivalent to copy()
> newCopy() will be just renamed to copy(boolean) 
>  
> See nabble thread:
> http://www.nabble.com/-DISCUSS--Exchange-copy-api-cleanup-td24400340.html

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


[jira] Commented: (CAMEL-1822) Cleanup unnecessary copy related methods in Exchange

Posted by "Hadrian Zbarcea (JIRA)" <ji...@apache.org>.
    [ https://issues.apache.org/activemq/browse/CAMEL-1822?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=53420#action_53420 ] 

Hadrian Zbarcea commented on CAMEL-1822:
----------------------------------------

While working on this cleanup, I became more convinced that 
Exchange copy(boolean handoverOnCompletion);

...should be removed from Exchange api. This is not really a different flavor of copy, but it represents modifications required to a related exchange to be used in async messaging.  I will move this method to Exchange helper and rename it to createCorrelatedCopy().  This change won't affect package dependencies.

If there are any objections, please shout. 

> Cleanup unnecessary copy related methods in Exchange
> ----------------------------------------------------
>
>                 Key: CAMEL-1822
>                 URL: https://issues.apache.org/activemq/browse/CAMEL-1822
>             Project: Apache Camel
>          Issue Type: Improvement
>    Affects Versions: 2.0-M2
>            Reporter: Hadrian Zbarcea
>            Assignee: Hadrian Zbarcea
>             Fix For: 2.0.0
>
>
> There are currently 4 apis related to copying exchanges that overlap for the most part, are confusing and unnecessary.  The consensus is to replace:
>     Exchange newInstance();
>     Exchange copy();
>     Exchange newCopy(boolean handoverOnCompletion);
>     void copyFrom(Exchange source);
> with:
>     Exchange copy();
>     Exchange copy(boolean handoverOnCompletion);
> newInstance() does not bring much value,
> copyFrom() is semantically equivalent to copy()
> newCopy() will be just renamed to copy(boolean) 
>  
> See nabble thread:
> http://www.nabble.com/-DISCUSS--Exchange-copy-api-cleanup-td24400340.html

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


[jira] Issue Comment Edited: (CAMEL-1822) Cleanup unnecessary copy related methods in Exchange

Posted by "Hadrian Zbarcea (JIRA)" <ji...@apache.org>.
    [ https://issues.apache.org/activemq/browse/CAMEL-1822?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=53420#action_53420 ] 

Hadrian Zbarcea edited comment on CAMEL-1822 at 8/1/09 7:19 AM:
----------------------------------------------------------------

While working on this cleanup, I became more convinced that 
Exchange copy(boolean handoverOnCompletion);

...should be removed from Exchange api. This is not really a different flavor of copy, but it represents modifications required to a related exchange to be used in async messaging.  I will move this method to ExchangeHelper and rename it to createCorrelatedCopy().  This change won't affect package dependencies.

If there are any objections, please shout. 

      was (Author: hadrian):
    While working on this cleanup, I became more convinced that 
Exchange copy(boolean handoverOnCompletion);

...should be removed from Exchange api. This is not really a different flavor of copy, but it represents modifications required to a related exchange to be used in async messaging.  I will move this method to Exchange helper and rename it to createCorrelatedCopy().  This change won't affect package dependencies.

If there are any objections, please shout. 
  
> Cleanup unnecessary copy related methods in Exchange
> ----------------------------------------------------
>
>                 Key: CAMEL-1822
>                 URL: https://issues.apache.org/activemq/browse/CAMEL-1822
>             Project: Apache Camel
>          Issue Type: Improvement
>    Affects Versions: 2.0-M2
>            Reporter: Hadrian Zbarcea
>            Assignee: Hadrian Zbarcea
>             Fix For: 2.0.0
>
>
> There are currently 4 apis related to copying exchanges that overlap for the most part, are confusing and unnecessary.  The consensus is to replace:
>     Exchange newInstance();
>     Exchange copy();
>     Exchange newCopy(boolean handoverOnCompletion);
>     void copyFrom(Exchange source);
> with:
>     Exchange copy();
>     Exchange copy(boolean handoverOnCompletion);
> newInstance() does not bring much value,
> copyFrom() is semantically equivalent to copy()
> newCopy() will be just renamed to copy(boolean) 
>  
> See nabble thread:
> http://www.nabble.com/-DISCUSS--Exchange-copy-api-cleanup-td24400340.html

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


[jira] Issue Comment Edited: (CAMEL-1822) Cleanup unnecessary copy related methods in Exchange

Posted by "Hadrian Zbarcea (JIRA)" <ji...@apache.org>.
    [ https://issues.apache.org/activemq/browse/CAMEL-1822?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=52796#action_52796 ] 

Hadrian Zbarcea edited comment on CAMEL-1822 at 8/1/09 6:56 AM:
----------------------------------------------------------------

[DONE:r799794] newInstance() does not bring much value,
[DONE:r799863] copyFrom() is semantically equivalent to copy()
[DONE:r792977] newCopy() will be just renamed to copy(boolean)

      was (Author: hadrian):
    [DONE:r799794] newInstance() does not bring much value,
copyFrom() is semantically equivalent to copy()
[DONE:r792977] newCopy() will be just renamed to copy(boolean)
  
> Cleanup unnecessary copy related methods in Exchange
> ----------------------------------------------------
>
>                 Key: CAMEL-1822
>                 URL: https://issues.apache.org/activemq/browse/CAMEL-1822
>             Project: Apache Camel
>          Issue Type: Improvement
>    Affects Versions: 2.0-M2
>            Reporter: Hadrian Zbarcea
>            Assignee: Hadrian Zbarcea
>             Fix For: 2.0.0
>
>
> There are currently 4 apis related to copying exchanges that overlap for the most part, are confusing and unnecessary.  The consensus is to replace:
>     Exchange newInstance();
>     Exchange copy();
>     Exchange newCopy(boolean handoverOnCompletion);
>     void copyFrom(Exchange source);
> with:
>     Exchange copy();
>     Exchange copy(boolean handoverOnCompletion);
> newInstance() does not bring much value,
> copyFrom() is semantically equivalent to copy()
> newCopy() will be just renamed to copy(boolean) 
>  
> See nabble thread:
> http://www.nabble.com/-DISCUSS--Exchange-copy-api-cleanup-td24400340.html

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.