You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@jackrabbit.apache.org by "Christoph Kiehl (JIRA)" <ji...@apache.org> on 2007/08/22 01:48:30 UTC

[jira] Created: (JCR-1073) Add getTotalSize() to QueryResults

Add getTotalSize() to QueryResults
----------------------------------

                 Key: JCR-1073
                 URL: https://issues.apache.org/jira/browse/JCR-1073
             Project: Jackrabbit
          Issue Type: New Feature
          Components: query
            Reporter: Christoph Kiehl
            Assignee: Christoph Kiehl
            Priority: Minor


As discussed in http://www.nabble.com/Total-size-of-a-query-result-and-setLimit%28%29-tf4280909.html#a12185543 a getTotalSize() method should be added to QueryResults.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


[jira] Updated: (JCR-1073) Add getTotalSize() to QueryResults

Posted by "Christoph Kiehl (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/JCR-1073?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Christoph Kiehl updated JCR-1073:
---------------------------------

    Attachment: patch.txt

A first shot how this might look like. I stumbled over QueryResultImpl which is apparently no longer used. Instead LazyQueryResultImpl is used. Can we discard QueryResultImpl and rename LazyQueryResultImpl to QueryResultImpl? We could then just implemented getTotalSize() on QueryResultImpl without the need for a further interface or abstract base class for both QueryResult implementations.

> Add getTotalSize() to QueryResults
> ----------------------------------
>
>                 Key: JCR-1073
>                 URL: https://issues.apache.org/jira/browse/JCR-1073
>             Project: Jackrabbit
>          Issue Type: New Feature
>          Components: query
>            Reporter: Christoph Kiehl
>            Assignee: Christoph Kiehl
>            Priority: Minor
>         Attachments: patch.txt
>
>
> As discussed in http://www.nabble.com/Total-size-of-a-query-result-and-setLimit%28%29-tf4280909.html#a12185543 a getTotalSize() method should be added to QueryResults.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


[jira] Commented: (JCR-1073) Add getTotalSize() to QueryResults

Posted by "Christoph Kiehl (JIRA)" <ji...@apache.org>.
    [ https://issues.apache.org/jira/browse/JCR-1073?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#action_12522428 ] 

Christoph Kiehl commented on JCR-1073:
--------------------------------------

WDYT about removing QueryResultImpl from jackrabbit and you just add it to your particular project? Is that an option? Seems to be a quite customized installation anyway.

> Add getTotalSize() to QueryResults
> ----------------------------------
>
>                 Key: JCR-1073
>                 URL: https://issues.apache.org/jira/browse/JCR-1073
>             Project: Jackrabbit
>          Issue Type: New Feature
>          Components: query
>            Reporter: Christoph Kiehl
>            Assignee: Christoph Kiehl
>            Priority: Minor
>         Attachments: patch.txt
>
>
> As discussed in http://www.nabble.com/Total-size-of-a-query-result-and-setLimit%28%29-tf4280909.html#a12185543 a getTotalSize() method should be added to QueryResults.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


[jira] Commented: (JCR-1073) Add getTotalSize() to QueryResults

Posted by "Marcel Reutegger (JIRA)" <ji...@apache.org>.
    [ https://issues.apache.org/jira/browse/JCR-1073?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#action_12522454 ] 

Marcel Reutegger commented on JCR-1073:
---------------------------------------

That's actually the better option, but we then have to open up the package private jackrabbit classes the QueryResultImpl currently uses:

- RowIteratorImpl
- DocOrderNodeIteratorImpl
- NodeIteratorImpl

Is that OK with you?

> Add getTotalSize() to QueryResults
> ----------------------------------
>
>                 Key: JCR-1073
>                 URL: https://issues.apache.org/jira/browse/JCR-1073
>             Project: Jackrabbit
>          Issue Type: New Feature
>          Components: query
>            Reporter: Christoph Kiehl
>            Assignee: Christoph Kiehl
>            Priority: Minor
>         Attachments: patch.txt
>
>
> As discussed in http://www.nabble.com/Total-size-of-a-query-result-and-setLimit%28%29-tf4280909.html#a12185543 a getTotalSize() method should be added to QueryResults.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


[jira] Resolved: (JCR-1073) Add getTotalSize() to QueryResults

Posted by "Christoph Kiehl (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/JCR-1073?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Christoph Kiehl resolved JCR-1073.
----------------------------------

       Resolution: Fixed
    Fix Version/s: 1.4

Committed patch in revision 572889. I'll open a new ticket for renaming LazyQueryResultImpl to QueryResultImpl as this might affect other users as well.

> Add getTotalSize() to QueryResults
> ----------------------------------
>
>                 Key: JCR-1073
>                 URL: https://issues.apache.org/jira/browse/JCR-1073
>             Project: Jackrabbit
>          Issue Type: New Feature
>          Components: query
>            Reporter: Christoph Kiehl
>            Assignee: Christoph Kiehl
>            Priority: Minor
>             Fix For: 1.4
>
>         Attachments: patch.txt
>
>
> As discussed in http://www.nabble.com/Total-size-of-a-query-result-and-setLimit%28%29-tf4280909.html#a12185543 a getTotalSize() method should be added to QueryResults.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


[jira] Commented: (JCR-1073) Add getTotalSize() to QueryResults

Posted by "Christoph Kiehl (JIRA)" <ji...@apache.org>.
    [ https://issues.apache.org/jira/browse/JCR-1073?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#action_12522463 ] 

Christoph Kiehl commented on JCR-1073:
--------------------------------------

I'm afraid if we open up jackrabbit here we might run into more issues like this one where people start using classes that are not intended to be extended or used outside of Jackrabbit. Another hacky solution would be to place to place the class in the org.apache.jackrabbit.core.query.lucene in your project as well. I think java doesn't mind if the file is in another jar file. If you dislike this solution I think we should spend some more time thinking about which parts should be usable from outside to implement a custom QueryHandler for instance (I guess you are using a customized QueryHandler in your project, aren't you?) Unfortunately I'm a bit low on time currently to concentrate on such a work :/

> Add getTotalSize() to QueryResults
> ----------------------------------
>
>                 Key: JCR-1073
>                 URL: https://issues.apache.org/jira/browse/JCR-1073
>             Project: Jackrabbit
>          Issue Type: New Feature
>          Components: query
>            Reporter: Christoph Kiehl
>            Assignee: Christoph Kiehl
>            Priority: Minor
>         Attachments: patch.txt
>
>
> As discussed in http://www.nabble.com/Total-size-of-a-query-result-and-setLimit%28%29-tf4280909.html#a12185543 a getTotalSize() method should be added to QueryResults.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


[jira] Updated: (JCR-1073) Add getTotalSize() to QueryResults

Posted by "Jukka Zitting (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/JCR-1073?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Jukka Zitting updated JCR-1073:
-------------------------------

    Component/s: jackrabbit-core

> Add getTotalSize() to QueryResults
> ----------------------------------
>
>                 Key: JCR-1073
>                 URL: https://issues.apache.org/jira/browse/JCR-1073
>             Project: Jackrabbit
>          Issue Type: New Feature
>          Components: jackrabbit-core, query
>            Reporter: Christoph Kiehl
>            Assignee: Christoph Kiehl
>            Priority: Minor
>             Fix For: 1.4
>
>         Attachments: patch.txt
>
>
> As discussed in http://www.nabble.com/Total-size-of-a-query-result-and-setLimit%28%29-tf4280909.html#a12185543 a getTotalSize() method should be added to QueryResults.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


[jira] Commented: (JCR-1073) Add getTotalSize() to QueryResults

Posted by "Marcel Reutegger (JIRA)" <ji...@apache.org>.
    [ https://issues.apache.org/jira/browse/JCR-1073?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#action_12522512 ] 

Marcel Reutegger commented on JCR-1073:
---------------------------------------

> I guess you are using a customized QueryHandler in your project, aren't you?

yes, we are.

I've now decoupled our code from the respective Jackrabbit classes.

Feel free to remove QueryResultImpl and rename LazyQueryResultImpl.

> Add getTotalSize() to QueryResults
> ----------------------------------
>
>                 Key: JCR-1073
>                 URL: https://issues.apache.org/jira/browse/JCR-1073
>             Project: Jackrabbit
>          Issue Type: New Feature
>          Components: query
>            Reporter: Christoph Kiehl
>            Assignee: Christoph Kiehl
>            Priority: Minor
>         Attachments: patch.txt
>
>
> As discussed in http://www.nabble.com/Total-size-of-a-query-result-and-setLimit%28%29-tf4280909.html#a12185543 a getTotalSize() method should be added to QueryResults.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


[jira] Commented: (JCR-1073) Add getTotalSize() to QueryResults

Posted by "Marcel Reutegger (JIRA)" <ji...@apache.org>.
    [ https://issues.apache.org/jira/browse/JCR-1073?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#action_12521770 ] 

Marcel Reutegger commented on JCR-1073:
---------------------------------------

+1 for the patch.

I'm still using the class QueryResultImpl in a different project. But I'm ok with renaming LazyQueryResultImpl to QueryResultImpl. We just have to rename QueryResultImpl as well ;) e.g. to SimpleQueryResultImpl.

> Add getTotalSize() to QueryResults
> ----------------------------------
>
>                 Key: JCR-1073
>                 URL: https://issues.apache.org/jira/browse/JCR-1073
>             Project: Jackrabbit
>          Issue Type: New Feature
>          Components: query
>            Reporter: Christoph Kiehl
>            Assignee: Christoph Kiehl
>            Priority: Minor
>         Attachments: patch.txt
>
>
> As discussed in http://www.nabble.com/Total-size-of-a-query-result-and-setLimit%28%29-tf4280909.html#a12185543 a getTotalSize() method should be added to QueryResults.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.