You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@spark.apache.org by "BingKun Pan (Jira)" <ji...@apache.org> on 2024/04/18 01:26:00 UTC
[jira] [Commented] (SPARK-47429) Rename errorClass to errorCondition
[ https://issues.apache.org/jira/browse/SPARK-47429?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=17838412#comment-17838412 ]
BingKun Pan commented on SPARK-47429:
-------------------------------------
This will be a very huge task, and I roughly counted almost 4k+ places where the variable `errorClass` is used
!image-2024-04-18-09-22-20-736.png|width=680,height=42!
But this consistent of terms that follow by SQL standards is really very great!
> Rename errorClass to errorCondition
> -----------------------------------
>
> Key: SPARK-47429
> URL: https://issues.apache.org/jira/browse/SPARK-47429
> Project: Spark
> Issue Type: Sub-task
> Components: SQL
> Affects Versions: 4.0.0
> Reporter: Nicholas Chammas
> Priority: Minor
>
> We've agreed on the parent task to rename {{errorClass}} to align it more closely with the SQL standard, and take advantage of the opportunity to break backwards compatibility offered by the Spark version change from 3.5 to 4.0.
> This ticket also covers renaming {{subClass}} as well.
> This is a subtask so the changes are in their own PR and easier to review apart from other things.
--
This message was sent by Atlassian Jira
(v8.20.10#820010)
---------------------------------------------------------------------
To unsubscribe, e-mail: issues-unsubscribe@spark.apache.org
For additional commands, e-mail: issues-help@spark.apache.org