You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@sling.apache.org by "Robert Munteanu (Jira)" <ji...@apache.org> on 2025/03/28 14:15:00 UTC
[jira] [Updated] (SLING-7159) Java9: Upgrade Jackrabbit Dependencies to make Commons Testing compatible with Java9
[ https://issues.apache.org/jira/browse/SLING-7159?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]
Robert Munteanu updated SLING-7159:
-----------------------------------
Fix Version/s: (was: Commons Testing 2.2.0)
> Java9: Upgrade Jackrabbit Dependencies to make Commons Testing compatible with Java9
> ------------------------------------------------------------------------------------
>
> Key: SLING-7159
> URL: https://issues.apache.org/jira/browse/SLING-7159
> Project: Sling
> Issue Type: Improvement
> Components: Testing
> Affects Versions: Commons Testing 2.1.2
> Reporter: Konrad Windszus
> Assignee: Konrad Windszus
> Priority: Major
>
> Currently when deriving tests from {{RepositoryTestBase}} and running them with Java9 you see an error like
> {code}
> java.lang.IllegalArgumentException: javax.jcr.RepositoryFactory is not an ImageIO SPI class
> at java.desktop/javax.imageio.spi.ServiceRegistry.checkClassAllowed(ServiceRegistry.java:745)
> at java.desktop/javax.imageio.spi.ServiceRegistry.lookupProviders(ServiceRegistry.java:230)
> at org.apache.jackrabbit.commons.JcrUtils.getRepository(JcrUtils.java:170)
> at org.apache.jackrabbit.commons.JcrUtils.getRepository(JcrUtils.java:244)
> at org.apache.sling.commons.testing.jcr.RepositoryUtil.startRepository(RepositoryUtil.java:107)
> at org.apache.sling.commons.testing.jcr.RepositoryProvider.getRepository(RepositoryProvider.java:68)
> at org.apache.sling.commons.testing.jcr.RepositoryTestBase.getRepository(RepositoryTestBase.java:67)
> at org.apache.sling.commons.testing.jcr.RepositoryTestBase.getSession(RepositoryTestBase.java:50)
> ...
> {code}
> This is due to the issue described in JCR-4179. Therefore the jackrabbit dependencies should be upgraded to at least 2.14.3.
--
This message was sent by Atlassian Jira
(v8.20.10#820010)