You are viewing a plain text version of this content. The canonical link for it is here.
Posted to commits@wicket.apache.org by "Martin Grigorov (JIRA)" <ji...@apache.org> on 2018/05/26 19:38:00 UTC
[jira] [Reopened] (WICKET-6536) Add generic to
MarkupContainer#visitChildren
[ https://issues.apache.org/jira/browse/WICKET-6536?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]
Martin Grigorov reopened WICKET-6536:
-------------------------------------
> Add generic to MarkupContainer#visitChildren
> --------------------------------------------
>
> Key: WICKET-6536
> URL: https://issues.apache.org/jira/browse/WICKET-6536
> Project: Wicket
> Issue Type: Improvement
> Components: wicket
> Affects Versions: 8.0.0-M8
> Reporter: Kamil
> Assignee: Sven Meier
> Priority: Major
>
> currently MarkupContainer#visitChildren has signature:
> {code:java}
> final <S extends Component, R> R visitChildren(final Class<?> clazz, final IVisitor<S, R> visitor){code}
> while im my opinion it should have:
> {code:java}
> final <S extends Component, R> R visitChildren(final Class<S> clazz, final IVisitor<S, R> visitor){code}
> Why force user to do class cast while we already know which class we pass to the method?
--
This message was sent by Atlassian JIRA
(v7.6.3#76005)