You are viewing a plain text version of this content. The canonical link for it is here.
Posted to cvs@httpd.apache.org by wr...@apache.org on 2016/08/20 01:17:51 UTC
svn commit: r1756979 - /httpd/httpd/trunk/docs/manual/mod/
Author: wrowe
Date: Sat Aug 20 01:17:51 2016
New Revision: 1756979
URL: http://svn.apache.org/viewvc?rev=1756979&view=rev
Log:
Regen docs, no complaints yet
Modified:
httpd/httpd/trunk/docs/manual/mod/core.html.de
httpd/httpd/trunk/docs/manual/mod/core.html.en
httpd/httpd/trunk/docs/manual/mod/core.html.es
httpd/httpd/trunk/docs/manual/mod/core.html.fr
httpd/httpd/trunk/docs/manual/mod/core.html.ja.utf8
httpd/httpd/trunk/docs/manual/mod/core.html.tr.utf8
httpd/httpd/trunk/docs/manual/mod/core.xml.de
httpd/httpd/trunk/docs/manual/mod/core.xml.es
httpd/httpd/trunk/docs/manual/mod/core.xml.fr
httpd/httpd/trunk/docs/manual/mod/core.xml.ja
httpd/httpd/trunk/docs/manual/mod/core.xml.tr
httpd/httpd/trunk/docs/manual/mod/quickreference.html.de
httpd/httpd/trunk/docs/manual/mod/quickreference.html.en
httpd/httpd/trunk/docs/manual/mod/quickreference.html.es
httpd/httpd/trunk/docs/manual/mod/quickreference.html.ja.utf8
httpd/httpd/trunk/docs/manual/mod/quickreference.html.ko.euc-kr
httpd/httpd/trunk/docs/manual/mod/quickreference.html.tr.utf8
httpd/httpd/trunk/docs/manual/mod/quickreference.html.zh-cn.utf8
Modified: httpd/httpd/trunk/docs/manual/mod/core.html.de
URL: http://svn.apache.org/viewvc/httpd/httpd/trunk/docs/manual/mod/core.html.de?rev=1756979&r1=1756978&r2=1756979&view=diff
==============================================================================
--- httpd/httpd/trunk/docs/manual/mod/core.html.de (original)
+++ httpd/httpd/trunk/docs/manual/mod/core.html.de Sat Aug 20 01:17:51 2016
@@ -1556,10 +1556,11 @@ angegebenen MIME-Content-Type</td></tr>
<div class="directive-section"><h2><a name="HttpProtocolOptions" id="HttpProtocolOptions">HttpProtocolOptions</a>-<a name="httpprotocoloptions" id="httpprotocoloptions">Direktive</a></h2>
<table class="directive">
<tr><th><a href="directive-dict.html#Description">Beschreibung:</a></th><td>Modify restrictions on HTTP Request Messages</td></tr>
-<tr><th><a href="directive-dict.html#Syntax">Syntax:</a></th><td><code>HttpProtocolOptions [Strict|Unsafe] [Allow0.9|Require1.0]
-[StrictWhitespace|LenientWhitespace] [RegisteredMethods|LenientMethods]</code></td></tr>
-<tr><th><a href="directive-dict.html#Default">Voreinstellung:</a></th><td><code>HttpProtocolOptions Strict Allow0.9 LenientWhitespace
-LenientMethods</code></td></tr>
+<tr><th><a href="directive-dict.html#Syntax">Syntax:</a></th><td><code>HttpProtocolOptions [Strict|Unsafe] [StrictURL|UnsafeURL]
+ [StrictWhitespace|LenientWhitespace] [RegisteredMethods|LenientMethods]
+ [Allow0.9|Require1.0]</code></td></tr>
+<tr><th><a href="directive-dict.html#Default">Voreinstellung:</a></th><td><code>HttpProtocolOptions Strict StrictURL LenientWhitespace
+LenientMethods Allow0.9</code></td></tr>
<tr><th><a href="directive-dict.html#Context">Kontext:</a></th><td>Serverkonfiguration, Virtual Host</td></tr>
<tr><th><a href="directive-dict.html#Status">Status:</a></th><td>Core</td></tr>
<tr><th><a href="directive-dict.html#Module">Modul:</a></th><td>core</td></tr>
Modified: httpd/httpd/trunk/docs/manual/mod/core.html.en
URL: http://svn.apache.org/viewvc/httpd/httpd/trunk/docs/manual/mod/core.html.en?rev=1756979&r1=1756978&r2=1756979&view=diff
==============================================================================
--- httpd/httpd/trunk/docs/manual/mod/core.html.en (original)
+++ httpd/httpd/trunk/docs/manual/mod/core.html.en Sat Aug 20 01:17:51 2016
@@ -2030,10 +2030,11 @@ media type in the HTTP Content-Type head
<div class="directive-section"><h2><a name="HttpProtocolOptions" id="HttpProtocolOptions">HttpProtocolOptions</a> <a name="httpprotocoloptions" id="httpprotocoloptions">Directive</a></h2>
<table class="directive">
<tr><th><a href="directive-dict.html#Description">Description:</a></th><td>Modify restrictions on HTTP Request Messages</td></tr>
-<tr><th><a href="directive-dict.html#Syntax">Syntax:</a></th><td><code>HttpProtocolOptions [Strict|Unsafe] [Allow0.9|Require1.0]
-[StrictWhitespace|LenientWhitespace] [RegisteredMethods|LenientMethods]</code></td></tr>
-<tr><th><a href="directive-dict.html#Default">Default:</a></th><td><code>HttpProtocolOptions Strict Allow0.9 LenientWhitespace
-LenientMethods</code></td></tr>
+<tr><th><a href="directive-dict.html#Syntax">Syntax:</a></th><td><code>HttpProtocolOptions [Strict|Unsafe] [StrictURL|UnsafeURL]
+ [StrictWhitespace|LenientWhitespace] [RegisteredMethods|LenientMethods]
+ [Allow0.9|Require1.0]</code></td></tr>
+<tr><th><a href="directive-dict.html#Default">Default:</a></th><td><code>HttpProtocolOptions Strict StrictURL LenientWhitespace
+LenientMethods Allow0.9</code></td></tr>
<tr><th><a href="directive-dict.html#Context">Context:</a></th><td>server config, virtual host</td></tr>
<tr><th><a href="directive-dict.html#Status">Status:</a></th><td>Core</td></tr>
<tr><th><a href="directive-dict.html#Module">Module:</a></th><td>core</td></tr>
@@ -2043,11 +2044,11 @@ LenientMethods</code></td></tr>
(<a href="https://tools.ietf.org/html/rfc7230#section-3.1.1">RFC 7230 �3.1.1</a>) and the HTTP Request Header Fields
(<a href="https://tools.ietf.org/html/rfc7230#section-3.2">RFC 7230 �3.2</a>), which are now applied by default or using
the <code>Strict</code> option. Due to legacy modules, applications or
- custom user-agents which must be deperecated, an <code>Unsafe</code>
- option has been added to revert to the legacy behavior. These rules are
- applied prior to request processing, so must be configured at the global
- or default (first) matching virtual host section, by interface and not
- by name, to be honored.</p>
+ custom user-agents which must be deperecated, <code>Unsafe</code>
+ and <code>UnsafeURL</code> options have been added to revert to the legacy
+ behaviors. These rules are applied prior to request processing, so must be
+ configured at the global or default (first) matching virtual host section,
+ by IP/port interface and not by name, to be honored.</p>
<p>Prior to the introduction of this directive, the Apache HTTP Server
request message parsers were tolerant of a number of forms of input
@@ -2058,23 +2059,26 @@ LenientMethods</code></td></tr>
of this directive, all grammer rules of the specification are enforced in
the default <code>Strict</code> operating mode.</p>
+ <p><a href="https://tools.ietf.org/html/rfc3986#section-2.2">RFC 7230 �2.2 and 2.3</a> define "Reserved Characters" and
+ "Unreserved Characters". All other character octets are required to
+ be %XX encoded under this spec, and RFC7230 defers to these requirements.
+ By default the <code>StrictURI</code> option will reject all requests
+ containing invalid characters. This rule can be relaxed with the
+ <code>UnsafeURI</code> option to support badly written user-agents.</p>
+
<p>Users are strongly cautioned against toggling the <code>Unsafe</code>
- mode of operation for these reasons, most especially on outward-facing,
- publicly accessible server deployments. Reviewing the messages within the
- <code class="directive">ErrorLog</code>, configured with
- <code class="directive">LogLevel</code> <code>info</code> level or below,
+ and <code>UnsafeURI</code> modes of operation, most especially on
+ outward-facing, publicly accessible server deployments. If an interface
+ is required of faulty monitoring or other custom software running only
+ on an intranet, users should consider toggling these only for a specific
+ virtual host configured on their private subnet.</p>
+
+ <p>Reviewing the messages logged to the <code class="directive">ErrorLog</code>,
+ configured with <code class="directive">LogLevel</code> <code>info</code> level,
can help identify such faulty requests along with their origin.
Users should pay particular attention to any 400 responses in the access
log for indiciations that valid requests are unexpectedly rejected.</p>
- <p><a href="https://tools.ietf.org/html/rfc2616#section-19.6">RFC 2616 �19.6</a> "Compatibility With Previous Versions" had
- encouraged HTTP servers to support legacy HTTP/0.9 requests. RFC 7230
- superceeds this with "The expectation to support HTTP/0.9 requests has
- been removed" and offers additional comments in
- <a href="https://tools.ietf.org/html/rfc7230#appendix-A">RFC 2616 Appendix A</a>. The <code>Require1.0</code> option allows
- the user to remove support of the default <code>Allow0.9</code> option's
- behavior.</p>
-
<p><a href="https://tools.ietf.org/html/rfc7230#section-3.5">RFC 7230 �3.5</a> "Message Parsing Robustness" permits, and
identifies potential risks of parsing messages containing non-space
character whitespace. While the spec defines that exactly one space
@@ -2091,13 +2095,21 @@ LenientMethods</code></td></tr>
origin servers shall respond with an error when an unsupported method
is encountered in the request line. This already happens when the
<code>LenientMethods</code> option is used, but administrators may wish
- to toggle the <code>RegisteredMethods</code> option and register all
- permitted method tokens using the <code class="directive">RegisterHttpMethod</code>
+ to toggle the <code>RegisteredMethods</code> option and register any
+ non-standard methods using the <code class="directive">RegisterHttpMethod</code>
directive, particularly if the <code>Unsafe</code> option has been toggled.
The <code>RegisteredMethods</code> option should <strong>not</strong>
be toggled for forward proxy hosts, as the methods supported by the
origin servers are unknown to the proxy server.</p>
+ <p><a href="https://tools.ietf.org/html/rfc2616#section-19.6">RFC 2616 �19.6</a> "Compatibility With Previous Versions" had
+ encouraged HTTP servers to support legacy HTTP/0.9 requests. RFC 7230
+ superceeds this with "The expectation to support HTTP/0.9 requests has
+ been removed" and offers additional comments in
+ <a href="https://tools.ietf.org/html/rfc7230#appendix-A">RFC 2616 Appendix A</a>. The <code>Require1.0</code> option allows
+ the user to remove support of the default <code>Allow0.9</code> option's
+ behavior.</p>
+
</div>
<div class="top"><a href="#page-header"><img alt="top" src="../images/up.gif" /></a></div>
<div class="directive-section"><h2><a name="If" id="If"><If></a> <a name="if" id="if">Directive</a></h2>
Modified: httpd/httpd/trunk/docs/manual/mod/core.html.es
URL: http://svn.apache.org/viewvc/httpd/httpd/trunk/docs/manual/mod/core.html.es?rev=1756979&r1=1756978&r2=1756979&view=diff
==============================================================================
--- httpd/httpd/trunk/docs/manual/mod/core.html.es (original)
+++ httpd/httpd/trunk/docs/manual/mod/core.html.es Sat Aug 20 01:17:51 2016
@@ -1739,10 +1739,11 @@ media type in the HTTP Content-Type head
<div class="directive-section"><h2><a name="HttpProtocolOptions" id="HttpProtocolOptions">HttpProtocolOptions</a> <a name="httpprotocoloptions" id="httpprotocoloptions">Directiva</a></h2>
<table class="directive">
<tr><th><a href="directive-dict.html#Description">Descripci�n:</a></th><td>Modify restrictions on HTTP Request Messages</td></tr>
-<tr><th><a href="directive-dict.html#Syntax">Sintaxis:</a></th><td><code>HttpProtocolOptions [Strict|Unsafe] [Allow0.9|Require1.0]
-[StrictWhitespace|LenientWhitespace] [RegisteredMethods|LenientMethods]</code></td></tr>
-<tr><th><a href="directive-dict.html#Default">Valor por defecto:</a></th><td><code>HttpProtocolOptions Strict Allow0.9 LenientWhitespace
-LenientMethods</code></td></tr>
+<tr><th><a href="directive-dict.html#Syntax">Sintaxis:</a></th><td><code>HttpProtocolOptions [Strict|Unsafe] [StrictURL|UnsafeURL]
+ [StrictWhitespace|LenientWhitespace] [RegisteredMethods|LenientMethods]
+ [Allow0.9|Require1.0]</code></td></tr>
+<tr><th><a href="directive-dict.html#Default">Valor por defecto:</a></th><td><code>HttpProtocolOptions Strict StrictURL LenientWhitespace
+LenientMethods Allow0.9</code></td></tr>
<tr><th><a href="directive-dict.html#Context">Contexto:</a></th><td>server config, virtual host</td></tr>
<tr><th><a href="directive-dict.html#Status">Estado:</a></th><td>Core</td></tr>
<tr><th><a href="directive-dict.html#Module">M�dulo:</a></th><td>core</td></tr>
Modified: httpd/httpd/trunk/docs/manual/mod/core.html.fr
URL: http://svn.apache.org/viewvc/httpd/httpd/trunk/docs/manual/mod/core.html.fr?rev=1756979&r1=1756978&r2=1756979&view=diff
==============================================================================
--- httpd/httpd/trunk/docs/manual/mod/core.html.fr (original)
+++ httpd/httpd/trunk/docs/manual/mod/core.html.fr Sat Aug 20 01:17:51 2016
@@ -2175,10 +2175,11 @@ clients</td></tr>
<div class="directive-section"><h2><a name="httpprotocoloptions" id="httpprotocoloptions">Directive</a> <a name="HttpProtocolOptions" id="HttpProtocolOptions">HttpProtocolOptions</a></h2>
<table class="directive">
<tr><th><a href="directive-dict.html#Description">Description:</a></th><td>Modify restrictions on HTTP Request Messages</td></tr>
-<tr><th><a href="directive-dict.html#Syntax">Syntaxe:</a></th><td><code>HttpProtocolOptions [Strict|Unsafe] [Allow0.9|Require1.0]
-[StrictWhitespace|LenientWhitespace] [RegisteredMethods|LenientMethods]</code></td></tr>
-<tr><th><a href="directive-dict.html#Default">D�faut:</a></th><td><code>HttpProtocolOptions Strict Allow0.9 LenientWhitespace
-LenientMethods</code></td></tr>
+<tr><th><a href="directive-dict.html#Syntax">Syntaxe:</a></th><td><code>HttpProtocolOptions [Strict|Unsafe] [StrictURL|UnsafeURL]
+ [StrictWhitespace|LenientWhitespace] [RegisteredMethods|LenientMethods]
+ [Allow0.9|Require1.0]</code></td></tr>
+<tr><th><a href="directive-dict.html#Default">D�faut:</a></th><td><code>HttpProtocolOptions Strict StrictURL LenientWhitespace
+LenientMethods Allow0.9</code></td></tr>
<tr><th><a href="directive-dict.html#Context">Contexte:</a></th><td>configuration du serveur, serveur virtuel</td></tr>
<tr><th><a href="directive-dict.html#Status">Statut:</a></th><td>Core</td></tr>
<tr><th><a href="directive-dict.html#Module">Module:</a></th><td>core</td></tr>
Modified: httpd/httpd/trunk/docs/manual/mod/core.html.ja.utf8
URL: http://svn.apache.org/viewvc/httpd/httpd/trunk/docs/manual/mod/core.html.ja.utf8?rev=1756979&r1=1756978&r2=1756979&view=diff
==============================================================================
--- httpd/httpd/trunk/docs/manual/mod/core.html.ja.utf8 [utf-8] (original)
+++ httpd/httpd/trunk/docs/manual/mod/core.html.ja.utf8 [utf-8] Sat Aug 20 01:17:51 2016
@@ -1504,10 +1504,11 @@ request</td></tr>
<div class="directive-section"><h2><a name="HttpProtocolOptions" id="HttpProtocolOptions">HttpProtocolOptions</a> <a name="httpprotocoloptions" id="httpprotocoloptions">\u30c7\u30a3\u30ec\u30af\u30c6\u30a3\u30d6</a></h2>
<table class="directive">
<tr><th><a href="directive-dict.html#Description">\u8aac\u660e:</a></th><td>Modify restrictions on HTTP Request Messages</td></tr>
-<tr><th><a href="directive-dict.html#Syntax">\u69cb\u6587:</a></th><td><code>HttpProtocolOptions [Strict|Unsafe] [Allow0.9|Require1.0]
-[StrictWhitespace|LenientWhitespace] [RegisteredMethods|LenientMethods]</code></td></tr>
-<tr><th><a href="directive-dict.html#Default">\u30c7\u30d5\u30a9\u30eb\u30c8:</a></th><td><code>HttpProtocolOptions Strict Allow0.9 LenientWhitespace
-LenientMethods</code></td></tr>
+<tr><th><a href="directive-dict.html#Syntax">\u69cb\u6587:</a></th><td><code>HttpProtocolOptions [Strict|Unsafe] [StrictURL|UnsafeURL]
+ [StrictWhitespace|LenientWhitespace] [RegisteredMethods|LenientMethods]
+ [Allow0.9|Require1.0]</code></td></tr>
+<tr><th><a href="directive-dict.html#Default">\u30c7\u30d5\u30a9\u30eb\u30c8:</a></th><td><code>HttpProtocolOptions Strict StrictURL LenientWhitespace
+LenientMethods Allow0.9</code></td></tr>
<tr><th><a href="directive-dict.html#Context">\u30b3\u30f3\u30c6\u30ad\u30b9\u30c8:</a></th><td>\u30b5\u30fc\u30d0\u8a2d\u5b9a\u30d5\u30a1\u30a4\u30eb, \u30d0\u30fc\u30c1\u30e3\u30eb\u30db\u30b9\u30c8</td></tr>
<tr><th><a href="directive-dict.html#Status">\u30b9\u30c6\u30fc\u30bf\u30b9:</a></th><td>Core</td></tr>
<tr><th><a href="directive-dict.html#Module">\u30e2\u30b8\u30e5\u30fc\u30eb:</a></th><td>core</td></tr>
Modified: httpd/httpd/trunk/docs/manual/mod/core.html.tr.utf8
URL: http://svn.apache.org/viewvc/httpd/httpd/trunk/docs/manual/mod/core.html.tr.utf8?rev=1756979&r1=1756978&r2=1756979&view=diff
==============================================================================
--- httpd/httpd/trunk/docs/manual/mod/core.html.tr.utf8 [utf-8] (original)
+++ httpd/httpd/trunk/docs/manual/mod/core.html.tr.utf8 [utf-8] Sat Aug 20 01:17:51 2016
@@ -1971,10 +1971,11 @@ i�in iptal edilmi\u015ftir.</td></tr>
<div class="directive-section"><h2><a name="HttpProtocolOptions" id="HttpProtocolOptions">HttpProtocolOptions</a> <a name="httpprotocoloptions" id="httpprotocoloptions">Y�nergesi</a></h2>
<table class="directive">
<tr><th><a href="directive-dict.html#Description">A�\u0131klama:</a></th><td>Modify restrictions on HTTP Request Messages</td></tr>
-<tr><th><a href="directive-dict.html#Syntax">S�zdizimi:</a></th><td><code>HttpProtocolOptions [Strict|Unsafe] [Allow0.9|Require1.0]
-[StrictWhitespace|LenientWhitespace] [RegisteredMethods|LenientMethods]</code></td></tr>
-<tr><th><a href="directive-dict.html#Default">�ntan\u0131ml\u0131:</a></th><td><code>HttpProtocolOptions Strict Allow0.9 LenientWhitespace
-LenientMethods</code></td></tr>
+<tr><th><a href="directive-dict.html#Syntax">S�zdizimi:</a></th><td><code>HttpProtocolOptions [Strict|Unsafe] [StrictURL|UnsafeURL]
+ [StrictWhitespace|LenientWhitespace] [RegisteredMethods|LenientMethods]
+ [Allow0.9|Require1.0]</code></td></tr>
+<tr><th><a href="directive-dict.html#Default">�ntan\u0131ml\u0131:</a></th><td><code>HttpProtocolOptions Strict StrictURL LenientWhitespace
+LenientMethods Allow0.9</code></td></tr>
<tr><th><a href="directive-dict.html#Context">Ba\u011flam:</a></th><td>sunucu geneli, sanal konak</td></tr>
<tr><th><a href="directive-dict.html#Status">Durum:</a></th><td>�ekirdek</td></tr>
<tr><th><a href="directive-dict.html#Module">Mod�l:</a></th><td>core</td></tr>
Modified: httpd/httpd/trunk/docs/manual/mod/core.xml.de
URL: http://svn.apache.org/viewvc/httpd/httpd/trunk/docs/manual/mod/core.xml.de?rev=1756979&r1=1756978&r2=1756979&view=diff
==============================================================================
--- httpd/httpd/trunk/docs/manual/mod/core.xml.de (original)
+++ httpd/httpd/trunk/docs/manual/mod/core.xml.de Sat Aug 20 01:17:51 2016
@@ -1,7 +1,7 @@
<?xml version="1.0"?>
<!DOCTYPE modulesynopsis SYSTEM "../style/modulesynopsis.dtd">
<?xml-stylesheet type="text/xsl" href="../style/manual.de.xsl"?>
-<!-- English Revision: 344972:1756862 (outdated) -->
+<!-- English Revision: 344972:1756959 (outdated) -->
<!--
Licensed to the Apache Software Foundation (ASF) under one or more
Modified: httpd/httpd/trunk/docs/manual/mod/core.xml.es
URL: http://svn.apache.org/viewvc/httpd/httpd/trunk/docs/manual/mod/core.xml.es?rev=1756979&r1=1756978&r2=1756979&view=diff
==============================================================================
--- httpd/httpd/trunk/docs/manual/mod/core.xml.es [utf-8] (original)
+++ httpd/httpd/trunk/docs/manual/mod/core.xml.es [utf-8] Sat Aug 20 01:17:51 2016
@@ -1,7 +1,7 @@
<?xml version="1.0" encoding="utf-8"?>
<!DOCTYPE modulesynopsis SYSTEM "../style/modulesynopsis.dtd">
<?xml-stylesheet type="text/xsl" href="../style/manual.es.xsl"?>
-<!-- English Revision: 1741251:1756862 (outdated) -->
+<!-- English Revision: 1741251:1756959 (outdated) -->
<!-- Translated by Luis Gil de Bernab� Pfeiffer lgilbernabe[AT]apache.org -->
<!-- Reviewed by Sergio Ramos-->
<!--
Modified: httpd/httpd/trunk/docs/manual/mod/core.xml.fr
URL: http://svn.apache.org/viewvc/httpd/httpd/trunk/docs/manual/mod/core.xml.fr?rev=1756979&r1=1756978&r2=1756979&view=diff
==============================================================================
--- httpd/httpd/trunk/docs/manual/mod/core.xml.fr (original)
+++ httpd/httpd/trunk/docs/manual/mod/core.xml.fr Sat Aug 20 01:17:51 2016
@@ -1,7 +1,7 @@
<?xml version="1.0" encoding="UTF-8" ?>
<!DOCTYPE modulesynopsis SYSTEM "../style/modulesynopsis.dtd">
<?xml-stylesheet type="text/xsl" href="../style/manual.fr.xsl"?>
-<!-- English Revision: 1750750:1756862 (outdated) -->
+<!-- English Revision: 1750750:1756959 (outdated) -->
<!-- French translation : Lucien GENTIS -->
<!-- Reviewed by : Vincent Deffontaines -->
Modified: httpd/httpd/trunk/docs/manual/mod/core.xml.ja
URL: http://svn.apache.org/viewvc/httpd/httpd/trunk/docs/manual/mod/core.xml.ja?rev=1756979&r1=1756978&r2=1756979&view=diff
==============================================================================
--- httpd/httpd/trunk/docs/manual/mod/core.xml.ja [utf-8] (original)
+++ httpd/httpd/trunk/docs/manual/mod/core.xml.ja [utf-8] Sat Aug 20 01:17:51 2016
@@ -1,7 +1,7 @@
<?xml version="1.0" encoding="UTF-8" ?>
<!DOCTYPE modulesynopsis SYSTEM "../style/modulesynopsis.dtd">
<?xml-stylesheet type="text/xsl" href="../style/manual.ja.xsl"?>
-<!-- English Revision: 669847:1756862 (outdated) -->
+<!-- English Revision: 669847:1756959 (outdated) -->
<!--
Licensed to the Apache Software Foundation (ASF) under one or more
Modified: httpd/httpd/trunk/docs/manual/mod/core.xml.tr
URL: http://svn.apache.org/viewvc/httpd/httpd/trunk/docs/manual/mod/core.xml.tr?rev=1756979&r1=1756978&r2=1756979&view=diff
==============================================================================
--- httpd/httpd/trunk/docs/manual/mod/core.xml.tr [utf-8] (original)
+++ httpd/httpd/trunk/docs/manual/mod/core.xml.tr [utf-8] Sat Aug 20 01:17:51 2016
@@ -1,7 +1,7 @@
<?xml version="1.0"?>
<!DOCTYPE modulesynopsis SYSTEM "../style/modulesynopsis.dtd">
<?xml-stylesheet type="text/xsl" href="../style/manual.tr.xsl"?>
-<!-- English Revision: 1302855:1756862 (outdated) -->
+<!-- English Revision: 1302855:1756959 (outdated) -->
<!-- =====================================================
Translated by: Nilg�n Belma Bug�ner <nilgun belgeler.org>
Reviewed by: Orhan Berent <berent belgeler.org>
Modified: httpd/httpd/trunk/docs/manual/mod/quickreference.html.de
URL: http://svn.apache.org/viewvc/httpd/httpd/trunk/docs/manual/mod/quickreference.html.de?rev=1756979&r1=1756978&r2=1756979&view=diff
==============================================================================
--- httpd/httpd/trunk/docs/manual/mod/quickreference.html.de (original)
+++ httpd/httpd/trunk/docs/manual/mod/quickreference.html.de Sat Aug 20 01:17:51 2016
@@ -541,8 +541,9 @@ heartbeat requests to this server</td></
<tr><td><a href="mod_heartmonitor.html#heartbeatstorage">HeartbeatStorage <var>file-path</var></a></td><td> logs/hb.dat </td><td>s</td><td>X</td></tr><tr><td class="descr" colspan="4">Path to store heartbeat data</td></tr>
<tr class="odd"><td><a href="mod_lbmethod_heartbeat.html#heartbeatstorage">HeartbeatStorage <var>file-path</var></a></td><td> logs/hb.dat </td><td>s</td><td>X</td></tr><tr class="odd"><td class="descr" colspan="4">Path to read heartbeat data</td></tr>
<tr><td><a href="core.html#hostnamelookups">HostnameLookups On|Off|Double</a></td><td> Off </td><td>svd</td><td>C</td></tr><tr><td class="descr" colspan="4">Aktiviert DNS-Lookups auf Client-IP-Adressen</td></tr>
-<tr class="odd"><td><a href="core.html#httpprotocoloptions">HttpProtocolOptions [Strict|Unsafe] [Allow0.9|Require1.0]
-[StrictWhitespace|LenientWhitespace] [RegisteredMethods|LenientMethods]</a></td><td> Strict Allow0.9 Len +</td><td>sv</td><td>C</td></tr><tr class="odd"><td class="descr" colspan="4">Modify restrictions on HTTP Request Messages</td></tr>
+<tr class="odd"><td><a href="core.html#httpprotocoloptions">HttpProtocolOptions [Strict|Unsafe] [StrictURL|UnsafeURL]
+ [StrictWhitespace|LenientWhitespace] [RegisteredMethods|LenientMethods]
+ [Allow0.9|Require1.0]</a></td><td> Strict StrictURL Le +</td><td>sv</td><td>C</td></tr><tr class="odd"><td class="descr" colspan="4">Modify restrictions on HTTP Request Messages</td></tr>
<tr><td><a href="mod_ident.html#identitycheck" id="I" name="I">IdentityCheck On|Off</a></td><td> Off </td><td>svd</td><td>E</td></tr><tr><td class="descr" colspan="4">Enables logging of the RFC 1413 identity of the remote
user</td></tr>
<tr class="odd"><td><a href="mod_ident.html#identitychecktimeout">IdentityCheckTimeout <var>seconds</var></a></td><td> 30 </td><td>svd</td><td>E</td></tr><tr class="odd"><td class="descr" colspan="4">Determines the timeout duration for ident requests</td></tr>
Modified: httpd/httpd/trunk/docs/manual/mod/quickreference.html.en
URL: http://svn.apache.org/viewvc/httpd/httpd/trunk/docs/manual/mod/quickreference.html.en?rev=1756979&r1=1756978&r2=1756979&view=diff
==============================================================================
--- httpd/httpd/trunk/docs/manual/mod/quickreference.html.en (original)
+++ httpd/httpd/trunk/docs/manual/mod/quickreference.html.en Sat Aug 20 01:17:51 2016
@@ -536,8 +536,9 @@ heartbeat requests to this server</td></
<tr><td><a href="mod_heartmonitor.html#heartbeatstorage">HeartbeatStorage <var>file-path</var></a></td><td> logs/hb.dat </td><td>s</td><td>X</td></tr><tr><td class="descr" colspan="4">Path to store heartbeat data</td></tr>
<tr class="odd"><td><a href="mod_lbmethod_heartbeat.html#heartbeatstorage">HeartbeatStorage <var>file-path</var></a></td><td> logs/hb.dat </td><td>s</td><td>X</td></tr><tr class="odd"><td class="descr" colspan="4">Path to read heartbeat data</td></tr>
<tr><td><a href="core.html#hostnamelookups">HostnameLookups On|Off|Double</a></td><td> Off </td><td>svd</td><td>C</td></tr><tr><td class="descr" colspan="4">Enables DNS lookups on client IP addresses</td></tr>
-<tr class="odd"><td><a href="core.html#httpprotocoloptions">HttpProtocolOptions [Strict|Unsafe] [Allow0.9|Require1.0]
-[StrictWhitespace|LenientWhitespace] [RegisteredMethods|LenientMethods]</a></td><td> Strict Allow0.9 Len +</td><td>sv</td><td>C</td></tr><tr class="odd"><td class="descr" colspan="4">Modify restrictions on HTTP Request Messages</td></tr>
+<tr class="odd"><td><a href="core.html#httpprotocoloptions">HttpProtocolOptions [Strict|Unsafe] [StrictURL|UnsafeURL]
+ [StrictWhitespace|LenientWhitespace] [RegisteredMethods|LenientMethods]
+ [Allow0.9|Require1.0]</a></td><td> Strict StrictURL Le +</td><td>sv</td><td>C</td></tr><tr class="odd"><td class="descr" colspan="4">Modify restrictions on HTTP Request Messages</td></tr>
<tr><td><a href="mod_ident.html#identitycheck" id="I" name="I">IdentityCheck On|Off</a></td><td> Off </td><td>svd</td><td>E</td></tr><tr><td class="descr" colspan="4">Enables logging of the RFC 1413 identity of the remote
user</td></tr>
<tr class="odd"><td><a href="mod_ident.html#identitychecktimeout">IdentityCheckTimeout <var>seconds</var></a></td><td> 30 </td><td>svd</td><td>E</td></tr><tr class="odd"><td class="descr" colspan="4">Determines the timeout duration for ident requests</td></tr>
Modified: httpd/httpd/trunk/docs/manual/mod/quickreference.html.es
URL: http://svn.apache.org/viewvc/httpd/httpd/trunk/docs/manual/mod/quickreference.html.es?rev=1756979&r1=1756978&r2=1756979&view=diff
==============================================================================
--- httpd/httpd/trunk/docs/manual/mod/quickreference.html.es (original)
+++ httpd/httpd/trunk/docs/manual/mod/quickreference.html.es Sat Aug 20 01:17:51 2016
@@ -539,8 +539,9 @@ heartbeat requests to this server</td></
<tr><td><a href="mod_heartmonitor.html#heartbeatstorage">HeartbeatStorage <var>file-path</var></a></td><td> logs/hb.dat </td><td>s</td><td>X</td></tr><tr><td class="descr" colspan="4">Path to store heartbeat data</td></tr>
<tr class="odd"><td><a href="mod_lbmethod_heartbeat.html#heartbeatstorage">HeartbeatStorage <var>file-path</var></a></td><td> logs/hb.dat </td><td>s</td><td>X</td></tr><tr class="odd"><td class="descr" colspan="4">Path to read heartbeat data</td></tr>
<tr><td><a href="core.html#hostnamelookups">HostnameLookups On|Off|Double</a></td><td> Off </td><td>svd</td><td>C</td></tr><tr><td class="descr" colspan="4">Enables DNS lookups on client IP addresses</td></tr>
-<tr class="odd"><td><a href="core.html#httpprotocoloptions">HttpProtocolOptions [Strict|Unsafe] [Allow0.9|Require1.0]
-[StrictWhitespace|LenientWhitespace] [RegisteredMethods|LenientMethods]</a></td><td> Strict Allow0.9 Len +</td><td>sv</td><td>C</td></tr><tr class="odd"><td class="descr" colspan="4">Modify restrictions on HTTP Request Messages</td></tr>
+<tr class="odd"><td><a href="core.html#httpprotocoloptions">HttpProtocolOptions [Strict|Unsafe] [StrictURL|UnsafeURL]
+ [StrictWhitespace|LenientWhitespace] [RegisteredMethods|LenientMethods]
+ [Allow0.9|Require1.0]</a></td><td> Strict StrictURL Le +</td><td>sv</td><td>C</td></tr><tr class="odd"><td class="descr" colspan="4">Modify restrictions on HTTP Request Messages</td></tr>
<tr><td><a href="mod_ident.html#identitycheck" id="I" name="I">IdentityCheck On|Off</a></td><td> Off </td><td>svd</td><td>E</td></tr><tr><td class="descr" colspan="4">Enables logging of the RFC 1413 identity of the remote
user</td></tr>
<tr class="odd"><td><a href="mod_ident.html#identitychecktimeout">IdentityCheckTimeout <var>seconds</var></a></td><td> 30 </td><td>svd</td><td>E</td></tr><tr class="odd"><td class="descr" colspan="4">Determines the timeout duration for ident requests</td></tr>
Modified: httpd/httpd/trunk/docs/manual/mod/quickreference.html.ja.utf8
URL: http://svn.apache.org/viewvc/httpd/httpd/trunk/docs/manual/mod/quickreference.html.ja.utf8?rev=1756979&r1=1756978&r2=1756979&view=diff
==============================================================================
--- httpd/httpd/trunk/docs/manual/mod/quickreference.html.ja.utf8 [utf-8] (original)
+++ httpd/httpd/trunk/docs/manual/mod/quickreference.html.ja.utf8 [utf-8] Sat Aug 20 01:17:51 2016
@@ -511,8 +511,9 @@ heartbeat requests to this server</td></
<tr class="odd"><td><a href="mod_lbmethod_heartbeat.html#heartbeatstorage">HeartbeatStorage <var>file-path</var></a></td><td> logs/hb.dat </td><td>s</td><td>X</td></tr><tr class="odd"><td class="descr" colspan="4">Path to read heartbeat data</td></tr>
<tr><td><a href="core.html#hostnamelookups">HostnameLookups On|Off|Double</a></td><td> Off </td><td>svd</td><td>C</td></tr><tr><td class="descr" colspan="4">\u30af\u30e9\u30a4\u30a2\u30f3\u30c8\u306e IP \u30a2\u30c9\u30ec\u30b9\u306e DNS \u30eb\u30c3\u30af\u30a2\u30c3\u30d7\u3092
\u6709\u52b9\u306b\u3059\u308b</td></tr>
-<tr class="odd"><td><a href="core.html#httpprotocoloptions">HttpProtocolOptions [Strict|Unsafe] [Allow0.9|Require1.0]
-[StrictWhitespace|LenientWhitespace] [RegisteredMethods|LenientMethods]</a></td><td> Strict Allow0.9 Len +</td><td>sv</td><td>C</td></tr><tr class="odd"><td class="descr" colspan="4">Modify restrictions on HTTP Request Messages</td></tr>
+<tr class="odd"><td><a href="core.html#httpprotocoloptions">HttpProtocolOptions [Strict|Unsafe] [StrictURL|UnsafeURL]
+ [StrictWhitespace|LenientWhitespace] [RegisteredMethods|LenientMethods]
+ [Allow0.9|Require1.0]</a></td><td> Strict StrictURL Le +</td><td>sv</td><td>C</td></tr><tr class="odd"><td class="descr" colspan="4">Modify restrictions on HTTP Request Messages</td></tr>
<tr><td><a href="mod_ident.html#identitycheck" id="I" name="I">IdentityCheck On|Off</a></td><td> Off </td><td>svd</td><td>E</td></tr><tr><td class="descr" colspan="4">\u30ea\u30e2\u30fc\u30c8\u30e6\u30fc\u30b6\u306e RFC 1413 \u306b\u3088\u308b\u30a2\u30a4\u30c7\u30f3\u30c6\u30a3\u30c6\u30a3\u306e\u30ed\u30ae\u30f3\u30b0\u3092
\u6709\u52b9\u306b\u3059\u308b</td></tr>
<tr class="odd"><td><a href="mod_ident.html#identitychecktimeout">IdentityCheckTimeout <var>seconds</var></a></td><td> 30 </td><td>svd</td><td>E</td></tr><tr class="odd"><td class="descr" colspan="4">Ident \u30ea\u30af\u30a8\u30b9\u30c8\u304c\u30bf\u30a4\u30e0\u30a2\u30a6\u30c8\u3059\u308b\u307e\u3067\u306e\u671f\u9593\u3092\u6c7a\u3081\u308b</td></tr>
Modified: httpd/httpd/trunk/docs/manual/mod/quickreference.html.ko.euc-kr
URL: http://svn.apache.org/viewvc/httpd/httpd/trunk/docs/manual/mod/quickreference.html.ko.euc-kr?rev=1756979&r1=1756978&r2=1756979&view=diff
==============================================================================
--- httpd/httpd/trunk/docs/manual/mod/quickreference.html.ko.euc-kr [euc-kr] (original)
+++ httpd/httpd/trunk/docs/manual/mod/quickreference.html.ko.euc-kr [euc-kr] Sat Aug 20 01:17:51 2016
@@ -508,8 +508,9 @@ heartbeat requests to this server</td></
<tr><td><a href="mod_heartmonitor.html#heartbeatstorage">HeartbeatStorage <var>file-path</var></a></td><td> logs/hb.dat </td><td>s</td><td>X</td></tr><tr><td class="descr" colspan="4">Path to store heartbeat data</td></tr>
<tr class="odd"><td><a href="mod_lbmethod_heartbeat.html#heartbeatstorage">HeartbeatStorage <var>file-path</var></a></td><td> logs/hb.dat </td><td>s</td><td>X</td></tr><tr class="odd"><td class="descr" colspan="4">Path to read heartbeat data</td></tr>
<tr><td><a href="core.html#hostnamelookups">HostnameLookups On|Off|Double</a></td><td> Off </td><td>svd</td><td>C</td></tr><tr><td class="descr" colspan="4">Enables DNS lookups on client IP addresses</td></tr>
-<tr class="odd"><td><a href="core.html#httpprotocoloptions">HttpProtocolOptions [Strict|Unsafe] [Allow0.9|Require1.0]
-[StrictWhitespace|LenientWhitespace] [RegisteredMethods|LenientMethods]</a></td><td> Strict Allow0.9 Len +</td><td>sv</td><td>C</td></tr><tr class="odd"><td class="descr" colspan="4">Modify restrictions on HTTP Request Messages</td></tr>
+<tr class="odd"><td><a href="core.html#httpprotocoloptions">HttpProtocolOptions [Strict|Unsafe] [StrictURL|UnsafeURL]
+ [StrictWhitespace|LenientWhitespace] [RegisteredMethods|LenientMethods]
+ [Allow0.9|Require1.0]</a></td><td> Strict StrictURL Le +</td><td>sv</td><td>C</td></tr><tr class="odd"><td class="descr" colspan="4">Modify restrictions on HTTP Request Messages</td></tr>
<tr><td><a href="mod_ident.html#identitycheck" id="I" name="I">IdentityCheck On|Off</a></td><td> Off </td><td>svd</td><td>E</td></tr><tr><td class="descr" colspan="4">\uc6d0\uaca9 \uc0ac\uc6a9\uc790\uc758 RFC 1413 \uc2e0\uc6d0\uc744 \ub85c\uadf8\uc5d0 \uae30\ub85d\ud55c\ub2e4</td></tr>
<tr class="odd"><td><a href="mod_ident.html#identitychecktimeout">IdentityCheckTimeout <var>seconds</var></a></td><td> 30 </td><td>svd</td><td>E</td></tr><tr class="odd"><td class="descr" colspan="4">ident \uc694\uccad\uc758 \uc2dc\uac04\uc81c\ud55c\uc744 \uc9c0\uc815\ud55c\ub2e4</td></tr>
<tr><td><a href="mod_systemd.html#idleshutdown">IdleShutdown seconds</a></td><td> 0 </td><td>s</td><td>E</td></tr><tr><td class="descr" colspan="4">Enable shutting down the httpd when it is idle for some time.</td></tr>
Modified: httpd/httpd/trunk/docs/manual/mod/quickreference.html.tr.utf8
URL: http://svn.apache.org/viewvc/httpd/httpd/trunk/docs/manual/mod/quickreference.html.tr.utf8?rev=1756979&r1=1756978&r2=1756979&view=diff
==============================================================================
--- httpd/httpd/trunk/docs/manual/mod/quickreference.html.tr.utf8 [utf-8] (original)
+++ httpd/httpd/trunk/docs/manual/mod/quickreference.html.tr.utf8 [utf-8] Sat Aug 20 01:17:51 2016
@@ -534,8 +534,9 @@ heartbeat requests to this server</td></
<tr class="odd"><td><a href="mod_lbmethod_heartbeat.html#heartbeatstorage">HeartbeatStorage <var>file-path</var></a></td><td> logs/hb.dat </td><td>s</td><td>D</td></tr><tr class="odd"><td class="descr" colspan="4">Path to read heartbeat data</td></tr>
<tr><td><a href="core.html#hostnamelookups">HostnameLookups On|Off|Double</a></td><td> Off </td><td>skd</td><td>�</td></tr><tr><td class="descr" colspan="4">\u0130stemci IP adresleri �zerinde DNS sorgular\u0131n\u0131 etkin k\u0131lar.
</td></tr>
-<tr class="odd"><td><a href="core.html#httpprotocoloptions">HttpProtocolOptions [Strict|Unsafe] [Allow0.9|Require1.0]
-[StrictWhitespace|LenientWhitespace] [RegisteredMethods|LenientMethods]</a></td><td> Strict Allow0.9 Len +</td><td>sk</td><td>�</td></tr><tr class="odd"><td class="descr" colspan="4">Modify restrictions on HTTP Request Messages</td></tr>
+<tr class="odd"><td><a href="core.html#httpprotocoloptions">HttpProtocolOptions [Strict|Unsafe] [StrictURL|UnsafeURL]
+ [StrictWhitespace|LenientWhitespace] [RegisteredMethods|LenientMethods]
+ [Allow0.9|Require1.0]</a></td><td> Strict StrictURL Le +</td><td>sk</td><td>�</td></tr><tr class="odd"><td class="descr" colspan="4">Modify restrictions on HTTP Request Messages</td></tr>
<tr><td><a href="mod_ident.html#identitycheck" id="I" name="I">IdentityCheck On|Off</a></td><td> Off </td><td>skd</td><td>E</td></tr><tr><td class="descr" colspan="4">Enables logging of the RFC 1413 identity of the remote
user</td></tr>
<tr class="odd"><td><a href="mod_ident.html#identitychecktimeout">IdentityCheckTimeout <var>seconds</var></a></td><td> 30 </td><td>skd</td><td>E</td></tr><tr class="odd"><td class="descr" colspan="4">Determines the timeout duration for ident requests</td></tr>
Modified: httpd/httpd/trunk/docs/manual/mod/quickreference.html.zh-cn.utf8
URL: http://svn.apache.org/viewvc/httpd/httpd/trunk/docs/manual/mod/quickreference.html.zh-cn.utf8?rev=1756979&r1=1756978&r2=1756979&view=diff
==============================================================================
--- httpd/httpd/trunk/docs/manual/mod/quickreference.html.zh-cn.utf8 (original)
+++ httpd/httpd/trunk/docs/manual/mod/quickreference.html.zh-cn.utf8 Sat Aug 20 01:17:51 2016
@@ -531,8 +531,9 @@ heartbeat requests to this server</td></
<tr><td><a href="mod_heartmonitor.html#heartbeatstorage">HeartbeatStorage <var>file-path</var></a></td><td> logs/hb.dat </td><td>s</td><td>X</td></tr><tr><td class="descr" colspan="4">Path to store heartbeat data</td></tr>
<tr class="odd"><td><a href="mod_lbmethod_heartbeat.html#heartbeatstorage">HeartbeatStorage <var>file-path</var></a></td><td> logs/hb.dat </td><td>s</td><td>X</td></tr><tr class="odd"><td class="descr" colspan="4">Path to read heartbeat data</td></tr>
<tr><td><a href="core.html#hostnamelookups">HostnameLookups On|Off|Double</a></td><td> Off </td><td>svd</td><td>C</td></tr><tr><td class="descr" colspan="4">Enables DNS lookups on client IP addresses</td></tr>
-<tr class="odd"><td><a href="core.html#httpprotocoloptions">HttpProtocolOptions [Strict|Unsafe] [Allow0.9|Require1.0]
-[StrictWhitespace|LenientWhitespace] [RegisteredMethods|LenientMethods]</a></td><td> Strict Allow0.9 Len +</td><td>sv</td><td>C</td></tr><tr class="odd"><td class="descr" colspan="4">Modify restrictions on HTTP Request Messages</td></tr>
+<tr class="odd"><td><a href="core.html#httpprotocoloptions">HttpProtocolOptions [Strict|Unsafe] [StrictURL|UnsafeURL]
+ [StrictWhitespace|LenientWhitespace] [RegisteredMethods|LenientMethods]
+ [Allow0.9|Require1.0]</a></td><td> Strict StrictURL Le +</td><td>sv</td><td>C</td></tr><tr class="odd"><td class="descr" colspan="4">Modify restrictions on HTTP Request Messages</td></tr>
<tr><td><a href="mod_ident.html#identitycheck" id="I" name="I">IdentityCheck On|Off</a></td><td> Off </td><td>svd</td><td>E</td></tr><tr><td class="descr" colspan="4">Enables logging of the RFC 1413 identity of the remote
user</td></tr>
<tr class="odd"><td><a href="mod_ident.html#identitychecktimeout">IdentityCheckTimeout <var>seconds</var></a></td><td> 30 </td><td>svd</td><td>E</td></tr><tr class="odd"><td class="descr" colspan="4">Determines the timeout duration for ident requests</td></tr>