You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@flink.apache.org by "Fabian Hueske (JIRA)" <ji...@apache.org> on 2015/04/21 13:02:58 UTC
[jira] [Updated] (FLINK-1890) Add note to docs that ReadFields
annotations are currently not evaluated
[ https://issues.apache.org/jira/browse/FLINK-1890?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]
Fabian Hueske updated FLINK-1890:
---------------------------------
Summary: Add note to docs that ReadFields annotations are currently not evaluated (was: Add withReadFields or sth. similar to Scala API)
> Add note to docs that ReadFields annotations are currently not evaluated
> ------------------------------------------------------------------------
>
> Key: FLINK-1890
> URL: https://issues.apache.org/jira/browse/FLINK-1890
> Project: Flink
> Issue Type: Wish
> Components: Java API, Scala API
> Reporter: Stefan Bunk
> Priority: Minor
>
> In the Scala API, you have the option to declare forwarded fields via the
> {{withForwardedFields}} method.
> It would be nice to have sth. similar for read fields, as otherwise one needs to create a class, which I personally try to avoid for readability.
> Maybe grouping all annotations in one function and have a first parameter indicating the type of annotation is also an option, if you plan on adding more annotations and want to keep the interface smaller.
--
This message was sent by Atlassian JIRA
(v6.3.4#6332)