You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@ozone.apache.org by "Kirill Sizov (Jira)" <ji...@apache.org> on 2024/01/31 14:19:00 UTC
[jira] [Updated] (HDDS-10262) Encapsulate SnapshotCache inside OmSnapshotManager
[ https://issues.apache.org/jira/browse/HDDS-10262?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]
Kirill Sizov updated HDDS-10262:
--------------------------------
Status: Patch Available (was: In Progress)
> Encapsulate SnapshotCache inside OmSnapshotManager
> --------------------------------------------------
>
> Key: HDDS-10262
> URL: https://issues.apache.org/jira/browse/HDDS-10262
> Project: Apache Ozone
> Issue Type: Sub-task
> Reporter: Kirill Sizov
> Assignee: Kirill Sizov
> Priority: Major
> Labels: pull-request-available
>
> {{SnapshotCache}} is an in-memory storage for the currently open {{OmSnapshot}} instances.
> It is currently publicly accessible through {{OmSnapshotManager.getSnapshotCache()}}, thus any change to its internals (like switching it to SnapshotId - see HDDS-10250) may affect many unrelated places.
> To make further changes to {{SnapshotCache}} smaller and reduce code duplication, this class should be fully encapsulated inside {{OmSnapshotManager}}.
--
This message was sent by Atlassian Jira
(v8.20.10#820010)
---------------------------------------------------------------------
To unsubscribe, e-mail: issues-unsubscribe@ozone.apache.org
For additional commands, e-mail: issues-help@ozone.apache.org