You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@maven.apache.org by ji...@codehaus.org on 2004/06/28 23:54:16 UTC

[jira] Commented: (MPECLIPSE-18) Patch to add support for custom project names in dependencies

The following comment has been added to this issue:

     Author: David Eric Pugh
    Created: Mon, 28 Jun 2004 5:52 PM
       Body:
Why would you want to change the name of the dependency?  Should you be using the version that you are referencing in Maven, versus a different kind?  Otherwise what Maven builds against will be different list of dependencis from what Eclipse builds again, correct?
---------------------------------------------------------------------
View this comment:
  http://jira.codehaus.org/browse/MPECLIPSE-18?page=comments#action_21124

---------------------------------------------------------------------
View the issue:
  http://jira.codehaus.org/browse/MPECLIPSE-18

Here is an overview of the issue:
---------------------------------------------------------------------
        Key: MPECLIPSE-18
    Summary: Patch to add support for custom project names in dependencies
       Type: Improvement

     Status: Unassigned
   Priority: Minor

 Original Estimate: 10 minutes
 Time Spent: Unknown
  Remaining: 10 minutes

    Project: maven-eclipse-plugin
   Versions:
             1.6

   Assignee: 
   Reporter: Rob Dupuis

    Created: Tue, 10 Feb 2004 11:30 AM
    Updated: Mon, 28 Jun 2004 5:52 PM

Description:
I'm working on a project in which the aritfact name does not match the eclipse project name. I've created patches to support a new project.xml dependency property called eclipse.dependency.name, which allows you to specify a custom project name for a dependency.

eg Before:

<dependency>
  <groupId>kizoom</groupId> 
  <artifactId>common</artifactId>
  <version>1</version>
  <properties>
    <eclipse.dependency>true</eclipse.dependency>
  </properties>
</dependency>

After:
<dependency>
  <groupId>kizoom</groupId> 
  <artifactId>common</artifactId>
  <version>1</version>
  <properties>
    <eclipse.dependency>true</eclipse.dependency>
    <eclipse.dependency.name>KizoomCommon</eclipse.dependency.name>
  </properties>
</dependency>

Not sure about the name eclipse.dependency.name, should this be eclipse.dependency.project.name or maybe eclipse.dependency.project?


---------------------------------------------------------------------
JIRA INFORMATION:
This message is automatically generated by JIRA.

If you think it was sent incorrectly contact one of the administrators:
   http://jira.codehaus.org/secure/Administrators.jspa

If you want more information on JIRA, or have a bug to report see:
   http://www.atlassian.com/software/jira


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@maven.apache.org
For additional commands, e-mail: dev-help@maven.apache.org