You are viewing a plain text version of this content. The canonical link for it is here.
Posted to jira@arrow.apache.org by "Krisztian Szucs (Jira)" <ji...@apache.org> on 2020/10/07 22:31:00 UTC
[jira] [Commented] (ARROW-10215) [Rust] [DataFusion] Rename
"Source" typedef
[ https://issues.apache.org/jira/browse/ARROW-10215?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=17209906#comment-17209906 ]
Krisztian Szucs commented on ARROW-10215:
-----------------------------------------
Postponing to 3.0.
> [Rust] [DataFusion] Rename "Source" typedef
> -------------------------------------------
>
> Key: ARROW-10215
> URL: https://issues.apache.org/jira/browse/ARROW-10215
> Project: Apache Arrow
> Issue Type: Improvement
> Components: Rust, Rust - DataFusion
> Reporter: Andy Grove
> Priority: Minor
> Fix For: 3.0.0
>
>
> The name "Source" for this type doesn't make sense to me. I would like to discuss alternate names for it.
> {code:java}
> type Source = Box<dyn RecordBatchReader + Send>; {code}
> My first thoughts are:
> * RecordBatchIterator
> * RecordBatchStream
> * SendableRecordBatchReader
--
This message was sent by Atlassian Jira
(v8.3.4#803005)