You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@camel.apache.org by "Claus Ibsen (JIRA)" <ji...@apache.org> on 2009/04/22 08:11:33 UTC

[jira] Created: (CAMEL-1557) ThrowFault - Should be renamed to ThrowException and be exception based instead of FAULT

ThrowFault - Should be renamed to ThrowException and be exception based instead of FAULT
----------------------------------------------------------------------------------------

                 Key: CAMEL-1557
                 URL: https://issues.apache.org/activemq/browse/CAMEL-1557
             Project: Apache Camel
          Issue Type: Task
    Affects Versions: 2.0-M1
            Reporter: Claus Ibsen
             Fix For: 2.0.0


Camel uses Exceptions for errors and it would be more useable to be able to set an exception on the Exchange.

Also in line what Hadrian wanted to "merge the FAULT and Exception" into using Exception only. There is a ticket for this somewhere.


-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


[jira] Assigned: (CAMEL-1557) ThrowFault - Should be renamed to ThrowException and be exception based instead of FAULT

Posted by "Claus Ibsen (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/activemq/browse/CAMEL-1557?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Claus Ibsen reassigned CAMEL-1557:
----------------------------------

    Assignee: Claus Ibsen

> ThrowFault - Should be renamed to ThrowException and be exception based instead of FAULT
> ----------------------------------------------------------------------------------------
>
>                 Key: CAMEL-1557
>                 URL: https://issues.apache.org/activemq/browse/CAMEL-1557
>             Project: Apache Camel
>          Issue Type: Task
>    Affects Versions: 2.0-M1
>            Reporter: Claus Ibsen
>            Assignee: Claus Ibsen
>             Fix For: 2.0.0
>
>
> Camel uses Exceptions for errors and it would be more useable to be able to set an exception on the Exchange.
> Also in line what Hadrian wanted to "merge the FAULT and Exception" into using Exception only. There is a ticket for this somewhere.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


[jira] Resolved: (CAMEL-1557) ThrowFault - Should be renamed to ThrowException and be exception based instead of FAULT

Posted by "Claus Ibsen (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/activemq/browse/CAMEL-1557?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Claus Ibsen resolved CAMEL-1557.
--------------------------------

    Resolution: Fixed

trunk: 775844

{{throwFault}} removed. Added {{throwException}} instead.

> ThrowFault - Should be renamed to ThrowException and be exception based instead of FAULT
> ----------------------------------------------------------------------------------------
>
>                 Key: CAMEL-1557
>                 URL: https://issues.apache.org/activemq/browse/CAMEL-1557
>             Project: Apache Camel
>          Issue Type: Task
>    Affects Versions: 2.0-M1
>            Reporter: Claus Ibsen
>            Assignee: Claus Ibsen
>             Fix For: 2.0.0
>
>
> Camel uses Exceptions for errors and it would be more useable to be able to set an exception on the Exchange.
> Also in line what Hadrian wanted to "merge the FAULT and Exception" into using Exception only. There is a ticket for this somewhere.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.