You are viewing a plain text version of this content. The canonical link for it is here.
Posted to derby-dev@db.apache.org by "Mamta A. Satoor (JIRA)" <de...@db.apache.org> on 2006/08/31 01:05:22 UTC
[jira] Created: (DERBY-1787) The database owner is incorrectly
referred to as dba in the code comments that were checked in Derby 10.2 for
grant revoke work. We should clean this up at some point.
The database owner is incorrectly referred to as dba in the code comments that were checked in Derby 10.2 for grant revoke work. We should clean this up at some point.
-----------------------------------------------------------------------------------------------------------------------------------------------------------------------
Key: DERBY-1787
URL: http://issues.apache.org/jira/browse/DERBY-1787
Project: Derby
Issue Type: Improvement
Components: SQL
Affects Versions: 10.2.1.0
Reporter: Mamta A. Satoor
Priority: Minor
Grant revoke functionality was added in Derby 10.2 The comments that went into the grant revoke code, in some places refer to database owner as "dba". They are not the same thing. In the grant revoke world, dba is a role. We haven't added roles into Derby yet but current use of dba in comments might make it confusing when we do start working on roles including dba.
--
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira
[jira] Commented: (DERBY-1787) The database owner is incorrectly
referred to as dba in the code comments that were checked in Derby 10.2 for
grant revoke work. We should clean this up at some point.
Posted by "Yip Ng (JIRA)" <de...@db.apache.org>.
[ http://issues.apache.org/jira/browse/DERBY-1787?page=comments#action_12436317 ]
Yip Ng commented on DERBY-1787:
-------------------------------
Hi Mamta, thanks for cleaning up the comment and code for clarity. I applied the patch and it compiles cleanly. I also ran derbylang suite and it passed without any problem.
> The database owner is incorrectly referred to as dba in the code comments that were checked in Derby 10.2 for grant revoke work. We should clean this up at some point.
> -----------------------------------------------------------------------------------------------------------------------------------------------------------------------
>
> Key: DERBY-1787
> URL: http://issues.apache.org/jira/browse/DERBY-1787
> Project: Derby
> Issue Type: Improvement
> Components: SQL
> Affects Versions: 10.2.1.0
> Reporter: Mamta A. Satoor
> Assigned To: Mamta A. Satoor
> Priority: Minor
> Attachments: DERBY1787_UseCorrectTerminologyV1diff.txt
>
>
> Grant revoke functionality was added in Derby 10.2 The comments that went into the grant revoke code, in some places refer to database owner as "dba". They are not the same thing. In the grant revoke world, dba is a role. We haven't added roles into Derby yet but current use of dba in comments might make it confusing when we do start working on roles including dba.
--
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira
[jira] Updated: (DERBY-1787) The database owner is incorrectly
referred to as dba in the code comments that were checked in Derby 10.2 for
grant revoke work. We should clean this up at some point.
Posted by "Mamta A. Satoor (JIRA)" <de...@db.apache.org>.
[ http://issues.apache.org/jira/browse/DERBY-1787?page=all ]
Mamta A. Satoor updated DERBY-1787:
-----------------------------------
Attachment: DERBY1787_UseCorrectTerminologyV1diff.txt
Attaching a simple patch which fixes the comments and method names related to this Jira entry. The files affected are as followis
svn stat -q
$ svn stat -q
M java\engine\org\apache\derby\impl\sql\conn\GenericAuthorizer.java
M java\engine\org\apache\derby\impl\sql\execute\PrivilegeInfo.java
M java\engine\org\apache\derby\impl\sql\execute\TablePrivilegeInfo.java
M java\engine\org\apache\derby\impl\sql\execute\DDLConstantAction.java
M java\engine\org\apache\derby\impl\sql\catalog\DataDictionaryImpl.java
M java\engine\org\apache\derby\impl\sql\catalog\DD_Version.java
M java\engine\org\apache\derby\iapi\sql\dictionary\StatementSchemaPermission.java
M java\engine\org\apache\derby\iapi\sql\dictionary\DataDictionary.java
> The database owner is incorrectly referred to as dba in the code comments that were checked in Derby 10.2 for grant revoke work. We should clean this up at some point.
> -----------------------------------------------------------------------------------------------------------------------------------------------------------------------
>
> Key: DERBY-1787
> URL: http://issues.apache.org/jira/browse/DERBY-1787
> Project: Derby
> Issue Type: Improvement
> Components: SQL
> Affects Versions: 10.2.1.0
> Reporter: Mamta A. Satoor
> Priority: Minor
> Attachments: DERBY1787_UseCorrectTerminologyV1diff.txt
>
>
> Grant revoke functionality was added in Derby 10.2 The comments that went into the grant revoke code, in some places refer to database owner as "dba". They are not the same thing. In the grant revoke world, dba is a role. We haven't added roles into Derby yet but current use of dba in comments might make it confusing when we do start working on roles including dba.
--
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira
[jira] Updated: (DERBY-1787) The database owner is incorrectly
referred to as dba in the code comments that were checked in Derby 10.2 for
grant revoke work. We should clean this up at some point.
Posted by "Mike Matrigali (JIRA)" <de...@db.apache.org>.
[ http://issues.apache.org/jira/browse/DERBY-1787?page=all ]
Mike Matrigali updated DERBY-1787:
----------------------------------
Fix Version/s: 10.3.0.0
committed change to the trunk.
m1_ibm142:142>svn commit
Sending java\engine\org\apache\derby\iapi\sql\dictionary\DataDictionary.
ava
Sending java\engine\org\apache\derby\iapi\sql\dictionary\StatementSchema
ermission.java
Sending java\engine\org\apache\derby\impl\sql\catalog\DD_Version.java
Sending java\engine\org\apache\derby\impl\sql\catalog\DataDictionaryImpl
java
Sending java\engine\org\apache\derby\impl\sql\conn\GenericAuthorizer.jav
Sending java\engine\org\apache\derby\impl\sql\execute\DDLConstantAction.
ava
Sending java\engine\org\apache\derby\impl\sql\execute\PrivilegeInfo.java
Sending java\engine\org\apache\derby\impl\sql\execute\TablePrivilegeInfo
java
Transmitting file data ........
Committed revision 448424.
> The database owner is incorrectly referred to as dba in the code comments that were checked in Derby 10.2 for grant revoke work. We should clean this up at some point.
> -----------------------------------------------------------------------------------------------------------------------------------------------------------------------
>
> Key: DERBY-1787
> URL: http://issues.apache.org/jira/browse/DERBY-1787
> Project: Derby
> Issue Type: Improvement
> Components: SQL
> Affects Versions: 10.2.1.0
> Reporter: Mamta A. Satoor
> Assigned To: Mamta A. Satoor
> Priority: Minor
> Fix For: 10.3.0.0
>
> Attachments: DERBY1787_UseCorrectTerminologyV1diff.txt
>
>
> Grant revoke functionality was added in Derby 10.2 The comments that went into the grant revoke code, in some places refer to database owner as "dba". They are not the same thing. In the grant revoke world, dba is a role. We haven't added roles into Derby yet but current use of dba in comments might make it confusing when we do start working on roles including dba.
--
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira
[jira] Resolved: (DERBY-1787) The database owner is incorrectly
referred to as dba in the code comments that were checked in Derby 10.2 for
grant revoke work. We should clean this up at some point.
Posted by "Andrew McIntyre (JIRA)" <de...@db.apache.org>.
[ http://issues.apache.org/jira/browse/DERBY-1787?page=all ]
Andrew McIntyre resolved DERBY-1787.
------------------------------------
Resolution: Fixed
Derby Info: (was: [Patch Available])
Marked resolved, merged to 10.2 with revision 449004.
> The database owner is incorrectly referred to as dba in the code comments that were checked in Derby 10.2 for grant revoke work. We should clean this up at some point.
> -----------------------------------------------------------------------------------------------------------------------------------------------------------------------
>
> Key: DERBY-1787
> URL: http://issues.apache.org/jira/browse/DERBY-1787
> Project: Derby
> Issue Type: Improvement
> Components: SQL
> Affects Versions: 10.2.1.0
> Reporter: Mamta A. Satoor
> Assigned To: Mamta A. Satoor
> Priority: Minor
> Fix For: 10.2.1.0, 10.3.0.0
>
> Attachments: DERBY1787_UseCorrectTerminologyV1diff.txt
>
>
> Grant revoke functionality was added in Derby 10.2 The comments that went into the grant revoke code, in some places refer to database owner as "dba". They are not the same thing. In the grant revoke world, dba is a role. We haven't added roles into Derby yet but current use of dba in comments might make it confusing when we do start working on roles including dba.
--
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira
[jira] Updated: (DERBY-1787) The database owner is incorrectly
referred to as dba in the code comments that were checked in Derby 10.2 for
grant revoke work. We should clean this up at some point.
Posted by "Mamta A. Satoor (JIRA)" <de...@db.apache.org>.
[ http://issues.apache.org/jira/browse/DERBY-1787?page=all ]
Mamta A. Satoor updated DERBY-1787:
-----------------------------------
Assignee: Mamta A. Satoor
Derby Info: [Patch Available]
> The database owner is incorrectly referred to as dba in the code comments that were checked in Derby 10.2 for grant revoke work. We should clean this up at some point.
> -----------------------------------------------------------------------------------------------------------------------------------------------------------------------
>
> Key: DERBY-1787
> URL: http://issues.apache.org/jira/browse/DERBY-1787
> Project: Derby
> Issue Type: Improvement
> Components: SQL
> Affects Versions: 10.2.1.0
> Reporter: Mamta A. Satoor
> Assigned To: Mamta A. Satoor
> Priority: Minor
> Attachments: DERBY1787_UseCorrectTerminologyV1diff.txt
>
>
> Grant revoke functionality was added in Derby 10.2 The comments that went into the grant revoke code, in some places refer to database owner as "dba". They are not the same thing. In the grant revoke world, dba is a role. We haven't added roles into Derby yet but current use of dba in comments might make it confusing when we do start working on roles including dba.
--
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira
[jira] Updated: (DERBY-1787) The database owner is incorrectly
referred to as dba in the code comments that were checked in Derby 10.2 for
grant revoke work. We should clean this up at some point.
Posted by "Mamta A. Satoor (JIRA)" <de...@db.apache.org>.
[ http://issues.apache.org/jira/browse/DERBY-1787?page=all ]
Mamta A. Satoor updated DERBY-1787:
-----------------------------------
Fix Version/s: 10.2.1.0
The patch got merged into 10.2 codeline as part of revision 449004
> The database owner is incorrectly referred to as dba in the code comments that were checked in Derby 10.2 for grant revoke work. We should clean this up at some point.
> -----------------------------------------------------------------------------------------------------------------------------------------------------------------------
>
> Key: DERBY-1787
> URL: http://issues.apache.org/jira/browse/DERBY-1787
> Project: Derby
> Issue Type: Improvement
> Components: SQL
> Affects Versions: 10.2.1.0
> Reporter: Mamta A. Satoor
> Assigned To: Mamta A. Satoor
> Priority: Minor
> Fix For: 10.2.1.0, 10.3.0.0
>
> Attachments: DERBY1787_UseCorrectTerminologyV1diff.txt
>
>
> Grant revoke functionality was added in Derby 10.2 The comments that went into the grant revoke code, in some places refer to database owner as "dba". They are not the same thing. In the grant revoke world, dba is a role. We haven't added roles into Derby yet but current use of dba in comments might make it confusing when we do start working on roles including dba.
--
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira