You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@hbase.apache.org by "Jesse Yates (JIRA)" <ji...@apache.org> on 2012/08/30 18:20:07 UTC

[jira] [Resolved] (HBASE-5016) LoadBalancerFactory - "maser" in package name of dynamically loaded balancer class?

     [ https://issues.apache.org/jira/browse/HBASE-5016?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Jesse Yates resolved HBASE-5016.
--------------------------------

    Resolution: Fixed

Fixed in trunk - closing.
                
> LoadBalancerFactory - "maser" in package name of dynamically loaded balancer class?
> -----------------------------------------------------------------------------------
>
>                 Key: HBASE-5016
>                 URL: https://issues.apache.org/jira/browse/HBASE-5016
>             Project: HBase
>          Issue Type: Bug
>            Reporter: Doug Meil
>
> Shouldn't this... "hbase.maser.loadBalancer.class" be something like "hbase.master.loadBalancer.class"?  What's with "maser"?
> {code}
> /**
>  * The class that creates a load balancer from a conf.
>  */
> public class LoadBalancerFactory {
>   /**
>    * Create a loadblanacer from the given conf.
>    * @param conf
>    * @return A {@link LoadBalancer}
>    */
>   public static LoadBalancer getLoadBalancer(Configuration conf) {
>     // Create the balancer
>     Class<? extends LoadBalancer> balancerKlass = conf.getClass("hbase.maser.loadBalancer.class",DefaultLoadBalancer.class, LoadBalancer.class);
>     return ReflectionUtils.newInstance(balancerKlass, conf);
>   }
> }
> {code}

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira