You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@hama.apache.org by "Hyunsik Choi (JIRA)" <ji...@apache.org> on 2010/06/03 03:59:57 UTC

[jira] Created: (HAMA-270) wrong sequence of readFields() of ClusterStatus

wrong sequence of readFields() of ClusterStatus
-----------------------------------------------

                 Key: HAMA-270
                 URL: https://issues.apache.org/jira/browse/HAMA-270
             Project: Hama
          Issue Type: Bug
          Components: bsp
    Affects Versions: 0.2.0
            Reporter: Hyunsik Choi
            Assignee: Hyunsik Choi
             Fix For: 0.2.0


in write method
{code}

...
out.writeInt(activeGrooms.size());
for(String groom: activeGrooms) {
        Text.writeString(out, groom);
}
...
{code}

But, readFields method has wrong sequence as follows:
{code}
...
if (numGroomNames > 0) {
      name = Text.readString(in);
      activeGrooms.add(name);
}
...
{/code}

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


[jira] Updated: (HAMA-270) wrong sequence of readFields() of ClusterStatus

Posted by "Hyunsik Choi (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/HAMA-270?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Hyunsik Choi updated HAMA-270:
------------------------------

    Status: Open  (was: Patch Available)

The test unit class's name is wrong. In order to correct the class name, I will attach a fixed patch.

> wrong sequence of readFields() of ClusterStatus
> -----------------------------------------------
>
>                 Key: HAMA-270
>                 URL: https://issues.apache.org/jira/browse/HAMA-270
>             Project: Hama
>          Issue Type: Bug
>          Components: bsp
>    Affects Versions: 0.2.0
>            Reporter: Hyunsik Choi
>            Assignee: Hyunsik Choi
>             Fix For: 0.2.0
>
>         Attachments: HAMA-270.patch
>
>
> in write method
> {code}
> ...
> out.writeInt(activeGrooms.size());
> for(String groom: activeGrooms) {
>         Text.writeString(out, groom);
> }
> ...
> {code}
> But, readFields method has wrong sequence as follows:
> {code}
> ...
> if (numGroomNames > 0) {
>       name = Text.readString(in);
>       activeGrooms.add(name);
> }
> ...
> {code}

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


[jira] Commented: (HAMA-270) wrong sequence of readFields() of ClusterStatus

Posted by "Hudson (JIRA)" <ji...@apache.org>.
    [ https://issues.apache.org/jira/browse/HAMA-270?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12882927#action_12882927 ] 

Hudson commented on HAMA-270:
-----------------------------

Integrated in Hama-Patch #255 (See [http://hudson.zones.apache.org/hudson/job/Hama-Patch/255/])
    

> wrong sequence of readFields() of ClusterStatus
> -----------------------------------------------
>
>                 Key: HAMA-270
>                 URL: https://issues.apache.org/jira/browse/HAMA-270
>             Project: Hama
>          Issue Type: Bug
>          Components: bsp
>    Affects Versions: 0.2.0
>            Reporter: Hyunsik Choi
>            Assignee: Hyunsik Choi
>             Fix For: 0.2.0
>
>         Attachments: HAMA-270.patch, HAMA-270_2.patch
>
>
> in write method
> {code}
> ...
> out.writeInt(activeGrooms.size());
> for(String groom: activeGrooms) {
>         Text.writeString(out, groom);
> }
> ...
> {code}
> But, readFields method has wrong sequence as follows:
> {code}
> ...
> if (numGroomNames > 0) {
>       name = Text.readString(in);
>       activeGrooms.add(name);
> }
> ...
> {code}

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


[jira] Updated: (HAMA-270) wrong sequence of readFields() of ClusterStatus

Posted by "Hyunsik Choi (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/HAMA-270?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Hyunsik Choi updated HAMA-270:
------------------------------

        Status: Resolved  (was: Patch Available)
    Resolution: Fixed

All unit tests are passed, so I just committed.

http://hudson.zones.apache.org/hudson/job/Hama-Patch/252/console
======================================================================
    Adding comment to Jira.
======================================================================

+1 overall.  Here are the results of testing the latest attachment 
http://issues.apache.org/jira/secure/attachment/12446241/HAMA-270_2.patch
against trunk revision 950911.

    @author +1.  The patch does not contain any @author tags.

    tests included +1.  The patch appears to include 3 new or modified tests.

    javadoc +1.  The javadoc tool did not generate any warning messages.

    javac +1.  The applied patch does not generate any new javac compiler warnings.

    release audit +1.  The applied patch does not generate any new release audit warnings.

    findbugs +1.  The patch does not introduce any new Findbugs warnings.

    core tests +1.  The patch passed core unit tests.

Test results: http://hudson.zones.apache.org/hudson/job/Hama-Patch/252/testReport/
Findbugs warnings: http://hudson.zones.apache.org/hudson/job/Hama-Patch/252/findbugsResult/
Checkstyle results: http://hudson.zones.apache.org/hudson/job/Hama-Patch/252/artifact/trunk/build/test/checkstyle-errors.html
Console output: http://hudson.zones.apache.org/hudson/job/Hama-Patch/252/console

This message is automatically generated.

> wrong sequence of readFields() of ClusterStatus
> -----------------------------------------------
>
>                 Key: HAMA-270
>                 URL: https://issues.apache.org/jira/browse/HAMA-270
>             Project: Hama
>          Issue Type: Bug
>          Components: bsp
>    Affects Versions: 0.2.0
>            Reporter: Hyunsik Choi
>            Assignee: Hyunsik Choi
>             Fix For: 0.2.0
>
>         Attachments: HAMA-270.patch, HAMA-270_2.patch
>
>
> in write method
> {code}
> ...
> out.writeInt(activeGrooms.size());
> for(String groom: activeGrooms) {
>         Text.writeString(out, groom);
> }
> ...
> {code}
> But, readFields method has wrong sequence as follows:
> {code}
> ...
> if (numGroomNames > 0) {
>       name = Text.readString(in);
>       activeGrooms.add(name);
> }
> ...
> {code}

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


[jira] Updated: (HAMA-270) wrong sequence of readFields() of ClusterStatus

Posted by "Hyunsik Choi (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/HAMA-270?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Hyunsik Choi updated HAMA-270:
------------------------------

    Status: Patch Available  (was: Open)

I pass the patch to hudson.

> wrong sequence of readFields() of ClusterStatus
> -----------------------------------------------
>
>                 Key: HAMA-270
>                 URL: https://issues.apache.org/jira/browse/HAMA-270
>             Project: Hama
>          Issue Type: Bug
>          Components: bsp
>    Affects Versions: 0.2.0
>            Reporter: Hyunsik Choi
>            Assignee: Hyunsik Choi
>             Fix For: 0.2.0
>
>         Attachments: HAMA-270.patch, HAMA-270_2.patch
>
>
> in write method
> {code}
> ...
> out.writeInt(activeGrooms.size());
> for(String groom: activeGrooms) {
>         Text.writeString(out, groom);
> }
> ...
> {code}
> But, readFields method has wrong sequence as follows:
> {code}
> ...
> if (numGroomNames > 0) {
>       name = Text.readString(in);
>       activeGrooms.add(name);
> }
> ...
> {code}

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


[jira] Updated: (HAMA-270) wrong sequence of readFields() of ClusterStatus

Posted by "Hyunsik Choi (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/HAMA-270?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Hyunsik Choi updated HAMA-270:
------------------------------

    Status: Patch Available  (was: Open)

I pass the patch to hudson.

> wrong sequence of readFields() of ClusterStatus
> -----------------------------------------------
>
>                 Key: HAMA-270
>                 URL: https://issues.apache.org/jira/browse/HAMA-270
>             Project: Hama
>          Issue Type: Bug
>          Components: bsp
>    Affects Versions: 0.2.0
>            Reporter: Hyunsik Choi
>            Assignee: Hyunsik Choi
>             Fix For: 0.2.0
>
>         Attachments: HAMA-270.patch
>
>
> in write method
> {code}
> ...
> out.writeInt(activeGrooms.size());
> for(String groom: activeGrooms) {
>         Text.writeString(out, groom);
> }
> ...
> {code}
> But, readFields method has wrong sequence as follows:
> {code}
> ...
> if (numGroomNames > 0) {
>       name = Text.readString(in);
>       activeGrooms.add(name);
> }
> ...
> {code}

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


[jira] Updated: (HAMA-270) wrong sequence of readFields() of ClusterStatus

Posted by "Gavin (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/HAMA-270?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Gavin updated HAMA-270:
-----------------------

    Description: 
in write method
{code}

...
out.writeInt(activeGrooms.size());
for(String groom: activeGrooms) {
        Text.writeString(out, groom);
}
...
{/code}

But, readFields method has wrong sequence as follows:
{code}
...
if (numGroomNames > 0) {
      name = Text.readString(in);
      activeGrooms.add(name);
}
...
{/code}

  was:
in write method
{code}

...
out.writeInt(activeGrooms.size());
for(String groom: activeGrooms) {
        Text.writeString(out, groom);
}
...
{code}

But, readFields method has wrong sequence as follows:
{code}
...
if (numGroomNames > 0) {
      name = Text.readString(in);
      activeGrooms.add(name);
}
...
{/code}


> wrong sequence of readFields() of ClusterStatus
> -----------------------------------------------
>
>                 Key: HAMA-270
>                 URL: https://issues.apache.org/jira/browse/HAMA-270
>             Project: Hama
>          Issue Type: Bug
>          Components: bsp
>    Affects Versions: 0.2.0
>            Reporter: Hyunsik Choi
>            Assignee: Hyunsik Choi
>             Fix For: 0.2.0
>
>         Attachments: HAMA-270.patch
>
>
> in write method
> {code}
> ...
> out.writeInt(activeGrooms.size());
> for(String groom: activeGrooms) {
>         Text.writeString(out, groom);
> }
> ...
> {/code}
> But, readFields method has wrong sequence as follows:
> {code}
> ...
> if (numGroomNames > 0) {
>       name = Text.readString(in);
>       activeGrooms.add(name);
> }
> ...
> {/code}

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


[jira] Updated: (HAMA-270) wrong sequence of readFields() of ClusterStatus

Posted by "Hyunsik Choi (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/HAMA-270?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Hyunsik Choi updated HAMA-270:
------------------------------

    Attachment: HAMA-270.patch

I attach the patch and its test unit.

> wrong sequence of readFields() of ClusterStatus
> -----------------------------------------------
>
>                 Key: HAMA-270
>                 URL: https://issues.apache.org/jira/browse/HAMA-270
>             Project: Hama
>          Issue Type: Bug
>          Components: bsp
>    Affects Versions: 0.2.0
>            Reporter: Hyunsik Choi
>            Assignee: Hyunsik Choi
>             Fix For: 0.2.0
>
>         Attachments: HAMA-270.patch
>
>
> in write method
> {code}
> ...
> out.writeInt(activeGrooms.size());
> for(String groom: activeGrooms) {
>         Text.writeString(out, groom);
> }
> ...
> {code}
> But, readFields method has wrong sequence as follows:
> {code}
> ...
> if (numGroomNames > 0) {
>       name = Text.readString(in);
>       activeGrooms.add(name);
> }
> ...
> {/code}

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


[jira] Commented: (HAMA-270) wrong sequence of readFields() of ClusterStatus

Posted by "Edward J. Yoon (JIRA)" <ji...@apache.org>.
    [ https://issues.apache.org/jira/browse/HAMA-270?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12874954#action_12874954 ] 

Edward J. Yoon commented on HAMA-270:
-------------------------------------

+1

> wrong sequence of readFields() of ClusterStatus
> -----------------------------------------------
>
>                 Key: HAMA-270
>                 URL: https://issues.apache.org/jira/browse/HAMA-270
>             Project: Hama
>          Issue Type: Bug
>          Components: bsp
>    Affects Versions: 0.2.0
>            Reporter: Hyunsik Choi
>            Assignee: Hyunsik Choi
>             Fix For: 0.2.0
>
>         Attachments: HAMA-270.patch
>
>
> in write method
> {code}
> ...
> out.writeInt(activeGrooms.size());
> for(String groom: activeGrooms) {
>         Text.writeString(out, groom);
> }
> ...
> {code}
> But, readFields method has wrong sequence as follows:
> {code}
> ...
> if (numGroomNames > 0) {
>       name = Text.readString(in);
>       activeGrooms.add(name);
> }
> ...
> {code}

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


[jira] Updated: (HAMA-270) wrong sequence of readFields() of ClusterStatus

Posted by "Gavin (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/HAMA-270?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Gavin updated HAMA-270:
-----------------------

    Description: 
in write method
{code}

...
out.writeInt(activeGrooms.size());
for(String groom: activeGrooms) {
        Text.writeString(out, groom);
}
...
{code}

But, readFields method has wrong sequence as follows:
{code}
...
if (numGroomNames > 0) {
      name = Text.readString(in);
      activeGrooms.add(name);
}
...
{code}

  was:
in write method
{code}

...
out.writeInt(activeGrooms.size());
for(String groom: activeGrooms) {
        Text.writeString(out, groom);
}
...
{/code}

But, readFields method has wrong sequence as follows:
{code}
...
if (numGroomNames > 0) {
      name = Text.readString(in);
      activeGrooms.add(name);
}
...
{/code}


> wrong sequence of readFields() of ClusterStatus
> -----------------------------------------------
>
>                 Key: HAMA-270
>                 URL: https://issues.apache.org/jira/browse/HAMA-270
>             Project: Hama
>          Issue Type: Bug
>          Components: bsp
>    Affects Versions: 0.2.0
>            Reporter: Hyunsik Choi
>            Assignee: Hyunsik Choi
>             Fix For: 0.2.0
>
>         Attachments: HAMA-270.patch
>
>
> in write method
> {code}
> ...
> out.writeInt(activeGrooms.size());
> for(String groom: activeGrooms) {
>         Text.writeString(out, groom);
> }
> ...
> {code}
> But, readFields method has wrong sequence as follows:
> {code}
> ...
> if (numGroomNames > 0) {
>       name = Text.readString(in);
>       activeGrooms.add(name);
> }
> ...
> {code}

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


[jira] Updated: (HAMA-270) wrong sequence of readFields() of ClusterStatus

Posted by "Hyunsik Choi (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/HAMA-270?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Hyunsik Choi updated HAMA-270:
------------------------------

    Attachment: HAMA-270_2.patch

I attach the fixed patch.

> wrong sequence of readFields() of ClusterStatus
> -----------------------------------------------
>
>                 Key: HAMA-270
>                 URL: https://issues.apache.org/jira/browse/HAMA-270
>             Project: Hama
>          Issue Type: Bug
>          Components: bsp
>    Affects Versions: 0.2.0
>            Reporter: Hyunsik Choi
>            Assignee: Hyunsik Choi
>             Fix For: 0.2.0
>
>         Attachments: HAMA-270.patch, HAMA-270_2.patch
>
>
> in write method
> {code}
> ...
> out.writeInt(activeGrooms.size());
> for(String groom: activeGrooms) {
>         Text.writeString(out, groom);
> }
> ...
> {code}
> But, readFields method has wrong sequence as follows:
> {code}
> ...
> if (numGroomNames > 0) {
>       name = Text.readString(in);
>       activeGrooms.add(name);
> }
> ...
> {code}

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.