You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@ozone.apache.org by "Chia-Chuan Yu (Jira)" <ji...@apache.org> on 2025/04/06 15:15:00 UTC

[jira] [Commented] (HDDS-12774) Improve TestBucket

    [ https://issues.apache.org/jira/browse/HDDS-12774?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=17941388#comment-17941388 ] 

Chia-Chuan Yu commented on HDDS-12774:
--------------------------------------

Hi, [~adoroszlai] 

it seems to related to  {{TestHelper#createKey}} and {{{}TestDataUtil#createKey{}}},

can I help on this one? thanks!

> Improve TestBucket
> ------------------
>
>                 Key: HDDS-12774
>                 URL: https://issues.apache.org/jira/browse/HDDS-12774
>             Project: Apache Ozone
>          Issue Type: Sub-task
>          Components: test
>            Reporter: Attila Doroszlai
>            Assignee: Attila Doroszlai
>            Priority: Major
>
> - Allow setting volume and volume/bucket name in {{TestBucket.Builder}} (see TODO comments)
> - The name {{TestBucket}} indicates it is a test, but in reality it is a helper.  Rename the class according to naming conventions (e.g. BucketForTest).
> - Use it instead of {{TestHelper#createKey}} and {{TestDataUtil#createKey}}.



--
This message was sent by Atlassian Jira
(v8.20.10#820010)

---------------------------------------------------------------------
To unsubscribe, e-mail: issues-unsubscribe@ozone.apache.org
For additional commands, e-mail: issues-help@ozone.apache.org