You are viewing a plain text version of this content. The canonical link for it is here.
Posted to commits@spark.apache.org by ru...@apache.org on 2026/05/06 10:04:50 UTC

(spark) branch master updated: [MINOR][PYTHON][TESTS] Rename `test_utils` to `test_parity_utils` for Connect parity convention

This is an automated email from the ASF dual-hosted git repository.

zhengruifeng pushed a commit to branch master
in repository https://gitbox.apache.org/repos/asf/spark.git


The following commit(s) were added to refs/heads/master by this push:
     new d23148e3dd93 [MINOR][PYTHON][TESTS] Rename `test_utils` to `test_parity_utils` for Connect parity convention
d23148e3dd93 is described below

commit d23148e3dd93f493be3fe2e49193fdb566c535df
Author: Ruifeng Zheng <ru...@apache.org>
AuthorDate: Wed May 6 18:04:39 2026 +0800

    [MINOR][PYTHON][TESTS] Rename `test_utils` to `test_parity_utils` for Connect parity convention
    
    ### What changes were proposed in this pull request?
    
    The Connect parity test file `python/pyspark/sql/tests/connect/test_utils.py` and its class `ConnectUtilsTests` don't follow the naming convention used by 200+ other parity tests in `python/pyspark/sql/tests/connect/`:
    
    - Filename should be `test_parity_<name>.py`.
    - Class name should be `<Name>ParityTests`.
    
    This PR renames:
    - `python/pyspark/sql/tests/connect/test_utils.py` -> `python/pyspark/sql/tests/connect/test_parity_utils.py`
    - `ConnectUtilsTests` -> `UtilsParityTests`
    
    The reference to the old module path is updated in `dev/sparktestsupport/modules.py`.
    
    ### Why are the changes needed?
    
    Consistency. The `test_parity_*` filename and `*ParityTests` class name are the established convention across the Connect parity test suite; this rename brings the utils parity test in line and makes it easier to locate and identify parity tests at a glance.
    
    ### Does this PR introduce _any_ user-facing change?
    
    No. Test-only change with no behavioral impact.
    
    ### How was this patch tested?
    
    Existing tests; only filename and class name changed. The test module is still discovered through `dev/sparktestsupport/modules.py`.
    
    ### Was this patch authored or co-authored using generative AI tooling?
    
    Generated-by: Claude Code (Opus 4.7)
    
    Closes #55695 from zhengruifeng/rename-test-parity-utils.
    
    Authored-by: Ruifeng Zheng <ru...@apache.org>
    Signed-off-by: Ruifeng Zheng <ru...@foxmail.com>
---
 dev/sparktestsupport/modules.py                                         | 2 +-
 .../pyspark/sql/tests/connect/{test_utils.py => test_parity_utils.py}   | 2 +-
 2 files changed, 2 insertions(+), 2 deletions(-)

diff --git a/dev/sparktestsupport/modules.py b/dev/sparktestsupport/modules.py
index 67d311698e76..664b0d81840a 100644
--- a/dev/sparktestsupport/modules.py
+++ b/dev/sparktestsupport/modules.py
@@ -1188,7 +1188,7 @@ pyspark_connect = Module(
         "pyspark.sql.tests.connect.test_parity_python_datasource",
         "pyspark.sql.tests.connect.test_parity_frame_plot",
         "pyspark.sql.tests.connect.test_parity_frame_plot_plotly",
-        "pyspark.sql.tests.connect.test_utils",
+        "pyspark.sql.tests.connect.test_parity_utils",
         "pyspark.sql.tests.connect.client.test_artifact",
         "pyspark.sql.tests.connect.client.test_artifact_localcluster",
         "pyspark.sql.tests.connect.client.test_client",
diff --git a/python/pyspark/sql/tests/connect/test_utils.py b/python/pyspark/sql/tests/connect/test_parity_utils.py
similarity index 93%
rename from python/pyspark/sql/tests/connect/test_utils.py
rename to python/pyspark/sql/tests/connect/test_parity_utils.py
index 04531a588f73..521b6082cf22 100644
--- a/python/pyspark/sql/tests/connect/test_utils.py
+++ b/python/pyspark/sql/tests/connect/test_parity_utils.py
@@ -19,7 +19,7 @@ from pyspark.testing.connectutils import ReusedConnectTestCase
 from pyspark.sql.tests.test_utils import UtilsTestsMixin
 
 
-class ConnectUtilsTests(UtilsTestsMixin, ReusedConnectTestCase):
+class UtilsParityTests(UtilsTestsMixin, ReusedConnectTestCase):
     pass
 
 


---------------------------------------------------------------------
To unsubscribe, e-mail: commits-unsubscribe@spark.apache.org
For additional commands, e-mail: commits-help@spark.apache.org