You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@mesos.apache.org by Jie Yu <yu...@gmail.com> on 2012/06/18 20:12:30 UTC

Review Request: Add string utility functions to make code more readable.

-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/5391/
-----------------------------------------------------------

Review request for mesos, Benjamin Hindman and Vinod Kone.


Description
-------

Add two string utility functions (startsWith and contains) to make code more readable.


Diffs
-----

  src/common/strings.hpp aaeb801 
  src/tests/strings_tests.cpp 4a5fbfb 

Diff: https://reviews.apache.org/r/5391/diff/


Testing
-------

Make check. (Tested on Mac and Linux)


Thanks,

Jie Yu


Re: Review Request: Add string utility functions to make code more readable.

Posted by Benjamin Hindman <be...@berkeley.edu>.
-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/5391/#review8337
-----------------------------------------------------------

Ship it!


Ship It!

- Benjamin Hindman


On June 18, 2012, 6:12 p.m., Jie Yu wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/5391/
> -----------------------------------------------------------
> 
> (Updated June 18, 2012, 6:12 p.m.)
> 
> 
> Review request for mesos, Benjamin Hindman and Vinod Kone.
> 
> 
> Description
> -------
> 
> Add two string utility functions (startsWith and contains) to make code more readable.
> 
> 
> Diffs
> -----
> 
>   src/common/strings.hpp aaeb801 
>   src/tests/strings_tests.cpp 4a5fbfb 
> 
> Diff: https://reviews.apache.org/r/5391/diff/
> 
> 
> Testing
> -------
> 
> Make check. (Tested on Mac and Linux)
> 
> 
> Thanks,
> 
> Jie Yu
> 
>