You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@knox.apache.org by "Sandor Molnar (JIRA)" <ji...@apache.org> on 2019/07/16 11:18:00 UTC

[jira] [Work started] (KNOX-1922) Fix DNSName error in org.apache.knox.gateway.util.X509CertificateUtil

     [ https://issues.apache.org/jira/browse/KNOX-1922?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Work on KNOX-1922 started by Sandor Molnar.
-------------------------------------------
> Fix DNSName error in org.apache.knox.gateway.util.X509CertificateUtil
> ---------------------------------------------------------------------
>
>                 Key: KNOX-1922
>                 URL: https://issues.apache.org/jira/browse/KNOX-1922
>             Project: Apache Knox
>          Issue Type: Bug
>          Components: KnoxCLI, Server
>    Affects Versions: 1.3.0
>            Reporter: Sandor Molnar
>            Assignee: Sandor Molnar
>            Priority: Blocker
>
> As part of KNOX-1912, there has been some modification that added DNSName values for localhost even if the hostname evaluated to 127.0.0.1. However, due to [RFC-1034,|https://www.ietf.org/rfc/rfc1034.txt] this is not allowed. On the other hand, newer RFCs (e.g. RFC 2181, RFC 1123) are relaxing these restrictions. Oracle claimed they fixed it in JDK 8 u212 ([https://bugs.java.com/bugdatabase/view_bug.do?bug_id=8213952]) but it does not seem to be the case.
>  As a result, neither the build finishes successfully nor the gateway starts as expected due to the same DNSName issue ({{IOException: DNSName components must begin with a letter}}).
> Recommended solution: only add the evaluated localhost address if it starts with a letter.



--
This message was sent by Atlassian JIRA
(v7.6.14#76016)