You are viewing a plain text version of this content. The canonical link for it is here.
Posted to yarn-issues@hadoop.apache.org by "Giovanni Matteo Fumarola (JIRA)" <ji...@apache.org> on 2018/11/09 20:04:00 UTC

[jira] [Commented] (YARN-8996) [Submarine] Simplify the logic in YarnServiceJobSubmitter#needHdfs

    [ https://issues.apache.org/jira/browse/YARN-8996?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16681901#comment-16681901 ] 

Giovanni Matteo Fumarola commented on YARN-8996:
------------------------------------------------

This is a duplicate of YARN-8997.

> [Submarine] Simplify the logic in YarnServiceJobSubmitter#needHdfs
> ------------------------------------------------------------------
>
>                 Key: YARN-8996
>                 URL: https://issues.apache.org/jira/browse/YARN-8996
>             Project: Hadoop YARN
>          Issue Type: Improvement
>            Reporter: Zhankun Tang
>            Assignee: Zhankun Tang
>            Priority: Minor
>
> In YarnServiceJobSubmitter#needHdfs. Below code can be simplified to just one line.
> {code:java}
> if (content != null && content.contains("hdfs://")) {
>   return true;
> }
> return false;{code}
> {code:java}
> return content != null && content.contains("hdfs://");{code}



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

---------------------------------------------------------------------
To unsubscribe, e-mail: yarn-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: yarn-issues-help@hadoop.apache.org