You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@trafodion.apache.org by "liu ming (JIRA)" <ji...@apache.org> on 2018/05/15 15:08:00 UTC

[jira] [Created] (TRAFODION-3068) refactor of hbase interface for various access flags

liu ming created TRAFODION-3068:
-----------------------------------

             Summary: refactor of hbase interface for various access flags
                 Key: TRAFODION-3068
                 URL: https://issues.apache.org/jira/browse/TRAFODION-3068
             Project: Apache Trafodion
          Issue Type: Improvement
            Reporter: liu ming
            Assignee: liu ming


ExpHbaseInterface methods now contains a lot of input parameters for various flags:

useHbaseXn

cacheBlocks

smallScanner

useSnapshotScan

 

And I find I may need one more flag.

 

So suggest to refactor these input parameters into a single struct



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)