You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@flink.apache.org by "godfrey he (Jira)" <ji...@apache.org> on 2019/11/12 12:41:00 UTC
[jira] [Commented] (FLINK-14724) Join condition could be simplified
in logical phase
[ https://issues.apache.org/jira/browse/FLINK-14724?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16972350#comment-16972350 ]
godfrey he commented on FLINK-14724:
------------------------------------
I would like to take this ticket
> Join condition could be simplified in logical phase
> ---------------------------------------------------
>
> Key: FLINK-14724
> URL: https://issues.apache.org/jira/browse/FLINK-14724
> Project: Flink
> Issue Type: Sub-task
> Components: Table SQL / Planner
> Affects Versions: 1.9.0, 1.9.1
> Reporter: godfrey he
> Priority: Major
> Fix For: 1.10.0
>
>
> currently the plan of tpcds q38.sql contains {{NestedLoopJoin}}, because it's join condition is {{CAST(AND(IS NOT DISTINCT FROM($2, $3), IS NOT DISTINCT FROM($1, $4), IS NOT DISTINCT FROM($0, $5))):BOOLEAN}}, and planner can't find equal join keys from the condition by {{Join#analyzeCondition}}.
> {{SimplifyJoinConditionRule}} could solve this.
--
This message was sent by Atlassian Jira
(v8.3.4#803005)