You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@wink.apache.org by "Michael Elman (JIRA)" <ji...@apache.org> on 2009/07/08 13:04:14 UTC
[jira] Created: (WINK-57) Rename OFFactory to LifecycleManager
Rename OFFactory to LifecycleManager
------------------------------------
Key: WINK-57
URL: https://issues.apache.org/jira/browse/WINK-57
Project: Wink
Issue Type: Improvement
Components: Common, Spring
Affects Versions: 0.1
Reporter: Michael Elman
Assignee: Michael Elman
Priority: Minor
OFFactory is really a bad name and I think that LifecycleManager sounds much better ;)
So the proposed renames include:
{code}package: org.apache.wink.common.internal.factory -> org.apache.wink.common.internal.lifecycle
class: DefaultOFFactory -> DefaultLifecycleManager
class: OFFactory -> LifecycleManager
class: OFFactoryRegistry ->LifecycleManagerRegistry
class: ScopeOFFactory -> ScopeLifecycleManager
class: SpringOFFactory -> SpringLifecycleManager
class: SpringOFFactoryPostProcessor - > LifecycleManagerPostProcessor
{code}
The {{ObjectFactory}} interface and its implementing classes remain unchanged.
So in general the idea is: {{LifecycleManager}} is responsible to return {{ObjectFactory}}.
I'm not so good in naming, so any comments will be appreciated :)
--
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.
[jira] Closed: (WINK-57) Rename OFFactory to LifecycleManager
Posted by "Michael Elman (JIRA)" <ji...@apache.org>.
[ https://issues.apache.org/jira/browse/WINK-57?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]
Michael Elman closed WINK-57.
-----------------------------
> Rename OFFactory to LifecycleManager
> ------------------------------------
>
> Key: WINK-57
> URL: https://issues.apache.org/jira/browse/WINK-57
> Project: Wink
> Issue Type: Improvement
> Components: Common, Spring
> Affects Versions: 0.1
> Reporter: Michael Elman
> Assignee: Michael Elman
> Priority: Minor
> Fix For: 0.1
>
>
> OFFactory is really a bad name and I think that LifecycleManager sounds much better ;)
> So the proposed renames include:
> {code}package: org.apache.wink.common.internal.factory -> org.apache.wink.common.internal.lifecycle
> class: DefaultOFFactory -> DefaultLifecycleManager
> class: OFFactory -> LifecycleManager
> class: OFFactoryRegistry ->LifecycleManagerRegistry
> class: ScopeOFFactory -> ScopeLifecycleManager
> class: SpringOFFactory -> SpringLifecycleManager
> class: SpringOFFactoryPostProcessor - > LifecycleManagerPostProcessor
> {code}
> The {{ObjectFactory}} interface and its implementing classes remain unchanged.
> So in general the idea is: {{LifecycleManager}} is responsible to return {{ObjectFactory}}.
> I'm not so good in naming, so any comments will be appreciated :)
--
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.
[jira] Commented: (WINK-57) Rename OFFactory to LifecycleManager
Posted by "Hudson (JIRA)" <ji...@apache.org>.
[ https://issues.apache.org/jira/browse/WINK-57?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12728741#action_12728741 ]
Hudson commented on WINK-57:
----------------------------
Integrated in Wink-Trunk-JDK15 #12 (See [http://hudson.zones.apache.org/hudson/job/Wink-Trunk-JDK15/12/])
rename OFFactory to LifecycleManager
See []
> Rename OFFactory to LifecycleManager
> ------------------------------------
>
> Key: WINK-57
> URL: https://issues.apache.org/jira/browse/WINK-57
> Project: Wink
> Issue Type: Improvement
> Components: Common, Spring
> Affects Versions: 0.1
> Reporter: Michael Elman
> Assignee: Michael Elman
> Priority: Minor
>
> OFFactory is really a bad name and I think that LifecycleManager sounds much better ;)
> So the proposed renames include:
> {code}package: org.apache.wink.common.internal.factory -> org.apache.wink.common.internal.lifecycle
> class: DefaultOFFactory -> DefaultLifecycleManager
> class: OFFactory -> LifecycleManager
> class: OFFactoryRegistry ->LifecycleManagerRegistry
> class: ScopeOFFactory -> ScopeLifecycleManager
> class: SpringOFFactory -> SpringLifecycleManager
> class: SpringOFFactoryPostProcessor - > LifecycleManagerPostProcessor
> {code}
> The {{ObjectFactory}} interface and its implementing classes remain unchanged.
> So in general the idea is: {{LifecycleManager}} is responsible to return {{ObjectFactory}}.
> I'm not so good in naming, so any comments will be appreciated :)
--
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.
[jira] Commented: (WINK-57) Rename OFFactory to LifecycleManager
Posted by "Nadav Fischer (JIRA)" <ji...@apache.org>.
[ https://issues.apache.org/jira/browse/WINK-57?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12728632#action_12728632 ]
Nadav Fischer commented on WINK-57:
-----------------------------------
+1 to LifecycleManager.
You nailed it this time :-)
> Rename OFFactory to LifecycleManager
> ------------------------------------
>
> Key: WINK-57
> URL: https://issues.apache.org/jira/browse/WINK-57
> Project: Wink
> Issue Type: Improvement
> Components: Common, Spring
> Affects Versions: 0.1
> Reporter: Michael Elman
> Assignee: Michael Elman
> Priority: Minor
>
> OFFactory is really a bad name and I think that LifecycleManager sounds much better ;)
> So the proposed renames include:
> {code}package: org.apache.wink.common.internal.factory -> org.apache.wink.common.internal.lifecycle
> class: DefaultOFFactory -> DefaultLifecycleManager
> class: OFFactory -> LifecycleManager
> class: OFFactoryRegistry ->LifecycleManagerRegistry
> class: ScopeOFFactory -> ScopeLifecycleManager
> class: SpringOFFactory -> SpringLifecycleManager
> class: SpringOFFactoryPostProcessor - > LifecycleManagerPostProcessor
> {code}
> The {{ObjectFactory}} interface and its implementing classes remain unchanged.
> So in general the idea is: {{LifecycleManager}} is responsible to return {{ObjectFactory}}.
> I'm not so good in naming, so any comments will be appreciated :)
--
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.
[jira] Commented: (WINK-57) Rename OFFactory to LifecycleManager
Posted by "Nick Gallardo (JIRA)" <ji...@apache.org>.
[ https://issues.apache.org/jira/browse/WINK-57?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12728657#action_12728657 ]
Nick Gallardo commented on WINK-57:
-----------------------------------
+1 as well, I kinda struggled with the name OFFactory myself.
> Rename OFFactory to LifecycleManager
> ------------------------------------
>
> Key: WINK-57
> URL: https://issues.apache.org/jira/browse/WINK-57
> Project: Wink
> Issue Type: Improvement
> Components: Common, Spring
> Affects Versions: 0.1
> Reporter: Michael Elman
> Assignee: Michael Elman
> Priority: Minor
>
> OFFactory is really a bad name and I think that LifecycleManager sounds much better ;)
> So the proposed renames include:
> {code}package: org.apache.wink.common.internal.factory -> org.apache.wink.common.internal.lifecycle
> class: DefaultOFFactory -> DefaultLifecycleManager
> class: OFFactory -> LifecycleManager
> class: OFFactoryRegistry ->LifecycleManagerRegistry
> class: ScopeOFFactory -> ScopeLifecycleManager
> class: SpringOFFactory -> SpringLifecycleManager
> class: SpringOFFactoryPostProcessor - > LifecycleManagerPostProcessor
> {code}
> The {{ObjectFactory}} interface and its implementing classes remain unchanged.
> So in general the idea is: {{LifecycleManager}} is responsible to return {{ObjectFactory}}.
> I'm not so good in naming, so any comments will be appreciated :)
--
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.
[jira] Resolved: (WINK-57) Rename OFFactory to LifecycleManager
Posted by "Michael Elman (JIRA)" <ji...@apache.org>.
[ https://issues.apache.org/jira/browse/WINK-57?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]
Michael Elman resolved WINK-57.
-------------------------------
Resolution: Fixed
Fix Version/s: 0.1
> Rename OFFactory to LifecycleManager
> ------------------------------------
>
> Key: WINK-57
> URL: https://issues.apache.org/jira/browse/WINK-57
> Project: Wink
> Issue Type: Improvement
> Components: Common, Spring
> Affects Versions: 0.1
> Reporter: Michael Elman
> Assignee: Michael Elman
> Priority: Minor
> Fix For: 0.1
>
>
> OFFactory is really a bad name and I think that LifecycleManager sounds much better ;)
> So the proposed renames include:
> {code}package: org.apache.wink.common.internal.factory -> org.apache.wink.common.internal.lifecycle
> class: DefaultOFFactory -> DefaultLifecycleManager
> class: OFFactory -> LifecycleManager
> class: OFFactoryRegistry ->LifecycleManagerRegistry
> class: ScopeOFFactory -> ScopeLifecycleManager
> class: SpringOFFactory -> SpringLifecycleManager
> class: SpringOFFactoryPostProcessor - > LifecycleManagerPostProcessor
> {code}
> The {{ObjectFactory}} interface and its implementing classes remain unchanged.
> So in general the idea is: {{LifecycleManager}} is responsible to return {{ObjectFactory}}.
> I'm not so good in naming, so any comments will be appreciated :)
--
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.