You are viewing a plain text version of this content. The canonical link for it is here.
Posted to commits@harmony.apache.org by "Oliver Deakin (JIRA)" <ji...@apache.org> on 2006/09/20 16:46:22 UTC

[jira] Created: (HARMONY-1510) [classlib][build] build target names are inconsistent

[classlib][build] build target names are inconsistent
-----------------------------------------------------

                 Key: HARMONY-1510
                 URL: http://issues.apache.org/jira/browse/HARMONY-1510
             Project: Harmony
          Issue Type: Improvement
          Components: Classlib
            Reporter: Oliver Deakin
            Priority: Trivial
         Attachments: standardise.targets.diff

The current build system has inconsistencies in its build target names. At the moment we use:
 - hyphen separated words for targets in the top level build.xml and those under make
 - a mixture of hyphen separated and dot separated words for targets at the modular level.

Since we use dot separated words for property names in our scripts, I think we should use consistent hyphen separated names for targets throughout the build system.

I will attach a patch that fixes up all dot separated instances.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

[jira] Commented: (HARMONY-1510) [classlib][build] build target names are inconsistent

Posted by "Oliver Deakin (JIRA)" <ji...@apache.org>.
    [ http://issues.apache.org/jira/browse/HARMONY-1510?page=comments#action_12436824 ] 
            
Oliver Deakin commented on HARMONY-1510:
----------------------------------------

Looks good, thanks Mark.

> [classlib][build] build target names are inconsistent
> -----------------------------------------------------
>
>                 Key: HARMONY-1510
>                 URL: http://issues.apache.org/jira/browse/HARMONY-1510
>             Project: Harmony
>          Issue Type: Improvement
>          Components: Classlib
>            Reporter: Oliver Deakin
>         Assigned To: Mark Hindess
>            Priority: Trivial
>         Attachments: standardise.targets.diff
>
>
> The current build system has inconsistencies in its build target names. At the moment we use:
>  - hyphen separated words for targets in the top level build.xml and those under make
>  - a mixture of hyphen separated and dot separated words for targets at the modular level.
> Since we use dot separated words for property names in our scripts, I think we should use consistent hyphen separated names for targets throughout the build system.
> I will attach a patch that fixes up all dot separated instances.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

[jira] Updated: (HARMONY-1510) [classlib][build] build target names are inconsistent

Posted by "Oliver Deakin (JIRA)" <ji...@apache.org>.
     [ http://issues.apache.org/jira/browse/HARMONY-1510?page=all ]

Oliver Deakin updated HARMONY-1510:
-----------------------------------

    Attachment: standardise.targets.diff

Patch to standardise all build targets.

> [classlib][build] build target names are inconsistent
> -----------------------------------------------------
>
>                 Key: HARMONY-1510
>                 URL: http://issues.apache.org/jira/browse/HARMONY-1510
>             Project: Harmony
>          Issue Type: Improvement
>          Components: Classlib
>            Reporter: Oliver Deakin
>            Priority: Trivial
>         Attachments: standardise.targets.diff
>
>
> The current build system has inconsistencies in its build target names. At the moment we use:
>  - hyphen separated words for targets in the top level build.xml and those under make
>  - a mixture of hyphen separated and dot separated words for targets at the modular level.
> Since we use dot separated words for property names in our scripts, I think we should use consistent hyphen separated names for targets throughout the build system.
> I will attach a patch that fixes up all dot separated instances.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

[jira] Closed: (HARMONY-1510) [classlib][build] build target names are inconsistent

Posted by "Mark Hindess (JIRA)" <ji...@apache.org>.
     [ http://issues.apache.org/jira/browse/HARMONY-1510?page=all ]

Mark Hindess closed HARMONY-1510.
---------------------------------


Verified by Oliver.


> [classlib][build] build target names are inconsistent
> -----------------------------------------------------
>
>                 Key: HARMONY-1510
>                 URL: http://issues.apache.org/jira/browse/HARMONY-1510
>             Project: Harmony
>          Issue Type: Improvement
>          Components: Classlib
>            Reporter: Oliver Deakin
>         Assigned To: Mark Hindess
>            Priority: Trivial
>         Attachments: standardise.targets.diff
>
>
> The current build system has inconsistencies in its build target names. At the moment we use:
>  - hyphen separated words for targets in the top level build.xml and those under make
>  - a mixture of hyphen separated and dot separated words for targets at the modular level.
> Since we use dot separated words for property names in our scripts, I think we should use consistent hyphen separated names for targets throughout the build system.
> I will attach a patch that fixes up all dot separated instances.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

[jira] Resolved: (HARMONY-1510) [classlib][build] build target names are inconsistent

Posted by "Mark Hindess (JIRA)" <ji...@apache.org>.
     [ http://issues.apache.org/jira/browse/HARMONY-1510?page=all ]

Mark Hindess resolved HARMONY-1510.
-----------------------------------

    Resolution: Fixed
      Assignee: Mark Hindess

Applied in r448882. Please confirm that is has been applied as expected.
Thanks.


> [classlib][build] build target names are inconsistent
> -----------------------------------------------------
>
>                 Key: HARMONY-1510
>                 URL: http://issues.apache.org/jira/browse/HARMONY-1510
>             Project: Harmony
>          Issue Type: Improvement
>          Components: Classlib
>            Reporter: Oliver Deakin
>         Assigned To: Mark Hindess
>            Priority: Trivial
>         Attachments: standardise.targets.diff
>
>
> The current build system has inconsistencies in its build target names. At the moment we use:
>  - hyphen separated words for targets in the top level build.xml and those under make
>  - a mixture of hyphen separated and dot separated words for targets at the modular level.
> Since we use dot separated words for property names in our scripts, I think we should use consistent hyphen separated names for targets throughout the build system.
> I will attach a patch that fixes up all dot separated instances.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira