You are viewing a plain text version of this content. The canonical link for it is here.
Posted to commits@hudi.apache.org by "sivabalan narayanan (Jira)" <ji...@apache.org> on 2025/06/02 17:50:00 UTC

[jira] [Updated] (HUDI-8649) Refactor code in ExpressionIndexSupport to avoid duplicate code

     [ https://issues.apache.org/jira/browse/HUDI-8649?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

sivabalan narayanan updated HUDI-8649:
--------------------------------------
    Parent Issue: HUDI-9101  (was: HUDI-8716)

> Refactor code in ExpressionIndexSupport to avoid duplicate code
> ---------------------------------------------------------------
>
>                 Key: HUDI-8649
>                 URL: https://issues.apache.org/jira/browse/HUDI-8649
>             Project: Apache Hudi
>          Issue Type: Sub-task
>          Components: code-quality
>            Reporter: Lokesh Jain
>            Assignee: Lokesh Jain
>            Priority: Critical
>             Fix For: 1.1.0
>
>   Original Estimate: 2h
>  Remaining Estimate: 2h
>
> HUDI-8463 adds filtration for records with from_unixtime function and expression index. There is some duplicate code with ColumnStatsIndexSupport and function like `fetchQueryWithAttribute` which can be refactored to avoid duplicate.



--
This message was sent by Atlassian Jira
(v8.20.10#820010)