You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@dubbo.apache.org by Jason Joo <hb...@163.com> on 2018/08/03 02:38:07 UTC
2.6.3 compatible problem with 2.5.[9, 10]
hey, everyone
Today i found a big compatible problem in our staging env.
Issue has been submitted as https://github.com/apache/incubator-dubbo/issues/2174 <https://github.com/apache/incubator-dubbo/issues/2174>
And we can check it quickly in below table:
dubbo protocol fail
2.5.8 2.5.8 no
2.5.9 2.0.0(spec)
2.0.1(impl)(why 2.0.1?) yes
2.5.10 2.0.0(spec)
2.0.1(impl) yes
2.6.1 2.0.0 no
2.6.2 2.0.0 no
2.6.2 2.0.1 no
Maybe the best way to solve this is to patch 2.6.3(just released) and change it to "2.0.2"
Any opinion?
It's better to document the change log of protocol versions.
best regards,
Jason
Re: 2.6.3 compatible problem with 2.5.[9, 10]
Posted by Yong Zhu <je...@apache.org>.
hi, Jason
Thanks for your reporting. This is exactly a big compatible problem.
I suggest cancel the current release for 2.6.3, fix this problem ASAP.
How do you guys think?
Sincerely.
Jerrick
On Fri, Aug 3, 2018 at 10:44 AM Jason Joo <hb...@163.com> wrote:
> add the table as image:
>
>
>
> best regards,
>
> Jason
>
> On Aug 3, 2018, at 10:38, Jason Joo <hb...@163.com> wrote:
>
> hey, everyone
>
> Today i found a big compatible problem in our staging env.
>
> Issue has been submitted as
> https://github.com/apache/incubator-dubbo/issues/2174 <
> https://github.com/apache/incubator-dubbo/issues/2174>
>
> And we can check it quickly in below table:
>
> dubbo protocol fail
> 2.5.8 2.5.8 no
> 2.5.9 2.0.0(spec)
> 2.0.1(impl)(why 2.0.1?) yes
> 2.5.10 2.0.0(spec)
> 2.0.1(impl) yes
> 2.6.1 2.0.0 no
> 2.6.2 2.0.0 no
> 2.6.2 2.0.1 no
>
>
> Maybe the best way to solve this is to patch 2.6.3(just released) and
> change it to "2.0.2"
>
> Any opinion?
>
> It's better to document the change log of protocol versions.
>
>
> best regards,
>
> Jason
>
>
>
Re: 2.6.3 compatible problem with 2.5.[9, 10]
Posted by jun liu <ke...@gmail.com>.
>> dubbo protocol fail
>> 2.5.8 2.5.8 no
>> 2.5.9 2.0.0(spec)
>> 2.0.1(impl)(why 2.0.1?) yes
>> 2.5.10 2.0.0(spec)
>> 2.0.1(impl) yes
>> 2.6.1 2.0.0 no
>> 2.6.2 2.0.0 no
>> 2.6.2 2.0.1 no
This is a compatible problem we haven’t covered in test. For users stay with 2.5.9 and 2.5.10, this will block them from upgrading to 2.6.3, so I think we should cancel vote of RC2 now and upgrade the protocol version to 2.0.2.
>> It's better to document the change log of protocol versions.
Agree, we definitely need a Compatibility Notice part for every upcoming release. Let’s start from 2.6.3.
Best regards,
Jun
> On 3 Aug 2018, at 10:44, Jason Joo <hb...@163.com> wrote:
>
> add the table as image:
>
> <PastedGraphic-2.png>
>
> best regards,
>
> Jason
>
>> On Aug 3, 2018, at 10:38, Jason Joo <hblzxsj@163.com <ma...@163.com>> wrote:
>>
>> hey, everyone
>>
>> Today i found a big compatible problem in our staging env.
>>
>> Issue has been submitted as https://github.com/apache/incubator-dubbo/issues/2174 <https://github.com/apache/incubator-dubbo/issues/2174> <https://github.com/apache/incubator-dubbo/issues/2174 <https://github.com/apache/incubator-dubbo/issues/2174>>
>>
>> And we can check it quickly in below table:
>>
>> dubbo protocol fail
>> 2.5.8 2.5.8 no
>> 2.5.9 2.0.0(spec)
>> 2.0.1(impl)(why 2.0.1?) yes
>> 2.5.10 2.0.0(spec)
>> 2.0.1(impl) yes
>> 2.6.1 2.0.0 no
>> 2.6.2 2.0.0 no
>> 2.6.2 2.0.1 no
>>
>>
>> Maybe the best way to solve this is to patch 2.6.3(just released) and change it to "2.0.2"
>>
>> Any opinion?
>>
>> It's better to document the change log of protocol versions.
>>
>>
>> best regards,
>>
>> Jason
>>
>
Re: 2.6.3 compatible problem with 2.5.[9, 10]
Posted by Jason Joo <hb...@163.com>.
add the table as image:
best regards,
Jason
> On Aug 3, 2018, at 10:38, Jason Joo <hb...@163.com> wrote:
>
> hey, everyone
>
> Today i found a big compatible problem in our staging env.
>
> Issue has been submitted as https://github.com/apache/incubator-dubbo/issues/2174 <https://github.com/apache/incubator-dubbo/issues/2174>
>
> And we can check it quickly in below table:
>
> dubbo protocol fail
> 2.5.8 2.5.8 no
> 2.5.9 2.0.0(spec)
> 2.0.1(impl)(why 2.0.1?) yes
> 2.5.10 2.0.0(spec)
> 2.0.1(impl) yes
> 2.6.1 2.0.0 no
> 2.6.2 2.0.0 no
> 2.6.2 2.0.1 no
>
>
> Maybe the best way to solve this is to patch 2.6.3(just released) and change it to "2.0.2"
>
> Any opinion?
>
> It's better to document the change log of protocol versions.
>
>
> best regards,
>
> Jason
>