You are viewing a plain text version of this content. The canonical link for it is here.
Posted to commits@geode.apache.org by ds...@apache.org on 2017/11/16 20:34:24 UTC

[geode] branch feature/GEODE-3940 updated (11a385e -> ad786a5)

This is an automated email from the ASF dual-hosted git repository.

dschneider pushed a change to branch feature/GEODE-3940
in repository https://gitbox.apache.org/repos/asf/geode.git.


    from 11a385e  GEODE-3940: fix deadlock in backup messages
     add 2c46f7d  GEODE-3957: User Guide - Strengthen anti-SYNCOOKIES host machine requ… (#1018)
     add e2caeb5  GEODE-3335: Fix expected member count (#1034)
     add 44f449c  GEODE-3591: remove getAnyInstance call (#1027)
     add cb4f06c  GEODE-3601: remove getExisting call (#1036)
     add c1c6e74  GEODE-3539: add more tests for get, put, locate entry commands (#1025)
     add 650ed4e  GEODE-3963: make DM.getCache thread safe
     add 2d5d643  GEODE-3599: remove getInstance calls (#1037)
     add d9393de  GEODE-3598: remove getInstance calls (#1035)
     add 8987dc0  GEODE-3597: remove getInstance calls (#1033)
     add 66c3ba1  GEODE-3596: remove getInstanceCalls (#1032)
     add cd81d55  GEODE-3595: remove getInstance calls (#1030)
     add 369af90  GEODE-3594: remove calls of getInstance (#1029)
     add 8ca7000  GEODE-3593: remove call to getInstance (#1028)
     add 3bc8c1a  GEODE-3592: remove getAnyInstance call (#1026)
     add 36408b7  GEODE-3872: simplify the Command result Assert (#1043)
     add e67456d  GEODE-3539: cleanup GfshCommand and refactor tests
     add 36a1165  Revert "GEODE-3592: remove getAnyInstance call (#1026)"
     add 576bf71  GEODE-3539: rename GfshShellConnectionRule to GfshCommandRule (#1051)
     add abb39cf  GEODE-3970: Adjust default Travis _JAVA_OPTIONS (#1049)
     add bd523c3  GEODE-3951: PULSE Logout exception when using the defaults. (#1041)
     add 141c793  GEODE-2565: add if-exists option to DestoryGatewaySenderCommand (#1048)
     add ae03b84  GEODE-3973: have the cluster configuration start synchronously when starting a locator (#1050)
     add 9ebc4f7  Fix for GEODE-3898: Defined Indexes are not Persisted in Cluster Configuration. (#1022)
     add 1b985b0  GEODE-3898: fix merge conflict
     add 69143c1  GEODE-3961: Refactor ShowMetricsCommand to handle --categories uniformly
     add 7fae1a1  GEODE-3961: Correct test after bad rebase.
     add 23846b3  GEODE-3920: Added test to validate lucene 6 to 7 upgrade
     add 740ce79  GEODE-3539: Correct typo in javadoc annotation (#1057)
     add 944436a  GEODE-3738: Add Flaky category to ClientAuthorizationDUnitTest (#1054)
     add 5f08a9e  GEODE-3935: Closing down the cache after each test.
     add 4dafde1  GEODE-1019: Removing the flaky tag
     add dfaa0f1  GEODE-3978: add wait with respect to region size (#1060)
     add 7718945  GEODE-3979: fix flaky test (#1061)
     add e2bf74c  GEODE-3938: Allow query parameters within the to_date preset query function (#1003)
     add 0e5dd6b  GEODE-3007: Simplify support for custom GFSH commands (#1042)
     add 7f0d5f5  GEODE-1920 Addition of more logs to the test
     add 478665f  Revert "GEODE-1920 Addition of more logs to the test"
     new ad786a5  Merge remote-tracking branch 'origin/develop' into feature/GEODE-3940

The 1 revisions listed above as "new" are entirely new to this
repository and will be described in separate emails.  The revisions
listed as "add" were already present in the repository and have only
been added to this reference.


Summary of changes:
 geode-assembly/build.gradle                        |   2 -
 .../cli/commands/StatusLocatorRealGfshTest.java    |   1 -
 .../apache/geode/cache/query/internal/parse/oql.g  |   2 +-
 .../geode/distributed/ConfigurationProperties.java |   3 +
 .../internal/AbstractDistributionConfig.java       |   3 -
 .../distributed/internal/DistributionConfig.java   |  28 --
 .../internal/DistributionConfigImpl.java           |  21 +-
 .../internal/beans/MemberMBeanBridge.java          |   3 +-
 .../geode/management/internal/cli/CliUtil.java     |   2 +-
 .../management/internal/cli/CommandManager.java    | 307 ++++-----------------
 .../geode/management/internal/cli/GfshParser.java  |   8 +-
 .../geode/management/internal/cli/help/Helper.java |  63 +++--
 .../internal/cli/remote/MemberCommandService.java  |   3 +-
 .../cli/remote/OnlineCommandProcessor.java         |  16 +-
 .../internal/cli/util/ClasspathScanLoadHelper.java |  23 +-
 .../geode/cache/query/QueryServiceJUnitTest.java   |  48 ++++
 .../query/internal/parse/OQLParserTest.java}       |  39 +--
 .../geode/cache30/ClientServerCCEDUnitTest.java    |  16 +-
 .../geode/cache30/RegionReliabilityTestCase.java   |   6 +-
 .../internal/DistributionConfigJUnitTest.java      |   4 +-
 .../cli/ClasspathScanLoadHelperJUnitTest.java      |  27 +-
 .../internal/cli/CommandManagerJUnitTest.java      | 156 +----------
 .../internal/cli/commands/CliCommandTestBase.java  |   4 +-
 .../cli/remote/OnlineCommandProcessorTest.java     |   6 +-
 .../security/ClientAuthorizationDUnitTest.java     |   3 +-
 .../geode/security/query/QuerySecurityBase.java    |   9 +-
 .../org.springframework.shell.core.CommandMarker   |   8 -
 .../dunit/CqSecurityAuthorizedUserDUnitTest.java   |   3 -
 .../org.springframework.shell.core.CommandMarker   |   2 -
 .../LuceneSearchWithRollingUpgradeDUnit.java       | 102 ++++++-
 .../cache/wan/misc/WanValidationsDUnitTest.java    |   5 +-
 31 files changed, 343 insertions(+), 580 deletions(-)
 copy geode-core/src/test/java/org/apache/geode/{management/internal/cli/util/ExportLogsCacheWriterUnitTest.java => cache/query/internal/parse/OQLParserTest.java} (52%)
 delete mode 100644 geode-core/src/test/resources/META-INF/services/org.springframework.shell.core.CommandMarker
 delete mode 100644 geode-lucene/src/main/resources/META-INF/services/org.springframework.shell.core.CommandMarker

-- 
To stop receiving notification emails like this one, please contact
['"commits@geode.apache.org" <co...@geode.apache.org>'].

[geode] 01/01: Merge remote-tracking branch 'origin/develop' into feature/GEODE-3940

Posted by ds...@apache.org.
This is an automated email from the ASF dual-hosted git repository.

dschneider pushed a commit to branch feature/GEODE-3940
in repository https://gitbox.apache.org/repos/asf/geode.git

commit ad786a5699950454ed366174215950ad02ee756a
Merge: 11a385e 478665f
Author: Darrel Schneider <ds...@pivotal.io>
AuthorDate: Thu Nov 16 12:34:06 2017 -0800

    Merge remote-tracking branch 'origin/develop' into feature/GEODE-3940

 geode-assembly/build.gradle                        |   2 -
 .../cli/commands/StatusLocatorRealGfshTest.java    |   1 -
 .../apache/geode/cache/query/internal/parse/oql.g  |   2 +-
 .../geode/distributed/ConfigurationProperties.java |   3 +
 .../internal/AbstractDistributionConfig.java       |   3 -
 .../distributed/internal/DistributionConfig.java   |  28 --
 .../internal/DistributionConfigImpl.java           |  21 +-
 .../internal/beans/MemberMBeanBridge.java          |   3 +-
 .../geode/management/internal/cli/CliUtil.java     |   2 +-
 .../management/internal/cli/CommandManager.java    | 307 ++++-----------------
 .../geode/management/internal/cli/GfshParser.java  |   8 +-
 .../geode/management/internal/cli/help/Helper.java |  63 +++--
 .../internal/cli/remote/MemberCommandService.java  |   3 +-
 .../cli/remote/OnlineCommandProcessor.java         |  16 +-
 .../internal/cli/util/ClasspathScanLoadHelper.java |  23 +-
 .../geode/cache/query/QueryServiceJUnitTest.java   |  48 ++++
 .../cache/query/internal/parse/OQLParserTest.java  |  52 ++++
 .../geode/cache30/ClientServerCCEDUnitTest.java    |  16 +-
 .../geode/cache30/RegionReliabilityTestCase.java   |   6 +-
 .../internal/DistributionConfigJUnitTest.java      |   4 +-
 .../cli/ClasspathScanLoadHelperJUnitTest.java      |  27 +-
 .../internal/cli/CommandManagerJUnitTest.java      | 156 +----------
 .../internal/cli/commands/CliCommandTestBase.java  |   4 +-
 .../cli/remote/OnlineCommandProcessorTest.java     |   6 +-
 .../security/ClientAuthorizationDUnitTest.java     |   3 +-
 .../geode/security/query/QuerySecurityBase.java    |   9 +-
 .../org.springframework.shell.core.CommandMarker   |   8 -
 .../dunit/CqSecurityAuthorizedUserDUnitTest.java   |   3 -
 .../org.springframework.shell.core.CommandMarker   |   2 -
 .../LuceneSearchWithRollingUpgradeDUnit.java       | 102 ++++++-
 .../cache/wan/misc/WanValidationsDUnitTest.java    |   5 +-
 31 files changed, 373 insertions(+), 563 deletions(-)


-- 
To stop receiving notification emails like this one, please contact
"commits@geode.apache.org" <co...@geode.apache.org>.