You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@uima.apache.org by "Joern Kottmann (JIRA)" <de...@uima.apache.org> on 2018/12/12 09:24:00 UTC
[jira] [Created] (UIMA-5932) Refactor usage of Strings
Joern Kottmann created UIMA-5932:
------------------------------------
Summary: Refactor usage of Strings
Key: UIMA-5932
URL: https://issues.apache.org/jira/browse/UIMA-5932
Project: UIMA
Issue Type: Improvement
Reporter: Joern Kottmann
Attachments: uimaj-5932.patch
There are some improvements that can be made:
- Use String.contains instead of indexOf (code is easier to read)
- StringBuilder should be used instead of StringBuffer for non-concurrent use
- String.join can replace loops ({color:#d04437}*review careful*{color}, was done by hand)
- StringBuilder can sometimes be replaced by string concat (java will do the same internally again)
- String.substring can be removed, or be called with less arguments
- System.out.println can be called without an empty string argument
--
This message was sent by Atlassian JIRA
(v7.6.3#76005)