You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@felix.apache.org by "Richard S. Hall (JIRA)" <ji...@apache.org> on 2008/01/04 18:13:33 UTC

[jira] Created: (FELIX-448) Try to modify auto-property processing in Main to make it easier for people to re-use

Try to modify auto-property processing in Main to make it easier for people to re-use
-------------------------------------------------------------------------------------

                 Key: FELIX-448
                 URL: https://issues.apache.org/jira/browse/FELIX-448
             Project: Felix
          Issue Type: Improvement
          Components: Framework
            Reporter: Richard S. Hall
            Priority: Minor


Since we have moved auto-property processing out of the framework, people creating custom launchers must now handle automatically installing/starting bundles themselves. Perhaps we could modify the default launcher to better separate out this functionality so that it can be directly re-used in other custom launcher. Also, we need to update the embedding & launching documentation.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Re: [jira] Commented: (FELIX-448) Try to modify auto-property processing in Main to make it easier for people to re-use

Posted by "Richard S. Hall" <he...@ungoverned.org>.
Lucas,

I modified the patch to take into account your suggestion. I also 
eliminated duplicate code by combining the loop for installing 
auto-install bundles with the loop for installing auto-start bundles.

-> richard

Lucas Galfaso wrote:
> The patch looks very useful (and whenever you commit it I will modify
> the Eclipse OSGi entrypoint to use the new version.) I only have one
> question would it be possible to replace
>
> if (st.countTokens() > 0)
> {
>   String location = null;
>   do
>   {
>     location = nextLocation(st);
>     if (location != null)
>     {
>       [...]
>     }
>   }
>   while (location != null);
> }
>
>
> with
>
> for (String location = nextLocation(st) ; location!=null ; location =
> nextLocation(st)
> {
>   [...]
> }
>
> as I think it helps the readability.
>
> Regards,
>   Lucas
>
> On Jan 4, 2008 7:30 PM, Richard S. Hall (JIRA) <ji...@apache.org> wrote:
>   
>>     [ https://issues.apache.org/jira/browse/FELIX-448?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12556082#action_12556082 ]
>>
>> Richard S. Hall commented on FELIX-448:
>> ---------------------------------------
>>
>> If it wasn't clear in the above comment, I am looking for feedback. :-)
>>
>>
>>     
>>> Try to modify auto-property processing in Main to make it easier for people to re-use
>>> -------------------------------------------------------------------------------------
>>>
>>>                 Key: FELIX-448
>>>                 URL: https://issues.apache.org/jira/browse/FELIX-448
>>>             Project: Felix
>>>          Issue Type: Improvement
>>>          Components: Framework
>>>            Reporter: Richard S. Hall
>>>            Priority: Minor
>>>         Attachments: FELIX-448.patch
>>>
>>>
>>> Since we have moved auto-property processing out of the framework, people creating custom launchers must now handle automatically installing/starting bundles themselves. Perhaps we could modify the default launcher to better separate out this functionality so that it can be directly re-used in other custom launcher. Also, we need to update the embedding & launching documentation.
>>>       
>> --
>> This message is automatically generated by JIRA.
>> -
>> You can reply to this email to add a comment to the issue online.
>>
>>
>>     

Re: [jira] Commented: (FELIX-448) Try to modify auto-property processing in Main to make it easier for people to re-use

Posted by "Richard S. Hall" <he...@ungoverned.org>.
Sure thing...

-> richard

Lucas Galfaso wrote:
> The patch looks very useful (and whenever you commit it I will modify
> the Eclipse OSGi entrypoint to use the new version.) I only have one
> question would it be possible to replace
>
> if (st.countTokens() > 0)
> {
>   String location = null;
>   do
>   {
>     location = nextLocation(st);
>     if (location != null)
>     {
>       [...]
>     }
>   }
>   while (location != null);
> }
>
>
> with
>
> for (String location = nextLocation(st) ; location!=null ; location =
> nextLocation(st)
> {
>   [...]
> }
>
> as I think it helps the readability.
>
> Regards,
>   Lucas
>
> On Jan 4, 2008 7:30 PM, Richard S. Hall (JIRA) <ji...@apache.org> wrote:
>   
>>     [ https://issues.apache.org/jira/browse/FELIX-448?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12556082#action_12556082 ]
>>
>> Richard S. Hall commented on FELIX-448:
>> ---------------------------------------
>>
>> If it wasn't clear in the above comment, I am looking for feedback. :-)
>>
>>
>>     
>>> Try to modify auto-property processing in Main to make it easier for people to re-use
>>> -------------------------------------------------------------------------------------
>>>
>>>                 Key: FELIX-448
>>>                 URL: https://issues.apache.org/jira/browse/FELIX-448
>>>             Project: Felix
>>>          Issue Type: Improvement
>>>          Components: Framework
>>>            Reporter: Richard S. Hall
>>>            Priority: Minor
>>>         Attachments: FELIX-448.patch
>>>
>>>
>>> Since we have moved auto-property processing out of the framework, people creating custom launchers must now handle automatically installing/starting bundles themselves. Perhaps we could modify the default launcher to better separate out this functionality so that it can be directly re-used in other custom launcher. Also, we need to update the embedding & launching documentation.
>>>       
>> --
>> This message is automatically generated by JIRA.
>> -
>> You can reply to this email to add a comment to the issue online.
>>
>>
>>     

Re: [jira] Commented: (FELIX-448) Try to modify auto-property processing in Main to make it easier for people to re-use

Posted by Lucas Galfaso <lg...@gmail.com>.
The patch looks very useful (and whenever you commit it I will modify
the Eclipse OSGi entrypoint to use the new version.) I only have one
question would it be possible to replace

if (st.countTokens() > 0)
{
  String location = null;
  do
  {
    location = nextLocation(st);
    if (location != null)
    {
      [...]
    }
  }
  while (location != null);
}


with

for (String location = nextLocation(st) ; location!=null ; location =
nextLocation(st)
{
  [...]
}

as I think it helps the readability.

Regards,
  Lucas

On Jan 4, 2008 7:30 PM, Richard S. Hall (JIRA) <ji...@apache.org> wrote:
>
>     [ https://issues.apache.org/jira/browse/FELIX-448?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12556082#action_12556082 ]
>
> Richard S. Hall commented on FELIX-448:
> ---------------------------------------
>
> If it wasn't clear in the above comment, I am looking for feedback. :-)
>
>
> > Try to modify auto-property processing in Main to make it easier for people to re-use
> > -------------------------------------------------------------------------------------
> >
> >                 Key: FELIX-448
> >                 URL: https://issues.apache.org/jira/browse/FELIX-448
> >             Project: Felix
> >          Issue Type: Improvement
> >          Components: Framework
> >            Reporter: Richard S. Hall
> >            Priority: Minor
> >         Attachments: FELIX-448.patch
> >
> >
> > Since we have moved auto-property processing out of the framework, people creating custom launchers must now handle automatically installing/starting bundles themselves. Perhaps we could modify the default launcher to better separate out this functionality so that it can be directly re-used in other custom launcher. Also, we need to update the embedding & launching documentation.
>
> --
> This message is automatically generated by JIRA.
> -
> You can reply to this email to add a comment to the issue online.
>
>

[jira] Updated: (FELIX-448) Try to modify auto-property processing in Main to make it easier for people to re-use

Posted by "Richard S. Hall (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/FELIX-448?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Richard S. Hall updated FELIX-448:
----------------------------------

    Attachment: FELIX-448.patch

> Try to modify auto-property processing in Main to make it easier for people to re-use
> -------------------------------------------------------------------------------------
>
>                 Key: FELIX-448
>                 URL: https://issues.apache.org/jira/browse/FELIX-448
>             Project: Felix
>          Issue Type: Improvement
>          Components: Framework
>            Reporter: Richard S. Hall
>            Priority: Minor
>         Attachments: FELIX-448.patch
>
>
> Since we have moved auto-property processing out of the framework, people creating custom launchers must now handle automatically installing/starting bundles themselves. Perhaps we could modify the default launcher to better separate out this functionality so that it can be directly re-used in other custom launcher. Also, we need to update the embedding & launching documentation.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


[jira] Commented: (FELIX-448) Try to modify auto-property processing in Main to make it easier for people to re-use

Posted by "Richard S. Hall (JIRA)" <ji...@apache.org>.
    [ https://issues.apache.org/jira/browse/FELIX-448?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12556082#action_12556082 ] 

Richard S. Hall commented on FELIX-448:
---------------------------------------

If it wasn't clear in the above comment, I am looking for feedback. :-)

> Try to modify auto-property processing in Main to make it easier for people to re-use
> -------------------------------------------------------------------------------------
>
>                 Key: FELIX-448
>                 URL: https://issues.apache.org/jira/browse/FELIX-448
>             Project: Felix
>          Issue Type: Improvement
>          Components: Framework
>            Reporter: Richard S. Hall
>            Priority: Minor
>         Attachments: FELIX-448.patch
>
>
> Since we have moved auto-property processing out of the framework, people creating custom launchers must now handle automatically installing/starting bundles themselves. Perhaps we could modify the default launcher to better separate out this functionality so that it can be directly re-used in other custom launcher. Also, we need to update the embedding & launching documentation.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


[jira] Commented: (FELIX-448) Try to modify auto-property processing in Main to make it easier for people to re-use

Posted by "Richard S. Hall (JIRA)" <ji...@apache.org>.
    [ https://issues.apache.org/jira/browse/FELIX-448?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12556075#action_12556075 ] 

Richard S. Hall commented on FELIX-448:
---------------------------------------

The attached patch is a proposal for one way to modify our launcher to make it easier for people to create custom launchers. The main gist is that I have separated the auto-property processing into a separate AutoActivator class that can be used by others to process the auto-properties when creating their own launchers.

It is reasonably straightforward with the intention of trying to balance keeping things simple to avoid bloat while still making it reusable.

> Try to modify auto-property processing in Main to make it easier for people to re-use
> -------------------------------------------------------------------------------------
>
>                 Key: FELIX-448
>                 URL: https://issues.apache.org/jira/browse/FELIX-448
>             Project: Felix
>          Issue Type: Improvement
>          Components: Framework
>            Reporter: Richard S. Hall
>            Priority: Minor
>         Attachments: FELIX-448.patch
>
>
> Since we have moved auto-property processing out of the framework, people creating custom launchers must now handle automatically installing/starting bundles themselves. Perhaps we could modify the default launcher to better separate out this functionality so that it can be directly re-used in other custom launcher. Also, we need to update the embedding & launching documentation.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


[jira] Closed: (FELIX-448) Try to modify auto-property processing in Main to make it easier for people to re-use

Posted by "Richard S. Hall (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/FELIX-448?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Richard S. Hall closed FELIX-448.
---------------------------------

    Resolution: Fixed
      Assignee: Richard S. Hall

I have committed the patch. The patch was modified for readability and also to remove some duplicated code.

> Try to modify auto-property processing in Main to make it easier for people to re-use
> -------------------------------------------------------------------------------------
>
>                 Key: FELIX-448
>                 URL: https://issues.apache.org/jira/browse/FELIX-448
>             Project: Felix
>          Issue Type: Improvement
>          Components: Framework
>            Reporter: Richard S. Hall
>            Assignee: Richard S. Hall
>            Priority: Minor
>         Attachments: FELIX-448.patch
>
>
> Since we have moved auto-property processing out of the framework, people creating custom launchers must now handle automatically installing/starting bundles themselves. Perhaps we could modify the default launcher to better separate out this functionality so that it can be directly re-used in other custom launcher. Also, we need to update the embedding & launching documentation.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.