You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@flink.apache.org by "Martijn Visser (Jira)" <ji...@apache.org> on 2026/10/21 17:15:00 UTC

[jira] [Created] (FLINK-41071) Upgrade Testcontainers to 1.21.4 in the Cassandra connector to support Docker 29

Martijn Visser created FLINK-41071:
--------------------------------------

             Summary: Upgrade Testcontainers to 1.21.4 in the Cassandra connector to support Docker 29
                 Key: FLINK-41071
                 URL: https://issues.apache.org/jira/browse/FLINK-41071
             Project: Flink
          Issue Type: Bug
          Components: Connectors / Cassandra
            Reporter: Martijn Visser
            Assignee: Martijn Visser


The Cassandra connector uses Testcontainers 1.20.2, which talks to Docker with API version 1.32. Docker 29 dropped support for API versions below 1.40, so every ITCase fails before a container starts:

{code}
Caused by: com.github.dockerjava.api.exception.BadRequestException: Status 400: {"message":"client version 1.32 is too old. Minimum supported API version is 1.40, please upgrade your client to a newer version"}
{code}

The current GitHub runner image still has Docker 28.0.4, but ubuntu-latest moves to Ubuntu 26 from October 19, 2026. We should upgrade to Testcontainers 1.21.4, like the Kafka and MongoDB connectors did.



--
This message was sent by Atlassian Jira
(v8.20.10#820010)