You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@hbase.apache.org by "Chia-Ping Tsai (JIRA)" <ji...@apache.org> on 2017/03/19 13:38:41 UTC

[jira] [Comment Edited] (HBASE-15583) Discuss mutable vs immutable HTableDescriptor

    [ https://issues.apache.org/jira/browse/HBASE-15583?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15931688#comment-15931688 ] 

Chia-Ping Tsai edited comment on HBASE-15583 at 3/19/17 1:38 PM:
-----------------------------------------------------------------

The immutable HTableDescriptor (UnmodifyableHTableDescriptor) is broken. It should override the setValue(final Bytes key, final Bytes value) and remove(Bytes key), but it doesn't. We should fix it, or just get rid of it.


was (Author: chia7712):
The immutable HTableDescriptor (UnmodifyableHTableDescriptor) is broken. It should override the setValue(final Bytes key, final Bytes value), remove(Bytes key), but it doesn't. We should fix it, or just get rid of it.

> Discuss mutable vs immutable HTableDescriptor
> ---------------------------------------------
>
>                 Key: HBASE-15583
>                 URL: https://issues.apache.org/jira/browse/HBASE-15583
>             Project: HBase
>          Issue Type: Sub-task
>    Affects Versions: 2.0.0
>            Reporter: Gabor Liptak
>            Priority: Minor
>              Labels: beginner
>             Fix For: 2.0.0
>
>
> From [~enis] in https://issues.apache.org/jira/browse/HBASE-15505:
>     PS Should UnmodifyableHTableDescriptor be renamed to UnmodifiableHTableDescriptor?
> It should be named ImmutableHTableDescriptor to be consistent with collections naming. Let's do this as a subtask of the parent jira, not here. Thinking about it though, why would we return an Immutable HTD in HTable.getTableDescriptor() versus a mutable HTD in Admin.getTableDescriptor(). It does not make sense. Should we just get rid of the Immutable ones?
> We also have UnmodifyableHRegionInfo which is not used at the moment it seems. 



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)