You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@polaris.apache.org by "MonkeyCanCode (via GitHub)" <gi...@apache.org> on 2026/10/12 05:02:58 UTC
[PR] [Fix] Update dependency python to 3.15 [polaris]
MonkeyCanCode opened a new pull request, #5764:
URL: https://github.com/apache/polaris/pull/5764
<!--
๐ Describe what changes you're proposing, especially breaking or user-facing changes.
๐ See https://github.com/apache/polaris/blob/main/CONTRIBUTING.md for more.
-->
Fix PR for https://github.com/apache/polaris/pull/5758/changes.
## Checklist
- [ ] ๐ก๏ธ Don't disclose security issues! (contact security@apache.org)
- [ ] ๐ Clearly explained why the changes are needed, or linked related issues: Fixes #
- [ ] ๐งช Added/updated tests with good coverage, or manually tested (and explained how)
- [ ] ๐ก Added comments for complex logic
- [ ] ๐งพ Updated `CHANGELOG.md` (if needed)
- [ ] ๐ Updated documentation in `site/content/in-dev/unreleased` (if needed)
--
This is an automated message from the Apache Git Service.
To respond to the message, please log on to GitHub and use the
URL above to go to the specific comment.
To unsubscribe, e-mail: issues-unsubscribe@polaris.apache.org
For queries about this service, please contact Infrastructure at:
users@infra.apache.org
Re: [PR] [Fix] Update dependency python to 3.15 [polaris]
Posted by "Copilot (via GitHub)" <gi...@apache.org>.
Copilot commented on code in PR #5764:
URL: https://github.com/apache/polaris/pull/5764#discussion_r4244819116
##########
client/python/pyproject.toml:
##########
@@ -22,7 +22,7 @@ name = "apache-polaris"
version = "1.9.0"
description = "Apache Polaris"
authors = [{ name = "Apache Software Foundation", email = "dev@polaris.apache.org" }]
-requires-python = ">=3.11,<3.15"
+requires-python = ">=3.11,<4.0"
Review Comment:
The stated change adds Python 3.15 support, but this metadata also advertises compatibility with every future Python 3.x release (including untested 3.16+). The CI matrix only validates through 3.15, so please use an upper bound of `<3.16` and regenerate `uv.lock`, unless broad future-version support is an explicit part of this PR.
##########
.github/workflows/ci.yml:
##########
@@ -557,7 +557,7 @@ jobs:
distribution: 'temurin'
- uses: actions/setup-python@5fda3b95a4ea91299a34e894583c3862153e4b97 # v7.0.0
with:
- python-version: '3.14'
+ python-version: '3.15'
Review Comment:
This job now validates the guide tests with Python 3.15, but `site/content/guides/_index.md:55-56` still says that 3.14 is the validated version, and `site/it/README.md:45` lists 3.14 as the requirement. Please update the documentation to reflect what CI validates, or retain 3.14 here.
--
This is an automated message from the Apache Git Service.
To respond to the message, please log on to GitHub and use the
URL above to go to the specific comment.
To unsubscribe, e-mail: issues-unsubscribe@polaris.apache.org
For queries about this service, please contact Infrastructure at:
users@infra.apache.org
Re: [PR] [Fix] Update dependency python to 3.15 [polaris]
Posted by "jbonofre (via GitHub)" <gi...@apache.org>.
jbonofre merged PR #5764:
URL: https://github.com/apache/polaris/pull/5764
--
This is an automated message from the Apache Git Service.
To respond to the message, please log on to GitHub and use the
URL above to go to the specific comment.
To unsubscribe, e-mail: issues-unsubscribe@polaris.apache.org
For queries about this service, please contact Infrastructure at:
users@infra.apache.org
Re: [PR] [Fix] Update dependency python to 3.15 [polaris]
Posted by "MonkeyCanCode (via GitHub)" <gi...@apache.org>.
MonkeyCanCode commented on code in PR #5764:
URL: https://github.com/apache/polaris/pull/5764#discussion_r4244948484
##########
.github/workflows/ci.yml:
##########
@@ -557,7 +557,7 @@ jobs:
distribution: 'temurin'
- uses: actions/setup-python@5fda3b95a4ea91299a34e894583c3862153e4b97 # v7.0.0
with:
- python-version: '3.14'
+ python-version: '3.15'
Review Comment:
Updated doc to state this will work with Python 3.11 or later instead. For CI, this is only tested with latest python ATM, thus updated to 3.15).
--
This is an automated message from the Apache Git Service.
To respond to the message, please log on to GitHub and use the
URL above to go to the specific comment.
To unsubscribe, e-mail: issues-unsubscribe@polaris.apache.org
For queries about this service, please contact Infrastructure at:
users@infra.apache.org