You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@kafka.apache.org by "Kowshik Prakasam (Jira)" <ji...@apache.org> on 2020/10/21 18:40:00 UTC

[jira] [Created] (KAFKA-10623) Refactor code to avoid discovery conflicts for classes:{Supported|Finalized}VersionRange

Kowshik Prakasam created KAFKA-10623:
----------------------------------------

             Summary: Refactor code to avoid discovery conflicts for classes:{Supported|Finalized}VersionRange
                 Key: KAFKA-10623
                 URL: https://issues.apache.org/jira/browse/KAFKA-10623
             Project: Kafka
          Issue Type: Sub-task
            Reporter: Kowshik Prakasam


This Jira suggests changing few existing class names to avoid class discovery conflicts. Particularly the following classes:
{code:java}
org.apache.kafka.clients.admin.{Supported|Finalized}VersionRange{code}
conflict with

 

 
{code:java}
org.apache.kafka.common.feature.{Supported|Finalized}VersionRange{code}
The former is internal facing, while the latter is external facing (since it is used in the Admin#describeFeatures API). So, the internal facing classes can be renamed suitably. Possible alternative naming suggestions:

 

 
{code:java}
org.apache.kafka.clients.admin.{Supported|Finalized}Versions
{code}
{code:java}
org.apache.kafka.clients.admin.Broker{Supported|Finalized}Versions
{code}
{code:java}
org.apache.kafka.clients.admin.Broker{Supported|Finalized}VersionRange{code}
 



--
This message was sent by Atlassian Jira
(v8.3.4#803005)