You are viewing a plain text version of this content. The canonical link for it is here.
Posted to jira@kafka.apache.org by "João Pedro Fonseca (Jira)" <ji...@apache.org> on 2024/11/21 23:11:00 UTC

[jira] [Assigned] (KAFKA-12844) KIP-740 follow up: clean up TaskId

     [ https://issues.apache.org/jira/browse/KAFKA-12844?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

João Pedro Fonseca reassigned KAFKA-12844:
------------------------------------------

    Assignee: João Pedro Fonseca  (was: loboxu)

> KIP-740 follow up: clean up TaskId
> ----------------------------------
>
>                 Key: KAFKA-12844
>                 URL: https://issues.apache.org/jira/browse/KAFKA-12844
>             Project: Kafka
>          Issue Type: Task
>          Components: streams
>            Reporter: A. Sophie Blee-Goldman
>            Assignee: João Pedro Fonseca
>            Priority: Blocker
>             Fix For: 4.0.0
>
>
> See [KIP-740|https://cwiki.apache.org/confluence/pages/viewpage.action?pageId=181306557] – for the TaskId class, we need to remove the following deprecated APIs:
>  # The public partition and topicGroupId fields should be "removed", ie made private (can also now rename topicGroupId to subtopology to match the getter)
>  # The two #readFrom and two #writeTo methods can be removed (they have already been converted to internal utility methods we now use instead, so just remove them)



--
This message was sent by Atlassian Jira
(v8.20.10#820010)