You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@maven.apache.org by "Mark Dodgson (Jira)" <ji...@apache.org> on 2024/09/01 18:54:00 UTC

[jira] [Updated] (MRESOLVER-600) Implement RFC9457

     [ https://issues.apache.org/jira/browse/MRESOLVER-600?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Mark Dodgson updated MRESOLVER-600:
-----------------------------------
    Description: 
HTTP1.1 [RFC 9112|https://www.rfc-editor.org/rfc/rfc9112.html#name-status-line] section 4 defines the response status code to optionally include a text description (human readable) of the reason for the status code.
There is an additional [RFC9457|https://www.rfc-editor.org/rfc/rfc9457] which makes use of the body to inform of a reason for the error response allowing for easier investigation.
h2. Why is this important

[RFC9113|https://www.rfc-editor.org/rfc/rfc9113] is the HTTP2 protocol standard and the response status only considers the [status code|https://www.rfc-editor.org/rfc/rfc9113#name-response-pseudo-header-fiel] and not the reason phrase, as such important information can be lost in helping the client determine a route cause of a failure.

  was:
HTTP1.1 [RFC7230|https://www.rfc-editor.org/rfc/rfc7230#section-3.1.2] section 3.1.2 defines the response status code to optionally include a text description (human readable) of the reason for the status code. A more detailed RFC is [RFC2616|https://www.w3.org/Protocols/rfc2616/rfc2616-sec6.html]
There is an additional [RFC9457|https://www.rfc-editor.org/rfc/rfc9457] which makes use of the body to inform of a reason for the error response allowing for easier investigation.
h2. Why is this important

[RFC9113|https://datatracker.ietf.org/doc/html/rfc9113] is the HTTP2 protocol standard and the response status only considers the [status code|https://www.rfc-editor.org/rfc/rfc9113#name-response-pseudo-header-fiel] and not the reason phrase, as such important information can be lost in helping the client determine a route cause of a failure.


> Implement RFC9457
> -----------------
>
>                 Key: MRESOLVER-600
>                 URL: https://issues.apache.org/jira/browse/MRESOLVER-600
>             Project: Maven Resolver
>          Issue Type: New Feature
>          Components: Resolver
>            Reporter: Mark Dodgson
>            Priority: Minor
>
> HTTP1.1 [RFC 9112|https://www.rfc-editor.org/rfc/rfc9112.html#name-status-line] section 4 defines the response status code to optionally include a text description (human readable) of the reason for the status code.
> There is an additional [RFC9457|https://www.rfc-editor.org/rfc/rfc9457] which makes use of the body to inform of a reason for the error response allowing for easier investigation.
> h2. Why is this important
> [RFC9113|https://www.rfc-editor.org/rfc/rfc9113] is the HTTP2 protocol standard and the response status only considers the [status code|https://www.rfc-editor.org/rfc/rfc9113#name-response-pseudo-header-fiel] and not the reason phrase, as such important information can be lost in helping the client determine a route cause of a failure.



--
This message was sent by Atlassian Jira
(v8.20.10#820010)