You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@avro.apache.org by "Ismaël Mejía (JIRA)" <ji...@apache.org> on 2019/01/28 20:52:00 UTC

[jira] [Assigned] (AVRO-2309) Conversions.java - Use JDK Array Manipulations

     [ https://issues.apache.org/jira/browse/AVRO-2309?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Ismaël Mejía reassigned AVRO-2309:
----------------------------------

    Assignee: BELUGA BEHR

> Conversions.java - Use JDK Array Manipulations
> ----------------------------------------------
>
>                 Key: AVRO-2309
>                 URL: https://issues.apache.org/jira/browse/AVRO-2309
>             Project: Apache Avro
>          Issue Type: Improvement
>            Reporter: BELUGA BEHR
>            Assignee: BELUGA BEHR
>            Priority: Trivial
>
> {code:java|title=Conversions.java}
>       for (int i = 0; i < bytes.length; i += 1) {
>         if (i < offset) {
>           bytes[i] = fillByte;
>         } else {
>           bytes[i] = unscaled[i - offset];
>         }
>       }
> {code}
> Improve readability with {{Arrays.fill}} method to fill the first {{offset}} bytes and then copy over the remaining.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)