You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@hc.apache.org by "Hendy Irawan (JIRA)" <ji...@apache.org> on 2013/09/13 06:00:52 UTC

[jira] [Created] (HTTPCORE-349) HttpResponse should implement Closeable

Hendy Irawan created HTTPCORE-349:
-------------------------------------

             Summary: HttpResponse should implement Closeable
                 Key: HTTPCORE-349
                 URL: https://issues.apache.org/jira/browse/HTTPCORE-349
             Project: HttpComponents HttpCore
          Issue Type: Improvement
          Components: HttpCore
    Affects Versions: 4.3
            Reporter: Hendy Irawan


Currently we've got code like this:

{code}
final HttpResponse response = client.execute(postReq);
try {
	final StatusLine responseStatus = response.getStatusLine();
	final String responseBody;
	if (response.getEntity() != null)
		responseBody = IOUtils.toString(response.getEntity().getContent());
	else
		responseBody = null;
	if (responseStatus.getStatusCode() >= 200 && responseStatus.getStatusCode() < 300) {
		log.info("Job returned {}: {}", responseStatus, responseBody);
	} else
		log.error("Job returned {}: {}", responseStatus, responseBody);
} finally {
	HttpClientUtils.closeQuietly(response);
}
{code}

It would be great if this could be simplified to : (in Java 7)

{code}
try (final HttpResponse response = client.execute(postReq)) { 
    ...
}
{code}

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@hc.apache.org
For additional commands, e-mail: dev-help@hc.apache.org